Trying to get rcp going...

Unanswered Question
Feb 2nd, 2009

On another thread I complained about a 2501 with IOS 12.3(24) that won't permit me to make the IOS image available for tftp transfers. While that issue awaits resolution (or surrender), I am trying to transfer via rcp; which is brand new to me. First I familiarized myself with rsh and finally got it working, with Router-E (8MB Flash, IOS 12.0) as the server and Router-A (16MB Flash, IOS 12.2) the client[IOS 12.2 image already backed up in multiple locations]. Then I tried copying with the copy rcp flash command on Router A, and it was a dud.

<br />

<br />Here's the config of Router-E:

<br />=====================================

<br />Current configuration:

<br />!

<br />version 12.0

<br />service timestamps debug uptime

<br />service timestamps log uptime

<br />no service password-encryption

<br />!

<br />hostname Sethtek-E

<br />!

<br />enable secret xxx

<br />!

<br />username xochi password 0 xxxxxx

<br />ip subnet-zero

<br />ip rcmd rcp-enable

<br />ip rcmd rsh-enable

<br />ip rcmd remote-host stuey 10.50.50.1 snuffy

<br />no ip domain-lookup

<br />!

<br />!

<br />!

<br />interface Loopback0

<br /> ip address 222.1.5.1 255.255.255.0

<br /> no ip directed-broadcast

<br />!

<br />interface Ethernet0

<br /> ip address 10.50.50.5 255.255.255.0

<br /> no ip directed-broadcast

<br />!

<br />interface Serial0

<br /> ip address 215.0.0.5 255.255.255.252

<br /> no ip directed-broadcast

<br /> encapsulation ppp

<br /> clockrate 56000

<br />!

<br />interface Serial1

<br /> ip address 215.0.0.5 255.255.255.252

<br /> no ip directed-broadcast

<br /> encapsulation ppp

<br />!

<br />interface TokenRing0

<br /> ip address 10.4.4.5 255.255.255.0

<br /> no ip directed-broadcast

<br /> ring-speed 16

<br />!

<br />router ospf 10

<br /> network 10.4.4.0 0.0.0.255 area 0

<br /> network 222.1.5.0 0.0.0.255 area 0

<br />!

<br />ip classless

<br />!

<br />banner exec ^C

<br />

<br />Welcome to Seth's 2513

<br />^C

<br />banner motd ^C

<br />This here is Seth's 2513 router in Seth's CCNP Lab

<br />^C

<br />!

<br />line con 0

<br /> transport input none

<br />line aux 0

<br />line vty 0 4

<br /> password grover

<br /> login

<br />!

<br />end

<br />=====================================

<br />

<br />The image filename on E is "c2500-i-l.120-8.bin"

<br />

<br />so I try copy rcp flash and I get this:

<br />

<br />=====================================

<br />Router-A#copy rcp flash

<br /> **** NOTICE ****

<br />Flash load helper v1.0

<br />This process will accept the copy options and then terminate

<br />the current system image to use the ROM based image for the copy.

<br />Routing functionality will not be available during that time.

<br />If you are logged in via telnet, this connection will terminate.

<br />Users with console access can see the results of the copy operation.

<br /> ---- ******** ----

<br />[There are active users logged into the system]

<br />Proceed? [confirm]y

<br />Address or name of remote host []? 10.50.50.5

<br />Source username [snuffy]?

<br />Source filename []? c2500-i-l.120-8.bin

<br />Destination filename [c2500-i-l.120-8.bin]?

<br />The returned username is snuffy(3FFC4C)

<br />Accessing rcp:[email protected]/c2500-i-l.120-8.bin...

<br />%Error opening rcp:[email protected]/c2500-i-l.120-8.bin (Permission denied)

<br />Router-A#

<br />=====================================

<br />

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
CriscoSystems Mon, 02/02/2009 - 16:52

So when I tried it with "stuey" as the source username, I get this:

=====================================

Proceed? [confirm]y

Address or name of remote host [10.50.50.5]?

Source username [stuey]?

Source filename [flash:c2500-i-l.120-8.bin]?

Destination filename [flash:c2500-i-l.120-8.bin]?

The returned username is snuffy(3FFC4C)

%Flash Load Helper does not support embedded usernames. The configured (or

default) username 'snuffy' will be used instead.

Accessing rcp:[email protected]/flash:c2500-i-l.120-8.bin...

%Error opening rcp:[email protected]/flash:c2500-i-l.120-8.bin (No such file o)

Router-A#

=====================================

Which, is strange that it would say no such file because there quite bloody is such a file; it's the only friggin' file there IS in the flash memory on the remote device...

So, am I doing something wrong here, configuration or execution-wise?

Joe Clarke Mon, 02/02/2009 - 17:52

You're lacking a username configuration for stuey. Try adding:

username stuey password 0 stuey

Also, add:

ip rcmd remote-host stuey 10.50.50.1 snuffy enable

Then, from the host 10.50.50.1, username snuffy is allowed to use rcp.

CriscoSystems Wed, 02/04/2009 - 16:44

Ain't it crazymaking? All this remote-usernames and local usernames and local logins versus sent usernames....I am ready to pull my hair out over here.

See when I have the

ip rcmd remote-host stuey 10.50.50.1 snuffy

command configured, then from a remote device I can do

rsh 10.50.50.1 /user stuey show flash

successfully, as long as I'm logged in as snuffy on the remote device. I BELIEVED that if I configured

ip rcmd remote-username snuffy

that I would then be permitted to do rsh on 10.50.50.1 without having to log in as snuffy. I have been proven wrong about that. So what is the purpose of the ip rcmd remote-username command? Where does that value get inserted?

Joe Clarke Wed, 02/04/2009 - 16:53

This command is used for client connections (i.e. when specifying copy rcp://... from the command line).

CriscoSystems Thu, 02/05/2009 - 14:39

I must say I am still confused. Even throwing away my confusion about the remote-username command. When I have the

ip rcmd remote-host stuey 10.50.50.1 snuffy

command configured, then when I'm logged in as snuffy on 10.50.50.1 I am allowed to execute rsh commands, as long as I use stuey as the /user value. This is WITHOUT configuring a username for stuey on the 10.50.50.1 host.

But rcp requires that one be configured, while rsh does not?

Or am I __stilllll__ confused about the local-user vs. remote-user busines....

Joe Clarke Thu, 02/05/2009 - 20:35

I remembered incorrectly. A local username on the device is not required. However, the "enable" keyword is required for rcp since you need to be enabled to access flash. So you will need to change the command to:

ip rcmd remote-host stuey 10.50.50.1 snuffy enable

Actions

This Discussion