Problem line protocol with 28xx NM-16ESW

Answered Question
Feb 3rd, 2009
User Badges:

Hello,


I have a problem with a 2851 router connected to Microwave device. Line protocol goes up and down continuously on all interfaces. Microwave has 4 Ethernet connections plugged on a NM-16ESW of the router such as:


Fa1/1 on NM-16ESW <-> Ethernet1 of microwave

Fa1/2 on NM-16ESW <-> Ethernet2 of microwave

Fa1/3 on NM-16ESW <-> Ethernet3 of microwave

Fa1/4 on NM-16ESW <-> Ethernet4 of microwave


We have made Factory Acceptance Test before deployment where all was working well.


We tried all combination of speed (100M or Auto) and Duplex (Full or Auto) but problem still occurred.


We found a workaround (but non sustainable) by inserting a switch (3560) between Microwave and router: One link between router and switch, and the 4 Ethernet connection of Microwave on the switch.


The same problem occurred on a 2821.


Thank you for your assistance!


Best regards


Florian



Correct Answer by ogor about 8 years 5 months ago

do you have PoE on these module ?

try to desactivate the poe with power inline never command


Olivier

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
paolo bevilacqua Tue, 02/03/2009 - 02:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Try disabling keepalives under vlan 100.

flabarriere Tue, 02/03/2009 - 02:56
User Badges:

Please find below the configuration of Vlan100 :


interface Vlan100

ip address 10.52.38.252 255.255.255.192

standby 100 ip 10.52.38.254

standby 100 priority 110

standby 100 preempt


paolo bevilacqua Tue, 02/03/2009 - 03:17
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You would then add "no keeepalives" under it.

flabarriere Tue, 02/03/2009 - 05:32
User Badges:

I could not add the command "no keepalive" under interface vlan 100. So I type the command for the 4 interfaces :


interface FastEthernet1/1

description *** Sectorielle 1 ***

switchport access vlan 100

duplex full

speed 100

no keepalive

spanning-tree portfast

!

interface FastEthernet1/2

description *** Sectorielle 2 ***

switchport access vlan 100

duplex full

speed 100

no keepalive

spanning-tree portfast

!

interface FastEthernet1/3

description *** Sectorielle 3 ***

switchport access vlan 100

duplex full

speed 100

no keepalive

spanning-tree portfast

!

interface FastEthernet1/4

description *** Sectorielle 4 ***

switchport access vlan 100

duplex full

speed 100

no keepalive

spanning-tree portfast

We made another test by plugin only port Fa1/3 but the problem is still there :


Ro-vlau-gir-1#ter mon

*Feb 3 13:25:59.852: %LINK-3-UPDOWN: Interface FastEthernet1/3, changed state to up

*Feb 3 13:26:00.852: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to up

Ro-vlau-gir-1#

*Feb 3 13:26:12.064: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to down

Ro-vlau-gir-1#

*Feb 3 13:26:13.068: %LINK-3-UPDOWN: Interface FastEthernet1/3, changed state to up

*Feb 3 13:26:14.068: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to up

Ro-vlau-gir-1#

*Feb 3 13:26:18.636: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to down

*Feb 3 13:26:19.648: %LINK-3-UPDOWN: Interface FastEthernet1/3, changed state to up

Ro-vlau-gir-1#

*Feb 3 13:26:20.648: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to up

Ro-vlau-gir-1#

*Feb 3 13:26:23.336: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to down

Ro-vlau-gir-1#

*Feb 3 13:26:24.340: %LINK-3-UPDOWN: Interface FastEthernet1/3, changed state to up

*Feb 3 13:26:25.340: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to up

Ro-vlau-gir-1#

*Feb 3 13:26:29.820: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to down

Ro-vlau-gir-1#

*Feb 3 13:26:30.840: %LINK-3-UPDOWN: Interface FastEthernet1/3, changed state to up

*Feb 3 13:26:31.840: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to up

Ro-vlau-gir-1#

*Feb 3 13:26:34.608: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to down

Ro-vlau-gir-1#

*Feb 3 13:26:35.616: %LINK-3-UPDOWN: Interface FastEthernet1/3, changed state to up

*Feb 3 13:26:36.616: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to up

Ro-vlau-gir-1#

*Feb 3 13:26:40.908: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to down

Ro-vlau-gir-1#

Ro-vlau-gir-1#

*Feb 3 13:26:41.916: %LINK-3-UPDOWN: Interface FastEthernet1/3, changed state to up

*Feb 3 13:26:42.916: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to up

Ro-vlau-gir-1#

*Feb 3 13:26:45.884: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/3, changed state to down


And so on.

paolo bevilacqua Tue, 02/03/2009 - 05:37
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Sorry, I wouldn't know what to suggest. Seems a sort of incompatibility, but not sure of which kind exactly.

ogor Tue, 02/03/2009 - 05:39
User Badges:

try to implement :

switchport mode access

Correct Answer
ogor Tue, 02/03/2009 - 06:35
User Badges:

do you have PoE on these module ?

try to desactivate the poe with power inline never command


Olivier

flabarriere Tue, 02/03/2009 - 06:47
User Badges:

I don't think PoE is available in the NM-16ESW. For PoE that's NM-16ESW-PWR card.

Here is the output of "show inventory" command :


NAME: "16 Port 10BaseT/100BaseTX EtherSwitch", DESCR: "16 Port 10BaseT/100BaseTX EtherSwitch"

PID: NM-16ESW , VID: V01 , SN: FOC122349FD


But I will try the "power inline never" command.

ogor Tue, 02/03/2009 - 06:52
User Badges:

Ok, but I see that (check the last ref) :


Ro-vlau-gir-1#sh inv

NAME: "2851 chassis", DESCR: "2851 chassis"

PID: CISCO2851 , VID: V04 , SN: FHK1225F5DU


NAME: "VWIC2-2MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1", DESCR: "VWIC2-2

MFT-T1/E1 - 2-Port RJ-48 Multiflex Trunk - T1/E1"

PID: VWIC2-2MFT-T1/E1 , VID: V01 , SN: FOC1223617Y


NAME: "PVDMII DSP SIMM with four DSPs", DESCR: "PVDMII DSP SIMM with four DSPs"

PID: PVDM2-64 , VID: V01 , SN: FOC12244ZCP


NAME: "PVDMII DSP SIMM with four DSPs", DESCR: "PVDMII DSP SIMM with four DSPs"

PID: PVDM2-64 , VID: V01 , SN: FOC1224505N


NAME: "16 Port 10BaseT/100BaseTX EtherSwitch", DESCR: "16 Port 10BaseT/100BaseTX

EtherSwitch"

PID: NM-16ESW , VID: V01 , SN: FOC122349FD


NAME: "Power daughter card for 16 port EtherSwitch NM", DESCR: "Power daughter c

ard for 16 port EtherSwitch NM"


PID: PPWR-DCARD-16ESW , VID: V01 , SN: FOC121924RQ



Ro-vlau-gir-1#

paolo bevilacqua Tue, 02/03/2009 - 07:03
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Where do you see that? OP never posted complete output of "show inventory".


Also, PoE requires the PoE PS, that is only seen with "show environment".

flabarriere Tue, 02/03/2009 - 07:20
User Badges:

please find below the "show environment" result :


Ro-vlau-gir-1#sh environment


Main Power Supply is AC with -48V

-48V supply status: OK

-48V relay status: NON-ISOLATED


Fan 1 OK

Fan 2 OK

Fan 3 OK


System Temperature: 25 Celsius (normal)


Environmental information last updated 00:00:02 ago


paolo bevilacqua Tue, 02/03/2009 - 07:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

So you have a full PoE router and the "power inline newer" recommendation does make sense.

Actions

This Discussion