UC520 Call Quality

Unanswered Question
Feb 3rd, 2009
User Badges:

Hi


We have a UC520 with 4 FXO ports and have just started using the system. The LAN call quality is good but external call are very tinny and one caller said they thought we were "at the bottom of a well"


I saw one post suggesting we change from u-law to a-law but another saying that didnt apply for FXO


Can anyone please advise on what needs to be fine tuned (PS - previous analogue PBX call quality was very good)


Here is the Voice Port 0/1/0


Foreign Exchange Office 0/1/0 Slot is 0, Sub-unit is 1, Port is 0

Type of VoicePort is FXO

Operation State is DORMANT

Administrative State is UP

The Last Interface Down Failure Cause is Administrative Shutdown

Description is Configured by CCA 4 FXO-0/1/0-Custom

Noise Regeneration is enabled

Non Linear Processing is enabled

Non Linear Mute is disabled

Non Linear Threshold is -21 dB

Music On Hold Threshold is Set to -38 dBm

In Gain is Set to 0 dB

Out Attenuation is Set to 3 dB

Echo Cancellation is enabled

Echo Cancellation NLP mute is disabled

Echo Cancellation NLP threshold is -21 dB

Echo Cancel Coverage is set to 64 ms

Echo Cancel worst case ERL is set to 6 dB

Playout-delay Mode is set to adaptive

Playout-delay Nominal is set to 60 ms

Playout-delay Maximum is set to 1000 ms

Playout-delay Minimum mode is set to default, value 40 ms

Playout-delay Fax is set to 300 ms

Connection Mode is plar opx

Connection Number is 305

Initial Time Out is set to 10 s

Interdigit Time Out is set to 10 s

Call Disconnect Time Out is set to 60 s

Ringing Time Out is set to 180 s

Wait Release Time Out is set to 30 s

Companding Type is u-law

Region Tone is set for GB


Analog Info Follows:

Currently processing none

Maintenance Mode Set to None (not in mtc mode)

Number of signaling protocol errors are 0

Impedance is set to complex2 Ohm

Station name None, Station number None


Caller ID Info Follows:

Standard ETSI

DSP is pre-allocated

Translation profile (Incoming):

Translation profile (Outgoing):


Voice card specific Info Follows:

Signal Type is loopStart

Battery-Reversal with Answer Supervision is enabled

Number Of Rings is set to 1

Supervisory Disconnect is dualtone pre-connect

Answer Supervision is inactive

Hook Status is On Hook

Ring Detect Status is inactive

Ring Ground Status is inactive

Tip Ground Status is inactive

Dial Out Type is dtmf

Digit Duration Timing is set to 100 ms

InterDigit Duration Timing is set to 100 ms

Pulse Rate Timing is set to 10 pulses/second

InterDigit Pulse Duration Timing is set to 750 ms

Percent Break of Pulse is 65 percent

GuardOut timer is 2000 ms

Minimum ring duration timer is 125 ms

Hookflash-in Timing is set to 600 ms

Hookflash-out Timing is set to 400 ms

Supervisory Disconnect Timing (loopStart only) is set to 350 ms

OPX Ring Wait Timing is set to 6000 ms



Thanks in advance


Paul

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Tue, 02/03/2009 - 17:47
User Badges:
  • Red, 2250 points or more

Hi Paul,


Nothing particularly exciting on the voice port configuration here. You may try taking the DSP preallocate off and see if that makes a difference. It's hard to tell what configuration you have on the voice port from this command. You can start by taking all changes off the voice port and see if that helps.


Other things you can try:

-Different telephone wire

-Different port on the UC520

-"test voice port 0/1/0 thl-sweep" for the optimal impedance value

-'show proc cpu hist' make sure your CPU is fine

-'show call active voice brief | i lost' during the call for lost packets

-Confirm your latency is less than 150 ms (on a UC520 I highly doubt it is more than 150)

-Replace UC520 with analog phone, see if problem persists



hth,

nick

mparra.fusionet Tue, 02/03/2009 - 22:41
User Badges:

Hello Paul,


Yep changing the compand type from ulaw to alaw would only help if this was a BRI line out of the US.


Could you please attach a "sh run" just to have a quick look, we could try enable the

echo canceler, but I would like to see first what we have configured under the voice ports.


Thanks


- Manny

warpsystems Wed, 02/04/2009 - 03:58
User Badges:

Hi


I ran the impedance test and it recommended Complex6, so we have changed to that - bt no discernable improvement.


Have also tried different port / cables, without joy


Have attached the file, hope its the correct details


Thanks


Paul




Actions

This Discussion