cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1443
Views
0
Helpful
4
Replies

IPv6 Tunnel (Automatic IPv4-Compatible Mode)

enriquebs
Level 1
Level 1

Hi

I'm setting up this type of tunnels but I can't find any good source of information about how to do it. As far as I know we need a routing protocol that provides you with the next hop in order to reach the IPv6 netwotk, for example BGP, but in my topology it is going to be easier, just 3 routers connected to a switch.

I have an IPv6 loopback in each of them and ethernet connections using IPv4 addressing, here are the configs:

/////////R1/////////

interface Tunnel0

no ip address

no ip redirects

ipv6 ospf 1 area 0

tunnel source Ethernet0/0

tunnel mode ipv6ip auto-tunnel

!

interface Loopback50

no ip address

ipv6 address 2001:1:1:1::1/64

ipv6 ospf 1 area 0

!

interface Ethernet0/0

ip address 10.0.0.1 255.255.255.0

half-duplex

router ospf 100

log-adjacency-changes

network 10.0.0.1 0.0.0.0 area 0

/////////R2/////////

interface Tunnel0

no ip address

no ip redirects

ipv6 ospf 1 area 0

tunnel source Ethernet0/0

tunnel mode ipv6ip auto-tunnel

!

interface Loopback50

no ip address

ipv6 address 2001:2:2:2::2/64

ipv6 ospf 1 area 0

!

interface Ethernet0/0

ip address 10.0.0.2 255.255.255.0

half-duplex

router ospf 100

log-adjacency-changes

network 10.0.0.2 0.0.0.0 area 0

/////////R3/////////

interface Tunnel0

no ip address

no ip redirects

ipv6 ospf 1 area 0

tunnel source Ethernet0/0

tunnel mode ipv6ip auto-tunnel

!

interface Loopback50

no ip address

ipv6 address 2001:3:3:3::3/64

ipv6 ospf 1 area 0

!

interface Ethernet0/0

ip address 10.0.0.3 255.255.255.0

half-duplex

!

router ospf 100

log-adjacency-changes

network 10.0.0.3 0.0.0.0 area 0

!

I'm doing something wrong but don't know what...

any idea?

thanks!

4 Replies 4

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Enrique,

the tunnel needs to have an IPv4 destination for sure:

you want to tunnel ipv6 packets inside ipv4 packets.

specify as tunnel destination the ipv4 address of the remote end

then you should also provide an ipv6 address to the tunnel to make it a logical interface that can connect two IPv6 clouds

see

http://www.cisco.com/en/US/docs/ios/ipv6/configuration/guide/ip6-tunnel.html#wp1055738')">http://www.cisco.com/en/US/docs/ios/ipv6/configuration/guide/ip6-tunnel.html#wp1055738

to use the tunnel you can run a routing protocol for IPv6 or use static routes

Hope to help

Giuseppe

Hi Giuseppe,

Thanks for your response, but I think you are refering to manual tunnels (point to point). In this kind of tunnel (point to multipoint) the destination addresss of the tunnel is created automatically based on a next hop address converted from IPv4 to IPv6. All documentation I have found use MP-BGP because this protocol is able to pass the next hop address in this format ::1.2.3.4 making the address IPv4 compatible. Maybe it can't be done with OSPF...

thanks!

Hello Enrique,

just a few lines down in the same config guide shows that an ipv6 address is to be configured also for automatic tunnel 6to4

What is not needed is an ipv4 destination and you are right on this.

see

http://www.cisco.com/en/US/docs/ios/ipv6/configuration/guide/ip6-tunnel.html#wp1055738

Hope to help

Giuseppe

OK

You are right, I misunderstood what you meant. So, according to this we need statics or MP-BGP, right?

thnaks!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card