BGP ,EIGRP route tuning .

Unanswered Question
Feb 4th, 2009

Hi friends,

<br /><br />Could any one guide me for configuring the devices shown in the dia.

<br /><br />I need to configure the following things

<br /><br />

<br /><br />1.Need to run EIGRP between all the 4 devices,

<br /><br />2.Need to publish 50 & 51 segments on Router R1

<br /><br />3. Need ot publish 52,23,&54 segments on router R2

<br /><br />if Telco 1 fails all the segments should publish on Router R2,

<br /><br />IF Teclo 2 fails all the segments should publish on router R1

<br />

<br />current configuration:

<br />configured bgp with telco1 & 2,its working fine.

<br />eigrp running, but unable to form neighbourship with router 1 and router 2 .

<br />configured default static route on switches (0.0.0.0 0.0.0.0 1.1.1.1 on switch 1 and 0.0.0.0 0.0.0.0 1.1.2.1 on switch 2)

<br />configured route-map with prefix list for allowing above said segment route advatisement to the respective telcos ( used as-perpend ).

<br />M

<br /><br />

<br /><br />Thanks in advance

<br /><br />

<br /><br />rm

<br /><br />

<br /><br />

<br /><br />1) Diagram.JPG - Diagram.bmp

<br /><br />

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Wed, 02/04/2009 - 04:48

Hello Raahi,

first of all you need to be able to have EIGRP neighborships between R1,R2 and SW1,SW2.

to build a successful neighborship you need:

to use the same EIGRP AS number 123 on all devices.

to have a network command that includes the ip subnet used on link R1,SW1 and R2,Sw2 on both sides.

you can check this with

sh ip eigrp interfaces

sh ip eigrp neighbors

for the BGP part:

MED cannot pass via a third party provider the same happens for local preference.

you can use selective AS path prepending on R1 and R2 to make R1 more attractive for segments 50,51 and R2 more attractive for segments 52,53

redundancy is provided by the protocol

router on left side need to have an iBGP session to compare the routes they receive via the two different providers.

Some tuning on left site may be needed later for example using local preference to enforce the desired routing policies.

Hope to help

Giuseppe

passioncas Wed, 02/04/2009 - 04:58

Hello Rahi.

Is the link between the Switches S1 and S2 layer 3 or layer 2? Hope its a layer 3 as you said u have to enable EIGRP over all the 4 Devices(R1,R2.S1 and S2)..In that scenario ,how EIGRP neighbor ship will form between R1 and R2?

please get me the segments network address to be published on R1 and R2

regards

Rahul

maahiraahi Wed, 02/04/2009 - 21:02

few quires.

first we will finish eigrp.

i am Unable to build eigrp relationship between two routers as these ipaddress is in diffrent segments.

can i conntect two routers with cable and assign /30 ip , and add in eigrp network command ?

or changing any one router ip address will do ?

configuration of eigrp on all the 4 devices is as below,

router eigrp 101

redistribute connected

redistribute static

redistribute bgp 123

network 1.0.0.0

default-metric 2000 10000 255 1 1500

no auto-summary

no eigrp log-neighbor-changes

passioncas Wed, 02/04/2009 - 21:10

Hi

yes...the neighborship will be formed

To build EIGRP neighbor ship the neighbors should be directly connected and should be in the same network.

I have a few queries

1.Should EIGRP enabled on all devices (R1,R2,S1 and S2)

2.Have you configured iBGP between R1 and R2

Please share the network address to be published to external network

Regards

Rahul

maahiraahi Wed, 02/04/2009 - 21:55

eigrp enable on all the devices.

ibgp is configured between 2 routers also.

regards

rm

passioncas Wed, 02/04/2009 - 22:00

Hi friend,

Then R forms EIGRP neigborship with S1,S1 forms neighborship with R1 and S2,S2 froms neighborship with R2 and S1 and R2 forms neighborship with only S2 as R1 and R2 are not directly connected.(assume that Routed Port has been configured for Router to Swicth and Switch to Switch connectivity)

To get more clarification ,kindly share the configuration of all devices, if possible\

Regards

Rahul

maahiraahi Wed, 02/04/2009 - 22:07

eigrp conf on routers,

router eigrp 101

redistribute connected

redistribute static

redistribute bgp 123

network 1.0.0.0

default-metric 2000 10000 255 1 1500

no auto-summary

no eigrp log-neighbor-changes

Eigrp conf on switches,

S2:

router eigrp 101

redistribute connected

redistribute static

network 1.0.0.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 1.1.2.1

S1:

router eigrp 101

redistribute connected

redistribute static

network 1.0.0.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 1.1.1.1

passioncas Wed, 02/04/2009 - 22:11

Hi ,

Required all the configuration ,not only EIGRP Config

regards

Rahul

maahiraahi Wed, 02/04/2009 - 22:48

configuration as below,

Router 2:

router eigrp 101

redistribute connected

redistribute static

redistribute bgp 123

network 1.0.0.0

default-metric 2000 10000 255 1 1500

no auto-summary

no eigrp log-neighbor-changes

router bgp 123

bgp log-neighbor-changes

neighbor x.x.x.x remote-as 123

neighbor x.x.x.x remote-as xxxx- telco2 as

neighbor x.x.x.x ebgp-multihop 5

neighbor x.x.x.x update-source Loopback2

!

address-family ipv4

redistribute connected

redistribute static

neighbor 1.1.1.1 activate

neighbor 1.1.1.1 next-hop-self

neighbor x.x.x.x activate

neighbor x.x.x.x soft-reconfiguration inbound

neighbor x.x.x.x route-map telco2_out out

no auto-summary

no synchronization

network 1.1.1.0 mask 255.255.255.0

network 1.1.2.0 mask 255.255.255.0

network 1.1.50.0 mask 255.255.255.0

network 1.1.51.0 mask 255.255.255.0

network 1.1.52.0 mask 255.255.255.0

network 1.1.53.0 mask 255.255.255.0

network 1.1.54.0 mask 255.255.255.0

aggregate-address 1.1.0.0 255.255.0.0

ip prefix-list r2_traffic seq 1 permit 1.1.2.0/24

ip prefix-list r2_traffic seq 2 permit 1.1.50.0/24

ip prefix-list r2_traffic seq 3 permit 1.1.51.0/24

ip prefix-list r2_traffic seq 4 permit 1.1.52.0/24

!

ip prefix-list r1_traffic seq 1 permit 1.1.1.0/24

ip prefix-list r1_traffic seq 2 permit 1.1.53.0/24

ip prefix-list r1_traffic seq 3 permit 1.1.54.0/24

route-map telco2_out permit 10

match ip address prefix-list r1_traffic

set as-path prepend 123 123

!

route-map telco2_out permit 20

match ip address prefix-list r2_traffic

Router 1:

router eigrp 101

redistribute connected

redistribute static

redistribute bgp 123

network 1.0.0.0

default-metric 2000 10000 255 1 1500

no auto-summary

no eigrp log-neighbor-changes

router bgp 123

bgp log-neighbor-changes

neighbor x.x.x.x remote-as 123

neighbor x.x.x.x remote-as xxxx- telco1 as

neighbor x.x.x.x ebgp-multihop 5

neighbor x.x.x.x update-source Loopback2

!

address-family ipv4

redistribute connected

redistribute static

neighbor 1.1.2.1 activate

neighbor 1.1.2.1 next-hop-self

neighbor x.x.x.x activate

neighbor x.x.x.x soft-reconfiguration inbound

neighbor x.x.x.x route-map telco1_out out

no auto-summary

synchronization

network 1.1.1.0 mask 255.255.255.0

network 1.1.2.0 mask 255.255.255.0

network 1.1.50.0 mask 255.255.255.0

network 1.1.51.0 mask 255.255.255.0

network 1.1.52.0 mask 255.255.255.0

network 1.1.53.0 mask 255.255.255.0

network 1.1.54.0 mask 255.255.255.0

ip prefix-list r2_traffic seq 1 permit 1.1.2.0/24

ip prefix-list r2_traffic seq 2 permit 1.1.50.0/24

ip prefix-list r2_traffic seq 3 permit 1.1.51.0/24

ip prefix-list r2_traffic seq 4 permit 1.1.52.0/24

!

ip prefix-list r1_traffic seq 1 permit 1.1.1.0/24

ip prefix-list r1_traffic seq 2 permit 1.1.53.0/24

ip prefix-list r1_traffic seq 3 permit 1.1.54.0/24

route-map telco1_out permit 10

match ip address prefix-list r2_traffic

set as-path prepend 123 123

!

route-map telco1_out permit 20

match ip address prefix-list r1_traffic

S2:

router eigrp 101

redistribute connected

redistribute static

network 1.0.0.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 1.1.2.1

S1:

router eigrp 101

redistribute connected

redistribute static

network 1.0.0.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 1.1.1.1

passioncas Wed, 02/04/2009 - 22:52

Hi ..

Is the link between the Router and Switch Layer 3 or Layer 2?

Is the link between the the Switches Layer 3 or Layer 2?

meanwhile I will go through configuration and let you know the changes has to be done..

Regards

Rahul

maahiraahi Wed, 02/04/2009 - 23:10

Dear Rahul ,

Switches are L3 & connected by cable. not l3 link.

The problem i facing is

1.unable to form eigrp relation ship with routers. rechability is done through static route on both the swithces.(now both eigrp and static is running)

2. on router 2 external routes from our organization network are unable to add in routing table(think due to aggregate command & finding RIB errors on received routes). best route to external network (in side the organization)is through router1 execpt for the locations connected only through TELCO2.

Kindly guide me.

Regards

rm

passioncas Thu, 02/05/2009 - 00:42

Hi Rm,

Please go through the below config

R1

---------------------

Router Eigrp 101

Network 1.0.0.0

Router bgp 123

neighbor remote-as 250 ###As per the digram (eBGP)

bgp log-neighbor-changes

neighbor [External_peer] soft-reconfiguration inbound

neighbor prefix-list Defrt in ##Accept default Route only)

neighbor [External_peer] route-map Telco_1 out ##AS_Path prepend

neighbor [External_peer] update-source [loopback 2]

neighbor [External_peer] ebgp-multihop 5

neighbor [internal_peer] remote-as 121 ###iBGP with R2

neighbor [internal_peer] next-hop-self

network 1.1.1.0 mask 255.255.255.0

network 1.1.2.0 mask 255.255.255.0

network 1.1.53.0 mask 255.255.254.0

network 1.1.50.0 mask 255.255.255.0

network 1.1.51.0 mask 255.255.255.0

network 1.1.52.0 mask 255.255.255.0

ip prefix-list r2_traffic seq 1 permit 1.1.2.0/24

ip prefix-list r2_traffic seq 2 permit 1.1.50.0/24

ip prefix-list r2_traffic seq 3 permit 1.1.51.0/24

ip prefix-list r2_traffic seq 4 permit 1.1.52.0/24

ip prefix-list r1_traffic seq 1 permit 1.1.1.0/24

ip prefix-list r1_traffic seq 2 permit 1.1.53.0/23

Ip prefix-list Defrt seq 5 permit 0.0.0.0/0

route-map telco1_out permit 10

match ip address prefix-list r2_traffic

set as-path prepend 123 123

route-map telco1_out permit 20

R2

-------------------

---------------------

Router Eigrp 101

Network 1.0.0.0

Router bgp 123

neighbor remote-as 300 ###As per the digram (eBGP)

bgp log-neighbor-changes

neighbor [External_peer] soft-reconfiguration inbound

neighbor prefix-list Defrt in ##Accept default Route only)

neighbor [External_peer] route-map Telco_2 out ##AS_Path prepend

neighbor [External_peer] update-source [loopback 2]

neighbor [External_peer] ebgp-multihop 5

neighbor [internal_peer] remote-as 121 ###iBGP with R2

neighbor [internal_peer] next-hop-self

network 1.1.1.0 mask 255.255.255.0

network 1.1.2.0 mask 255.255.255.0

network 1.1.53.0 mask 255.255.254.0

network 1.1.50.0 mask 255.255.255.0

network 1.1.51.0 mask 255.255.255.0

network 1.1.52.0 mask 255.255.255.0

ip prefix-list r2_traffic seq 1 permit 1.1.2.0/24

ip prefix-list r2_traffic seq 2 permit 1.1.50.0/24

ip prefix-list r2_traffic seq 3 permit 1.1.51.0/24

ip prefix-list r2_traffic seq 4 permit 1.1.52.0/24

ip prefix-list r1_traffic seq 1 permit 1.1.1.0/24

ip prefix-list r1_traffic seq 2 permit 1.1.53.0/23

Ip prefix-list Defrt seq 5 permit 0.0.0.0/0

route-map telco1_out permit 10

match ip address prefix-list r1_traffic

set as-path prepend 123 123

route-map telco1_out permit 20

S1

-----------------

router eigrp 101

network 1.0.0.0

network 2.0.0.0

redistribute static meric [BW] [Delay] [reliabilty] [load] [MTU]

exit

ip route x.x.x.x mask x.x.x.x For internal network (2.0,1.0,53.0...)

ip route 0.0.0.0 0.0.0.0 1.1.1.1

s2

-------------------------------

router eigrp 101

network 1.0.0.0

network 2.0.0.0

redistribute static meric [BW] [Delay] [reliabilty] [load] [MTU]

exit

ip route x.x.x.x mask x.x.x.x For internal network (2.0,1.0,53.0...)

ip route 0.0.0.0 0.0.0.0 1.1.2.1

----------------------------------------

To get a lear picture please share the diagram with all Interface IP address, including loop back...

And also share me the following output

1.Show ip bg summary

2.sh ip bgp

3.show ip bgp neighbors

Regards

Rahul

Regards

Rahul

Actions

This Discussion