CUPC not able to connect to Presence

Unanswered Question
Feb 4th, 2009
User Badges:

Hi there,


We used to use CUCM 6.x and CUPS 6.x butI've rebuilt our CUPS server as version 7, and we are now using CUCM 7.


I've got everything working apart from the Presence side of things, where the Presence client Server Health under the CUPC client is red, and not able to connect (Retrying). All other connections are green.


I can't see anything wrong on the CUPS server from the troubleshooter, and I have reviewd most/all of the CUPS posts on here regarding this issue.


Thing's i've done to try and resolve the issue:


- Applied an "ALL" incoming ACL

- Set the Proxy domain to "nowcomm.local"

- Reset everything

- Tried multiple PC's in the office to figure out if firewalls were causing the problem, but all have the same problem


When we ran CUPS 6.x everything seemed to work fine with these settings, so i'm a bit lost now as to what else I can try to do!


Any suggestions welcome. Thanks,


Mike.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (4 ratings)
Loading.
Tommer Catlin Wed, 02/04/2009 - 08:27
User Badges:
  • Green, 3000 points or more

On your CUPS server and also your Pub/Sub, have you added in the correct DNS and domain name to the servers?


You can do this from CLI of each server:


Set network domain (enter domain name)

you will need to reboot the machines.


if this is not in here, typically, the SIP Publish trunk will not work on Pub/Sub correctly. And on CUPS, it can not resolve names correctly.

nowcommsupport Wed, 02/04/2009 - 08:35
User Badges:

Hmm yes I thought it might be something to do with it - we're not using DNS at all on any of the servers, and i've renamed the hostid's to be just IP addresses.


I'm not ruling this out, but it used to work with 6.x !

Tommer Catlin Wed, 02/04/2009 - 08:39
User Badges:
  • Green, 3000 points or more

Right.. it used to work with 6, but not with 7x I have found. I changed everything to IPs and it did not work for me. I opened a tac case, added in my DNS, and domain names to the pub/sub/cups and it started working.


Also, if you are trying to see yourself as presence, it does not work. If open up your client, add in your own name, this hoses the presence state completely.

nowcommsupport Wed, 02/04/2009 - 08:44
User Badges:

Good point, i'd best remove myself! Thanks for that one...


Just sorting the DNS details now, thanks for the input!

Tommer Catlin Wed, 02/04/2009 - 09:02
User Badges:
  • Green, 3000 points or more

I spent hours trying to figure out why my presence would not change. Finally I figured out or TAC, cant remember which, we removed my name from my own client and magically it started working. It's like it was looping itself for presence and never worked. So for testing, make sure you have (2) clients up and running to really test that it works. One client is not a good test.


Good luck!

htluo Wed, 02/04/2009 - 09:32
User Badges:
  • Red, 2250 points or more

What version is your CUPC? 1.2.x or 7.0.x?


Usually we see this behavior on different version of CUPC instead of CUPS.


Workflow has been changed on CUPC 7.0.x. It'll try to use the node_name+proxy_domain to connect to presence.


For more detailed information, please see:


http://htluo.blogspot.com/2009/01/how-does-cupc-deterine-presence-address.html


Michael

nowcommsupport Wed, 02/04/2009 - 09:54
User Badges:

Ok I'm using CUPC 7.x


I've added DNS records to our AD server, and then enabled the DNS servers on the CUCM Publisher (We dont have Subs), and on the CUPS server. I then rebooted both boxes.


I can successfully enter now-d-cups or now-d-cm-pub into my browser and it resolves correctly.


Presence still isnt working however. Thanks for your post Michael, I had a read of your blog. Below is the text from the Presence server health window:


Presence.Domain=nowcomm.local

Presence.MostRecentListenPort=50027

Presenc.Primary.Address=now-d-cups

Presence.Primary.Port=5060

Presence.Primary.Protocol=TCP

Presence.username=mgerrard


Users in the contacts list originally appear as [email protected] before resolving to the proper display name.


Mike.



htluo Wed, 02/04/2009 - 10:47
User Badges:
  • Red, 2250 points or more

From your CUPC computer, can you ping now-d-cups.nowcomm.local? This is the address CUPC tried to connect.


Michael

nowcommsupport Thu, 02/05/2009 - 03:21
User Badges:

Hi Michael, yes I can no problems.


The plot thickens...


I found that under licensing, none of the units were being used! Some of the services under service parameters had "Inactive" next to them, but a quick visit to Serviceability told me that the services were activated and running (the troublshooter also says the same). i had to fully deactivate services one at a time, and reactivate them to get the services to go active properly, and to use the licenses from the pool. Definitely something screwy going on!


So..


I'm now able to see that Presence has gone "green" in the client's troubleshooter, but still no Presence information. One other slight oddity is that adding a user to the contacts list, doesn't appear until I close the program completely and re-enter it.


Mike.

htluo Thu, 02/05/2009 - 05:53
User Badges:
  • Red, 2250 points or more

This is called "Notification Issue". In English - "status didn't update until next logon".


Usually, it's firewall or VPN related. The best way to verify is to do sniffer capture on client and server side.


Michael

nowcommsupport Thu, 02/05/2009 - 09:21
User Badges:

No firewall involved - just inter-vlan routing.


Although all the services are now green, including presence, we still get no presence information in the CUP client :(


CSS, DNS, all check out ok.


Any more ideas anyone?

htluo Thu, 02/05/2009 - 10:13
User Badges:
  • Red, 2250 points or more

The idea already given :)


"The best way to verify is to do sniffer capture on client and server side".


That's the ultimate way to tell if it's network related or not. (and easiest way)

nowcommsupport Fri, 02/06/2009 - 02:24
User Badges:

I should be able to set this up today, and i'll post the results after i've had a look.


Have you any other suggestions though Michael? We're running inter Vlan routing (So no firewalls) and I have disabled all firewalls on my PC, including uninstalling VPN client. The thing is though that it used to work with CUPS 6.x with VPN client installed (Though my Windows firewall has always been disabled). The server has been rebuilt, but has the same IP address so routing etc to the box should be the same.

Johann Aicher Fri, 02/06/2009 - 04:06
User Badges:

I've had the same problems here and we went back to CUPS 6.0(4).


Cisco has released CUPS 7.0(3) yesterday but there is no Readme for it now on the Cisco Site but all other new documents.


Reg.

Johann

htluo Fri, 02/06/2009 - 06:01
User Badges:
  • Red, 2250 points or more

Even if you're not running Cisco VPN Client, the service is still running in background.


Stop the service to test CUPC just in case.


Michael

Tommer Catlin Fri, 02/06/2009 - 07:58
User Badges:
  • Green, 3000 points or more

Can you post a screen shot of your SIP Security profile and your SIP Trunk on CUCM?


Also did you enable the CUPS Service in CUCM Services from False to True?

Vinicius Ramos Thu, 05/14/2009 - 14:32
User Badges:

I'm with the same problem. The CUPC is not receiving the Presence IP Address from (?) the Presence Server (???).


I don't understand. I go to "Show Server Health" and the Presence is with an error: "None server configured".

chadlincoln Thu, 05/14/2009 - 14:50
User Badges:
  • Bronze, 100 points or more

Go to Application, CUPC, Proxy profile. Select the proxy/presence server. Make sure the user is associated there.


Please rate if this helped.

Actions

This Discussion