Management Station to Device SSH failed in LMS 2.6

Unanswered Question
Feb 4th, 2009
User Badges:

I recently upgraded IOS on Catalyst 2960 to support SSH v2. I ran "Management Station to Device" for SSH from the Device Center and it failed. From packet capture, it shows "Server Protocol: SSH-2-Cisco1.25". Does this mean that SSH within CiscoWorks LMS 2.6 only support SSH v1? How can I resolve this problem? Thank you in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Wed, 02/04/2009 - 09:50
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

I filed a bug against Management Station Device for SSH. The timeout specified is being treated as milliseconds instead of seconds. Try multiplying your timeout by 1000, and see if it works.

Joe Clarke Wed, 02/04/2009 - 10:14
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Ah, looks like the timeout was added in LMS 3.0. The code in LMS uses a static timeout. However, looking at the code, SSHv2 is explicitly not supported in LMS 2.6. The code looks to see that the device replies with SSH-1.5 or SSH-1.99. If the device replies with pure SSHv2 (i.e. SSH-2.0), then the code throws an unsupported version error.


In any event, a better way to test connectivity in any version of LMS is to use RME's Device Credential Verification feature. Go to RME > Devices > Device Management > Device Credential Verification Jobs, and create a new job to test SSH. RME does support SSHv2.

lemontgomery Wed, 04/15/2009 - 14:01
User Badges:

sorry are there any patches or updates for 2.6 to support sshv2.



Joe Clarke Wed, 04/15/2009 - 15:07
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please start a new thread for this question.

Actions

This Discussion