cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
560
Views
0
Helpful
3
Replies

trunk to a router's f/e port

Aaron Greene
Level 1
Level 1

I have a switch that connects to a 2800's f/e port. The switches port is configured to trunk only vlan 2. There is also an SVI on the switch for vlan 2. However, the router port only does layer 3 and the SVI needs to be routed across the WAN. How can I trunk vlan 2 from the switch to the router and keep the router's port layer3.

Here is the 2800's port:

interface FastEthernet0/1

ip vrf forwarding VRF10

ip address 10.33.10.17 255.255.255.240

ip helper-address 10.10.33.10

duplex auto

speed auto

vlan-id dot1q 2

exit-vlan-config

The last command I added, vlan-id dot1q 2 is a shot in the dark...not sure if that works...anybody know?

Here is the switch:

interface Vlan2

ip address 10.33.10.18 255.255.255.240

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 2

switchport mode trunk

2 Accepted Solutions

Accepted Solutions

Mark Yeates
Level 7
Level 7

On the 2800's FE port you will need to create a sub interface on for vlan 2. Here is an example below.

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.30

description Data VLAN

encapsulation dot1Q 30

ip address 10.0.30.1 255.255.255.0

!

interface FastEthernet0/0.40

description Voice VLAN

encapsulation dot1Q 40

ip address 10.0.40.1 255.255.255.0

HTH,

Mark

View solution in original post

Aaron

The suggestion by Mark is good if you need the connection from the switch to the router to be a trunk - especially if there are multiple VLANs to transport.

But your original post specifies that only a single VLAN is supposed to go over that link. In this case there are a couple of alternatives to consider:

- you would not need to configure the router interface with subinterfaces if you leave the switch port as a trunk and configure VLAN 2 as the native VLAN on the switch. Frames for the native VLAN are sent untagged (they are just normal Ethernet frames) which the router interface should recognize and be able to process.

- if only a single VLAN is transported I question why the switch port should be a trunk. To transport only VLAN 2 traffic you could just make the switch port an access port in VLAN 2. In this case the router interface would just be a standard FastEthernet interface configuration and there is no consideration of trunking.

HTH

Rick

HTH

Rick

View solution in original post

3 Replies 3

Mark Yeates
Level 7
Level 7

On the 2800's FE port you will need to create a sub interface on for vlan 2. Here is an example below.

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.30

description Data VLAN

encapsulation dot1Q 30

ip address 10.0.30.1 255.255.255.0

!

interface FastEthernet0/0.40

description Voice VLAN

encapsulation dot1Q 40

ip address 10.0.40.1 255.255.255.0

HTH,

Mark

Aaron

The suggestion by Mark is good if you need the connection from the switch to the router to be a trunk - especially if there are multiple VLANs to transport.

But your original post specifies that only a single VLAN is supposed to go over that link. In this case there are a couple of alternatives to consider:

- you would not need to configure the router interface with subinterfaces if you leave the switch port as a trunk and configure VLAN 2 as the native VLAN on the switch. Frames for the native VLAN are sent untagged (they are just normal Ethernet frames) which the router interface should recognize and be able to process.

- if only a single VLAN is transported I question why the switch port should be a trunk. To transport only VLAN 2 traffic you could just make the switch port an access port in VLAN 2. In this case the router interface would just be a standard FastEthernet interface configuration and there is no consideration of trunking.

HTH

Rick

HTH

Rick

Aaron

I am glad that our responses were helpful in resolving your question. Thank you for using the rating system to indicate that your question was resolved (and thanks for the rating). It makes the forum more useful when people can read a question and can know that there were responses which did lead to resolving the question.

The forum is an excellent place to learn about Cisco networking. I encourage you to continue your participation in the forum.

HTH

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card