Problem with NAT.

Unanswered Question
Feb 4th, 2009

I have a problem in a router c2811.

This router has an Isdn access to a central site using a Bri interface (wic-1b-s/t-v3).

The router has the following IOS: c2800nm-spservicesk9-mz.123-8.T8.bin.

This same router has an Internet access using an Adsl interface and at same time has an Isdn access to a customer, a client. Behind this router I have a firewall, an ASA5520.

The configuration can be seen in one file attached to this.

The problem is like this,

In the ASA, the traffic that goes to the outside is nated with the ip address of the outside interface.

In the router, the traffic that goes to the internet are not nated, but the traffic to the customer has to be nated (the client asked to be like this) with the ip address of the Isdn connection.

If I make a connection test (a “ping”) to the client internal network, from the ASA. I have no success. But if I do the same test in the router (with source in the internal interface of the router) I have success.

What I can see is that the packets are coming from the ASA and are going to the router internal interface. In the router they are nated and then are sent to the bri interface.

They are then sanded to the client internal network.

The replay to the “ping” is then sanded to my router (c2811), and I can still see this coming to my Bri interface.

The traffic, I mean, the destination ip address of the traffic is then translated to the ip address of the outside interface of the ASA…

This last thing should be happening, but it's not.

Almost the times I don't succeed in “pinging” the internal network of the client.

What I have in the ASA is:

ping outside 10.10.10.4 repeat 15

Type escape sequence to abort.

Sending 15, 100-byte ICMP Echos to 10.10.10.4, timeout is 2 seconds:

???!???????????

Success rate is 6 percent (1/15), round-trip min/avg/max = 310/310/310 ms

In the router I have this:

*Feb 3 22:58:13.044: %SEC-6-IPACCESSLOGDP: list 113 permitted icmp 10.10.10.4 -> 172.172.172.70 (0/0), 12 packets

*Feb 3 22:58:13.044: %SEC-6-IPACCESSLOGDP: list 114 permitted icmp 172.172.172.70 -> 10.10.10.4 (8/0), 15 packets

*Feb 3 22:58:13.044: %SEC-6-IPACCESSLOGDP: list 115 permitted icmp 10.10.10.4 -> 195.195.195.59 (0/0), 1 packet

In the ASA I have this routing:

route outside 0.0.0.0 0.0.0.0 195.195.195.57 1

route outside 172.172.172.98 255.255.255.255 195.195.195.57 1

Can some one help me?

I can not antherstand what is appening.

Thanks in advance,

Rui

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion