Help undestanding QoS config

Unanswered Question
Feb 4th, 2009
User Badges:

Hi,


I got the config of CE router of one my provider and I want to undestand QoS is doing and the statement on g0/1 "max-reserved-bandwith 85" makes any difference or not.


Here is the config:


!

class-map match-all BH

description Bursty-High

match any

class-map match-any ROUTING

match ip dscp cs6

match ip dscp cs7

match access-group 199

!

!

policy-map CE-PE-CHILD

description CE Egress Policy Map faced to PE

class ROUTING

police cir 16000 bc 8000 be 8000

conform-action set-dscp-transmit cs6

exceed-action set-dscp-transmit cs6

class BH

bandwidth 2652

random-detect dscp-based

police cir 2700000 bc 27000 be 27000

conform-action set-dscp-transmit af31

exceed-action set-dscp-transmit af32

class class-default

fair-queue

policy-map CE-PE-PARENT

class class-default

shape average 2700000 27000 0

service-policy CE-PE-CHILD

!

!

!

interface GigabitEthernet0/1

description << MPLS WAN >>

bandwidth 3000

ip address <Removed>

no ip redirects

no ip unreachables

no ip proxy-arp

load-interval 30

duplex full

speed 100

media-type rj45

no cdp enable

max-reserved-bandwidth 85

service-policy output CE-PE-PARENT

!

access-list 197 remark BL

access-list 197 permit ip any any dscp cs2

access-list 197 permit ip any any dscp 17

access-list 197 permit ip any any dscp af21

access-list 197 permit ip any any dscp 19

access-list 197 permit ip any any dscp af22

access-list 197 permit ip any any dscp 21

access-list 197 permit ip any any dscp af23

access-list 197 permit ip any any dscp 23

access-list 198 remark BH

access-list 198 permit ip any any dscp cs3

access-list 198 permit ip any any dscp 25

access-list 198 permit ip any any dscp af31

access-list 198 permit ip any any dscp 27

access-list 198 permit ip any any dscp af32

access-list 198 permit ip any any dscp 29

access-list 198 permit ip any any dscp af33

access-list 198 permit ip any any dscp 31

access-list 198 permit ip any any dscp cs6

access-list 198 permit ip any any dscp cs7

access-list 199 permit tcp any eq bgp any

access-list 199 permit tcp any any eq bgp

access-list 199 permit ospf any any



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lejoe.thomas Wed, 02/04/2009 - 19:51
User Badges:
  • Silver, 250 points or more

Hi Tayeb,


max-reserved bandwidth is used to specify how much interface bandwidth can be assigned to CBWFQ classes. By default this is 75%.

So in your case CBWFQ classes get 85% of 3000Kbps.


HTH


Lejoe

Joseph W. Doherty Thu, 02/05/2009 - 05:17
User Badges:
  • Super Bronze, 10000 points or more

As Lejoe notes, max-reserved-bandwith allows you to determine how much bandwidth CBWFQ can explictly define. However, I'm unsure how this rules interacts with a hiearchal policy, such as your example.


The parent policy doesn't define bandwidth in class-default, although its shaper defines 2.7 Mbps which is 90% of the link's 3 Mbps. Only the child policy BH class defines 2,652 Kbps, which is 98.2% of the parent shaper's 2.7 Mbps (or 88.4% of the link's 3 Mbps).


So, it appears that "max-reserved-bandwith 85" might be unnecessary for such a configuration since some of the explicit bandwidths appears to exceed it.

Actions

This Discussion