QOS 4500

Unanswered Question
Feb 4th, 2009

Is there any way to do QOS on a 4500 with a supII+ that is setup as a layer 2 device only ? Or is the only way to turn ip routing on the box . Devices like the 2960 do it , the 4500 can't ? I have read the 4500 qos docs but don't see anything for a 4500 with no routing.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Roberto Salazar Thu, 02/05/2009 - 10:25

The SupII+ is an IOS only sup and it looks like the latest support is 12.1(19)EW1. Here is a config guide on QoS and I do not see any requirement about enabling routing.

Hope that helps.

glen.grant Thu, 02/05/2009 - 11:48

We tried to configure it on a layer 4500 and it rejected it . Upon further investigation

from the qos doc we see this . We got the same error message from the switch when we tried to do this. We are running like 12.2.37Sg I think .

Note You cannot enable marking commands on an interface until IP routing is enabled globally. If IP routing is disabled globally and you try to configure the service policy on an interface, the configuration is accepted but it does not take effect. You are prompted with the message: "Set command will not take effect since CEF is disabled. Please enable IP routing and CEF globally.. " To enable IP routing globally, issue the ip routing and ip cef global configuration commands. After you do this, the marking commands take effect.

Giuseppe Larosa Thu, 02/05/2009 - 12:08

Hello Glen,

the note says that multilayer action starts only when you enable ip routing as a way to start CEF.

Before it behaves as a L2 switch only and uses only CAM table.

Modular QoS requires CEF enabled also on routers, so this last part is not a surprise (I mean that CEF needs to be enabled)

Best Regards

Giuseppe

Actions

This Discussion