QoS on NM-ESW16

Unanswered Question
Feb 5th, 2009

I have the following configuration on NM-ESW16:


interface FastEthernet0/4

switchport mode trunk

switchport priority default 6

switchport priority override

mls qos cos 6

mls qos cos override

interface FastEthernet0/0

switchport mode trunk


I have some traffic with cos=4 coming into fa0/4 and going out on fa0/0. I monitor the fa0/0 and expected to see the cos of the outgoing traffic to change to 6 on fa0/0, but it doesn't. Not matter what I do, the cos keeps the same.

I'm using IOS c3640-a3js-mz.124-23. Any idea?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Yudong Wu Thu, 02/05/2009 - 13:19

"mls qos cos 6" is to set default-CoS value to 6. Per cmd reference, "if the port is CoS trusted and packets are untagged, the default CoS value becomes the CoS value for the packet.".

liqun.yang Thu, 02/05/2009 - 13:28

I tried it for the untagged packets as well, it's the same, cos won't get change.

What's the correct way to rewrite the cos?


liqun.yang Fri, 02/06/2009 - 05:31

I tried all the possible "mls qos" commands combination which includes without override, with both tag and untag traffic, none of them makes any difference. Is it a bug?


Yudong Wu Thu, 02/05/2009 - 14:23

Re-read cmd reference, this is my understanding (I did not test it):

a) if the packet is untagged, you need enable "mls qos trust cos" so that packet will take the default-cos value you configured.

b) If the packet is tagged, you need enable "override"

By the way, did you enable "mls qos" globally? what's the output of "show mls qos int f0/4"?

liqun.yang Fri, 02/06/2009 - 05:44

For a) and b), I tried all possible "mls qos" command combinations with both tag and untag traffic, none of them make any difference.

I'm not sure how to enable "mls qos" globally on the 3600 router, because I can not just simply configure "mls qos" then enter, it has to be followed by the "map" option, so I don't think the "mls qos map" command is for globally enabling qos.

SW1(config)#mls qos ?

map qos map keyword

SW1(config)#mls qos

% Incomplete command.

Here is the output of "show mls qos int fa0/4":

SW1#show mls qos interface fastEthernet 0/4

interface fastEthernet 0/4


trust state: not trusted

trust mode: not trusted

COS override: dis

default COS: 4

pass-through: none

The line I don't understand is "pass-through: none". Does it mean the default cos does apply to pass-through traffic? If yes, how can I change it?


liqun.yang Fri, 02/06/2009 - 11:54

Thanks. Does Cisco still support NM-ESW16? or it's already EoF/EoS.

Thanks again


This Discussion