Changing Admin Distance of EIGRP

Unanswered Question
Feb 5th, 2009

Hi Guys,

I would like to change the admin distance of eigrp learned routes from the neighbor 172.20.248.3. When I am using:

distance 130 172.20.248.3 255.255.255.255

It's setting all eigrp routes to AD=130. Any thoughts how to get around with it?

switch1.bdb.qld#show ip eigrp neighbors

IP-EIGRP neighbors for process 109

H Address Interface Hold Uptime SRTT RTO Q Seq Type

(sec) (ms) Cnt Num

1 176.20.88.49 Vl24 11 00:19:16 54 324 0 883463

0 172.20.248.3 Vl406 13 00:19:17 1 200 0 1165020

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Istvan_Rabai Thu, 02/05/2009 - 22:34

Hi Shawkat,

The command is the following:

distance 130 172.20.248.3 0.0.0.0 [ACL number],

where the mask is a wildcard mask, not a normal subnet mask.

So 0.0.0.0 wildcard mask will identify the ip address of the ONE source router: 172.20.248.3

You can define the routes with the acl, for which to change the admin distance.

Cheers:

Istvan

shawkatalvi Sun, 02/08/2009 - 03:37

Thanks Istvan. I put the wild card mask incorrectly. Now the received eigrp routes are 130. But still router is preferring these eigrp AD=130 routes over RIP learned routes (AD=120), any idea why it's doing it?

Istvan_Rabai Sun, 02/08/2009 - 09:43

Hi Shawkat,

You should inspect the rip and eigrp routes more closely.

1. maybe the rip routes are not 120,

or

2. maybe the routes learned by eigrp are not learned by rip, therefore the route table process has the only choice of eigrp routes.

Cheers:

Istvan

shawkatalvi Sun, 02/08/2009 - 13:45

Hi Istvan,

RIP V2 routes are 120 for sure and they are learning the same EIGRP routes!! I am redistributing eigrp into rip like this:

router eigrp 109

redistribute static

passive-interface Vlan120

passive-interface FastEthernet0/23

network 172.20.0.0

network 176.20.0.0

distance 130 172.20.248.3 0.0.0.0

no auto-summary

!

router rip

version 2

redistribute eigrp 109 metric 2

passive-interface Vlan7

passive-interface Vlan24

passive-interface Vlan105

network 172.20.0.0

network 172.24.0.0

network 176.20.0.0

distribute-list 50 out

no auto-summary

need to investigate more.hmmm....

Istvan_Rabai Sun, 02/08/2009 - 22:55

Hi Shawkat,

You are maybe looking for the routes that are redistributed from eigrp to rip?

I should tell you that they will NOT appear in the routing table of THIS router.

These redistributed into rip routes will only appear in OTHER rip routers where THIS router advertises them (after processing them through the distribute-list 50 of course).

So the routing table process rightfully selects these routes into the routing table as eigrp routes with AD 130.

Please investigate the following:

- what are the routes learned by the rip process from any OTHER router (use "debug ip rip")

- what are the routes learned by the eigrp process from the 172.20.248.3 router (use the "show ip eigrp topology all-links")

- The same prefixes that were learned by the rip process AND the eigrp process as well should be in the routing table from the rip process, as they have AD 120.

Cheers:

Istvan

shawkatalvi Wed, 02/11/2009 - 18:44

Hi Istvan,

Thanks for your time. It's getting complicated and I can see if I continue with this approach, I will need to modify AD on few switches in between hops.

Rather is their anyway where I can modify metrics on advertising EIGRP routes through a specific interface. That way 172.20.248.3 would learn eigrp which will not be better than RIP?

Istvan_Rabai Wed, 02/11/2009 - 22:29

Hi Shawkat,

I don't know of a way of setting AD based on incoming interface.

You should look at the options of the "distance" command under the router config to see all the options there are.

Keep your config simple!

Cheers:

Istvan

Actions

This Discussion