Flex Links

Unanswered Question
Feb 6th, 2009
User Badges:
  • Bronze, 100 points or more

I am configuring FLEX LINKS in my Data Center - unless someone thinks this is a really BAD idea. (the reason is to remove spanning-tree) Our future calls for VSS but we are not ready for that now.

IOS is 12.2(33)SXI Advanced Enterprise.


My question is - can I still use vlan pruning?


Below is my data center setup.


My data center consists of multiple pairs of 6509E series switches that will act as a collapsed Access/Distribution layer.


All pairs of switches connect to the CORE via ONLY layer-3 redundant links.


IGP is EIGRP


The Access/Distribution layer pairs are joined together via two port-channels.


Port-channel 1 is 2 10-Gbps links

T1/1 and T5/5


Port-channel 2 is 4 1-Gbps links

G3/1, 4/1, G5/1 and G5/2


PC1 will be primary.

PC2 will be Secondary.


THANKS for any support.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
cdusio Fri, 02/06/2009 - 15:26
User Badges:
  • Bronze, 100 points or more

Yes you can still prune. Basically flex links are a substitute for spanning tree whereas the pruning you are speaking of refers more to trunking and is a seperate issue.

HTH

-C


fsebera Fri, 02/06/2009 - 15:52
User Badges:
  • Bronze, 100 points or more

Hey,

Thanks for the reply.


I noticed before enabling Flex Links I had pruning enabled on both Layer-2 links between the two 6500-E switches.


I have vlans 2-50 configured on both switches. VTP mode Transparent, VTP ver 1.

Vlan 50 is not assigned to any port on either switch.

With Flex Links not enabled

Show interface trunk revealed vlan 50 was being pruned.


Once I enabled FLEX LINKS, I noticed vlan 50 was now allowed on the link


show interface trunk


indicates vlan 50 is now being forwarded across the primary link (backup link shows no vlans being forwarded - as expected).


Perhaps I did something incorrect or reading the output wrong???


Frank

cdusio Sat, 02/07/2009 - 04:32
User Badges:
  • Bronze, 100 points or more

put the config in here so I can see what's doing... Specifically on the 6509 with the flex links configured.


Thanks


fsebera Mon, 02/09/2009 - 07:38
User Badges:
  • Bronze, 100 points or more

Hi C!

In my initial setup, I configured FLEXLINKS on both ends of the port-channel. I removed the config, I reloaded both switches, and configured FLEXLINKS on just one end, now is working as expected, I included the config for your review anyway.


Any thoughts?


A3#sh spanning-tree

VLAN0100

Spanning tree enabled protocol ieee

Root ID Priority 8192

Address 0021.56ee.dc64

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec


Bridge ID Priority 8192

Address 0021.56ee.dc64

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300


Interface Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Po1 Desg FWD 1 128.1665 P2p

Po2 Desg FWD 3 128.1666 P2p


A3#sh int trunk

Port Mode Encapsulation Status Native vlan

Po1 on 802.1q trunking 100

Po2 on 802.1q trunking 100


Port Vlans allowed on trunk

Po1 100-150

Po2 100-150


Port Vlans allowed and active in management domain

Po1 100

Po2 100


Port Vlans in spanning tree forwarding state and not pruned

Po1 100

Po2 100


A3#! SETUP FLEXLINKS BACKUP


A3(config)#int po1

A3(config-if)#switchport backup interface po2

A3(config-if)#

*Feb 9 09:29:50.673 EST: %SPANTREE-SP-6-PORTDEL_ALL_VLANS: Port-channel2 deleted from all Vlans

*Feb 9 09:29:50.677 EST: %SPANTREE-SP-6-PORTDEL_ALL_VLANS: Port-channel1 deleted from all Vlans


A3#sh run int po1

interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100-150

switchport trunk pruning vlan 100-150

switchport mode trunk

switchport backup interface Po2


A3#sh run int po2

interface Port-channel2

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100-150

switchport trunk pruning vlan 100-150

switchport mode trunk


A3#sh spanning-tree

No spanning tree instance exists.


A3#sh int trunk

Port Mode Encapsulation Status Native vlan

Po1 on 802.1q trunking 100

Po2 on 802.1q trunking 100


Port Vlans allowed on trunk

Po1 100-150

Po2 100-150


Port Vlans allowed and active in management domain

Po1 100

Po2 100


Port Vlans in spanning tree forwarding state and not pruned

Po1 100

Po2 none


! NOW LOOK AT LAYER-2 PEER SWITCH - in NEXT Message

fsebera Mon, 02/09/2009 - 07:39
User Badges:
  • Bronze, 100 points or more

A4#sh int trunk

Port Mode Encapsulation Status Native vlan

Po1 on 802.1q trunking 100

Po2 on 802.1q trunking 100


Port Vlans allowed on trunk

Po1 100-150

Po2 100-150


Port Vlans allowed and active in management domain

Po1 100

Po2 100


Port Vlans in spanning tree forwarding state and not pruned

Po1 100

Po2 100


A4#sh spanning-tree

VLAN0100

Spanning tree enabled protocol ieee

Root ID Priority 16384

Address 0021.56ed.bc64

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec


Bridge ID Priority 16384

Address 0021.56ed.bc64

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 15


Interface Role Sts Cost Prio.Nbr Type

------------------- ---- --- --------- -------- --------------------------------

Po1 Desg FWD 1 128.1665 P2p

Po2 Desg FWD 3 128.1666 P2p


A4#sh run int po1

interface Port-channel1

description A3 Primary

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100-150

switchport trunk pruning vlan 100-150

switchport mode trunk


A4#sh run int po2

interface Port-channel2

description A3 Secondary

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100-150

switchport trunk pruning vlan 100-150

switchport mode trunk


A4#sh run int T1/1

interface TenGigabitEthernet1/1

description A3 T1/1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100-150

switchport trunk pruning vlan 100-150

switchport mode trunk

dampening

udld port aggressive

channel-group 1 mode on


A4#sh run int T5/5

interface TenGigabitEthernet5/5

description A3 T5/5

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100-150

switchport trunk pruning vlan 100-150

switchport mode trunk

dampening

udld port aggressive

channel-group 1 mode on


A4#sh run int g8/25

interface GigabitEthernet8/25

description A3 G8/25

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100-150

switchport trunk pruning vlan 100-150

switchport mode trunk

dampening

udld port aggressive

channel-group 2 mode on


A4#sh run int g9/1

interface GigabitEthernet9/1

description A3 G9/1

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 100

switchport trunk allowed vlan 100-150

switchport trunk pruning vlan 100-150

switchport mode trunk

dampening

udld port aggressive

channel-group 2 mode on

Mohamed Sobair Sat, 02/07/2009 - 06:02
User Badges:
  • Gold, 750 points or more


What's the relation between Vlan prunning and flex-link?


Flex-link is a feature has been introduced to avoid loops in aredundant Network topology, basically configured on a redundant uplinks.


u should consider (Flex-link) when spanning-tree is not implememnted, As you know , its based on ur requirment and Network Design. The implication/limitation of Spanning-tree is the maximum diameter of 7 per STP instance. A large Scale Switching Network usually considers Flex-link instead of implementing Spanning-tree based on what described above.


HTH

Mohamed

Actions

This Discussion