Cannot go to the ready state

Unanswered Question
Feb 6th, 2009
User Badges:

getting the following error: cannot go to the ready state while the phone is out of service. other state changes are possible.

the agent extension is out of service. ready state change and call control operations cannot be performed.


running ccm 4.1(3)sr7

ipcc 4.0(3)


the two phones(7940) and are in a line group w/10 other people already. the problem started when i tried to share their lines. it worked, but now they cannot log back into their agent desktop.


so far i've disassociated the users from rmjtapi and added them back, reset the phone over ten times. factory reset.

these guys cannot take calls from the queue so any assistance would be greatly appreciated.

thank you.



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Graham Old Fri, 02/06/2009 - 12:56
User Badges:
  • Silver, 250 points or more

What do you mean by "in a line group w/10 other people" do you mean a hunt group?


Each agent must have a unique directory number, they can't share with another phone.

bbtekgraf Fri, 02/06/2009 - 13:01
User Badges:

yes a hunt group. i understand now that each agent must have a unique dn, and set the their phones back to the original status but continue to get this error message.

i've also rebooted the ipcc server.

thanks.

Graham Old Fri, 02/06/2009 - 13:27
User Badges:
  • Silver, 250 points or more

I have seen this error in the past but its so long since I worked on a V4.


You can only go ready when a phone is in the idle state. So if its ringing and you try to click ready you will get the first message.


I am sure its a CM setup issue. Check in the user setup that the primary extension and the ipcc extension are correct. Also have a look at the agents setup in users on CM and the agent setup in IPCC. Its possible it lost something with the DN changes.

bbtekgraf Fri, 02/06/2009 - 13:41
User Badges:

thank you for the reply. they've had agents for years and all this just started when i tried to share their lines this morning. unfortunately I found out after the fact that you cannot use shared lines for ccm attendant console pilot points or hunt group members.


i still need to get these sales reps where they can take calls from the queue.

going down in flames…..


the only other idea i have is to disassociate them, take them out as a resource, and start over again. reboot all the cisco servers.

resynchronize in ipcc ???? just not sure what to do.


Graham Old Fri, 02/06/2009 - 13:55
User Badges:
  • Silver, 250 points or more

If you are in a hole, create two new Agents such as agent1 and agent2 with new DN's. That should get them working. I often setup up a couple of spares. That way if they get a temp in they don't need to use an existing agent login.

bbtekgraf Fri, 02/06/2009 - 14:36
User Badges:

i'll try that.

thank you again for the reply and i will keep this updated since i've seen several post w/similar issues.

Actions

This Discussion