TFTP error on 7960...

Answered Question
Feb 6th, 2009

I am trying to setup/configure CME in a lab. It looks like everything is working (I can call between a couple 7960's and CIPC) but when the 7960 boots there is an unattractive "file not found" error on the phone. I did a 'debug tftp events' & 'debug tftp packets' and I found a couple of things:

May 18 08:07:29.056: TFTP: Looking for DISTINCTIVERINGLIST.XML

May 18 08:07:29.056: TFTP: Sending error 1 No such file

...

May 18 08:07:28.847: TFTP: Looking for RINGLIST.XML

May 18 08:07:28.847: TFTP: Sending error 1 No such file

But when I do a 'dir flash:' I see both of the files listed.

59 -rw- 2823 <no date> ringtones/DistinctiveRingList.xml

...

78 -rw- 495 <no date> ringtones/RingList.xml

Are they in the incorrect directory or something? How should I go about "fixing" this issue?

TIA

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 7 years 9 months ago

tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml

etc ...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Paolo Bevilacqua Fri, 02/06/2009 - 14:33

tftp-server flash:/ringtones/DistinctiveRingList.xml alias DistinctiveRingList.xml

etc ...

snickered Sat, 02/07/2009 - 04:52

Alright, it looks like I got rid of those errors. Now I get the same thing except with two different files:

May 18 22:57:11.962: TFTP: Looking for CTLSEP00123FDE5B09.tlv

May 18 22:57:11.962: TFTP: Sending error 1 No such file

...

May 18 22:57:19.258: TFTP: Looking for SEP0017956A7289.cnf.xml

May 18 22:57:19.258: TFTP: Sending error 1 No such file

These files aren't in flash: or system: and aren't listed in tftp-bindings. I figured these files were taken care of by 'create cnf-files'. I guess I was wrong. What should I do about these files? TIA.

Paolo Bevilacqua Sat, 02/07/2009 - 04:55

The first one is something security related and you can ignore it. The second one is the main one and must be generated when you enter the correct mac address under ephone.

snickered Sat, 02/07/2009 - 05:01

Hmmmm... I'm pretty sure I did that part right. Here's 'show run'

ephone 1

mac-address 0018.190E.48A9

button 1:1 2:4

And here's 'show ephone'

ephone-1 Mac:0018.190E.48A9 TCP socket:[1] activeLine:0 REGISTERED in SCCP ver 9 and Server in ver 8

mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0 caps:8

IP:192.168.3.71 52836 Telecaster 7960 keepalive 26 max_line 6

button 1: dn 1 number 1001 CH1 IDLE CH2 IDLE

button 2: dn 4 number 1004 CH1 IDLE CH2 IDLE shared with monitor-ring

And then after that I tried 'create cnf-files' and 'cnf-file perphone'.

Paolo Bevilacqua Sat, 02/07/2009 - 05:19

Right, but that's not the ...89 mac mentioned before.

Remember to always use type under ephone, strange things happen if you don't.

snickered Sat, 02/07/2009 - 20:12

Thanks for your help. I ended up deleting all of the ephones, turning off auto-reg and rebooting CME. Then I was able to manually add them.

viron Fri, 02/06/2009 - 14:54

The naming of files for tftp is case sensitive.

An easy way is to copy original xml files to ones with same name but using upper case characters.

It worked for me, I do not know 7960 phones request upper case ringtone files.

Regards.

MehmetKaya Thu, 10/11/2012 - 07:22

Hi All,

!

telephony-service

authentication credential admin XXXX

max-ephones 25

max-dn 40

ip source-address 11x.x.x port 2000

if the "11x.x.x port 2000" command is not correct you may faced same problem.

Thanks.

Actions

This Discussion