QoS over ADSL interface

Unanswered Question
Feb 9th, 2009
User Badges:
  • Bronze, 100 points or more

Hi guys, I have a cisco 3745 with a wic-adsl card and a IOS 12.3(26) entservices, I was wondering if it is possible to configure a QoS to prioritise the voice traffic.

Some link or example,

Thanks friends.

David

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Giuseppe Larosa Mon, 02/09/2009 - 13:24
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello David,

you can use CBWFQ with a LLQ queue (priority command) but you need to provide resources to the ATM pvc.


something like


int atmx/0

no ip address

int atmx/0.1 point-to-point

ip address x.x.x.1 255.255.255.252

pvc 8/35

cbr 200

service-policy qos out


see

http://www.cisco.com/en/US/docs/ios/12_2/12_2y/12_2yn8/feature/guide/ft_ipqos.html#wp1027859


Hope to help

Giuseppe


Joseph W. Doherty Mon, 02/09/2009 - 16:46
User Badges:
  • Super Bronze, 10000 points or more

I haven't worked with a wic-adsl card, but there's a good chance the interface would support CBWFQ (perhaps as Giuseppe notes).


One important consideration, you might need a parent policy with shaper that corresponds to the ADSL egress bandwidth, unless the card otherwise physically sends at ADSL egress bandwidth.


Something similar to:


class-map match-any VoIP

match . . . (something that matches your VoIP traffic)


policy-map ADSL_Out

class class-default

shape average # (bps available)


policy-map ADSL_Prioritize

class VoIP

priority ### (bandwidth allocated to VoIP)


interface ?

service-policy output ADSL_Out


(If the interface does transmit at egress ADSL bandwidth, you wouldn't need ADSL_Out policy's shaper.)

zenon_electronics Wed, 02/11/2009 - 03:42
User Badges:

Hi I have the same problem with QOS.

I configure priority to outgoing traffic, and it works fine. But when i start download from ftp or http, my Voice traffic is not prioritized. So I guess i have to prioritize the inbound trafic right ?

And if yes, please help with some suggestions. Thank you!

Joseph W. Doherty Wed, 02/11/2009 - 04:13
User Badges:
  • Super Bronze, 10000 points or more

For inbound, what you really want to do is apply QoS on the other side's outbound. If this is not possible, it's very difficult to effectively protect inbound VoIP. Two techniques that can be used, severely rate limit in-bound TCP traffic or shape outbound TCP ACKs. The idea being to keep TCP traffic from using all the link's bandwidth thus preserving bandwidth for VoIP.

david-lima Wed, 02/11/2009 - 16:39
User Badges:
  • Bronze, 100 points or more

Hi Joseph % Giuseppe, first thanks for your comments, I tried to apply the QoS on my ATM interface and it seems like it does not work, funny!!!

interface ATM0/0

no ip address

no atm ilmi-keepalive

dsl operating-mode auto

interface ATM0/0.1 point-to-point

description $ES_WAN$

ip address 10.X.X.222 255.255.255.252

pvc 0/35

protocol ip 10.X.X.221 broadcast

encapsulation aal5snap

service-policy output QoS-Voice-Data

But in the show runn, I cannot see this command. Do I'm missing something.

Thanks a lot guys,

David

Joseph W. Doherty Wed, 02/11/2009 - 19:07
User Badges:
  • Super Bronze, 10000 points or more

Good chance it's rejecting the policy because it doesn't "know" the bandwidth. If nothing logged on console, there might be something logged within the syslog.


Again, unsure with ADSL. On true ATM interfaces often have something like a vbr-nt under the PVC which defines the PVC's bandwidth. What also might work is a policy with a shaper.

bgroff Thu, 03/05/2009 - 12:33
User Badges:

Here is a functioning QoS policy that I have on a 2600XM running 12.4(13f)


policy-map VoiceLLQ

class VoiceTraffic

priority 256

class class-default

fair-queue 256

random-detect


interface ATM0/0

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0/0.100 point-to-point

no snmp trap link-status

pvc 0/35

ubr 512

tx-ring-limit 1

service-policy output VoiceLLQ

pppoe-client dial-pool-number 1

!

end



This config works on my SBC DSL line, and correctly prioritizes voice during upstream congestion.

Actions

This Discussion