HSRP in cisco 6500

Unanswered Question
Feb 9th, 2009

HI,

We have two cisco 6500 switch and i need to run HSRP for redunancy between the switch

but my query is since we have lot of VLAN created in primary switch how i can deploy the HSRP between them

whether i need to have different HSRP group for each VLAN

And if i connect the uplink from two catalyst to the distribution switch then whether i need to consider for STP

please suggest me

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Tshi M Mon, 02/09/2009 - 12:47

I had two 6500 series with multiple VLANs running HSRP. I had setup HSRP for each VLANs. I also used STP since you will be setting redundant links between your core switches (C6500) to the access layer switches.

vinoth.kumar Mon, 02/09/2009 - 12:50

HI

thanks for the reply

can u post me the sample config which you have deployed since iam new to HSRP and STP

Thanks in advance

Regards

Tshi M Mon, 02/09/2009 - 13:08

Here is just a sample config that i just wrote:

Core1

spanning-tree mode pvst

spanning-tree portfast bpduguard default

spanning-tree portfast bpdufilter default

spanning-tree backbonefast

spanning-tree vlan 30,40 priority 24576

!

!

interface Vlan30

ip address 10.20.30.2 255.255.255.0

ip helper-address 10.20.10.29

no ip route-cache

standby name Servers

standby 30 ip 10.20.30.1

standby 30 priority 110

standby 30 preempt

!

interface Vlan40

ip address 10.20.40.2 255.255.255.0

ip helper-address 10.20.10.29

no ip route-cache

standby name Workstations

standby 40 ip 10.20.40.1

standby 40 priority 110

standby 40 preempt

!

====================================================================================

Core 2

spanning-tree mode pvst

spanning-tree portfast bpduguard default

spanning-tree portfast bpdufilter default

spanning-tree backbonefast

spanning-tree vlan 30,40 priority 28672

!

!

interface Vlan30

ip address 10.20.30.3 255.255.255.0

ip helper-address 10.20.10.29

no ip route-cache

standby name Servers

standby 30 ip 10.20.30.1

standby 30 priority

standby 30 preempt

!

interface Vlan40

ip address 10.20.40.3 255.255.255.0

ip helper-address 10.20.10.29

no ip route-cache

standby name Workstations

standby 40 ip 10.20.40.1

standby 40 priority

standby 40 preempt

===================================================

I also used uplinkfast on the access layer switches:

spanning-tree mode pvst

spanning-tree portfast default

spanning-tree portfast bpduguard default

spanning-tree portfast bpdufilter default

spanning-tree uplinkfast

spanning-tree backbonefast

Regards,

take a look at this link as well

http://www.cisco.com/en/US/tech/tk389/tk621/technologies_configuration_example09186a008009467c.shtml

Tshi M Mon, 02/09/2009 - 14:17

Hi,

Was the above helpful in any way? Please rate as this helps the forum as well.

Regards,

vinoth.kumar Tue, 02/10/2009 - 04:31

Please find my attached setup diagram and suggest me how i can go head with the STP part

since we have planned redundancy for the server in terms of two NIC card

Regards,

Vinoth

Attachment: 

Actions

This Discussion