Accessing internal mail server ( Exchange ) through remote aceess VPN

Answered Question
Feb 10th, 2009

hi all,

I have a problem in configuring ASA 5510 to access my internal mail server ( Exchange ) through Remote access VPN

a..I configure my D-Link ADSL router to port forward the SMPTP ( 25 ) & POP3 ( 110 ) to the outside interface of ASA 5510 (

b. how can I configure ASA 5510 ( using ASDM ) to portforward ( SMTP 25 POP3 110 )to my internal mail server having IP

c. My internal LAN network ( ) is nated to for vpn clients

d. My mail server IP ( )will also be nated while the clients are accesing through Remote access VPN

e.What IP(Exchange server IP ( ) should I configure in Microsoft Outlook (incoming & outgoing mail server ),as vpn clients are getting nated IP

Below are my configuration details for Remote access vpn

: Saved

: Written by enable_15 at 13:42:51.243 UTC Thu Nov 27 2008


ASA Version 7.0(6)


hostname xxxx

domain-name xxxx

enable password xxxxx encrypted

passwd xxxxx encrypted




interface Ethernet0/0

nameif outside

security-level 0

ip address


interface Ethernet0/1

nameif inside

security-level 100

ip address


interface Ethernet0/2


no nameif

no security-level


interface Management0/0

nameif management

security-level 100


ip address


ftp mode passive

access-list inside _nat0_outbound extended permit ip any

access-list vpn standard permit any

access-list outside_cryptomap_dyn_20 extended permit ip any

ip local pool vpn-ip-pool mask

global ( outside) 10 interface

nat ( inside )0 access-list inside_nat0_outbound

nat ( inside )10

route outside D-Link ADSL Router LAN IP ) 1

group-policy vpn internal

group-policy vpn attributes

split-tunnel-policy excludespecified

split-tunnel-network-list value vpn


username xxxxx password xxxx encrypted privilege 0

username xxxxx attributes

vpn-group-policy vpn


asdm image disk0:/asdm-508.bin

no asdm history enable

arp timeout 14400

http server enable

http management

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart

crypto ipsec transform-set ESP-3DES-SHA esp-edes esp-sha-hmac

crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA

crypto map outside_map 655535 ipsec-isakmp dynamic outside_dyn_map

crypto map outside_map interface outside

isakmp enable outside

isakmp policy 10 authentication pre-share

isakmp policy 10 encryption 3des

isakmp policy 10 hash sha

isakmp policy 10 group 2

isakmp policy 10 lifetime 86400

tunnel-group vpn type ipsec-ra

tunnel-group vpn general-attributes

address-pool vpn-ip-pool

default-group-policy vpn

tunnel-group vpn ipsec-attributes

pre-shared-key *

telnet timeout 5

ssh timeout 5

console timeout 0

dhcpd address management

dhcpd lease 3600

dhcpd ping_timeout 50

dhcpd enable management


policy-map global_policy

class inspection_default

inspect dns maximum-length 512

inspect ftp

inspect h323 h225

inspect h323 ras

inspect rsh

inspect rtsp

inspect esmtp

inspect sqlnet

inspect skinny

inspect sunrpc

inspect xdmcp

inspect sip

inspect netbios

inspect tftp


service-policy global_policy global

: end

So can any one help me , how can I configure these task

I have this problem too.
0 votes
Correct Answer by Ivan Martinon about 7 years 8 months ago

You will without a problem

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Ivan Martinon Tue, 02/10/2009 - 10:09

Having your ASA to accept remote access connections saves you the trouble of needing to forward SMTP and POP ports to your exchange server, when you connect to your ASA with a vpn client logically you are directly connected to your LAN and you should be able to reach the exchange server with it's real ip address.

pranavam_dileep Wed, 02/11/2009 - 00:33

Dear imartino,

Ya, Iam able to ping my exchange server through vpn client.Is it enough for to get the mail.

but in some cisco document they are mentioning that we need to forward SMTP & POP as communication from the outside to inside is not allowed

expecting your valuable reply

Ivan Martinon Wed, 02/11/2009 - 08:14

You would need those in case you were coming via the internet without any vpn connection. In your case the fact that you are able to ping the server means that basic connectivity is possible hence by configuring your outlook to go to your exchange should be enough.

pranavam_dileep Wed, 02/11/2009 - 22:19

Dear imartino,

Now I understand, thank u , One more thing I have to clarify is that VPN clients are getting IP from a DHCP pool which is my internal network is natted to dhcp pool )

So my question is ,can I configure the smptp & pop3 server in microsoft outlook of the client machine, which is connected via remote access VPN with the IP of mail server ie.


This Discussion