c836 on a german adsl 2+ line (i have large headache) ^^

Answered Question
Feb 10th, 2009
User Badges:

Hello NetPRO Members,


General Questions (before i explain my router setup problems).


When i disable the atm0 interface i get always the message "*Mar 5 23:45:29.733: DSL: Connection has reached max retries, toggle to other mode" when i am connection over console

with the device. As long as the atm0 is not in use i dont like to get flood with that line periodically.


Any idea for this?


interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!


Is it an normal operation that the RxD and TxD LED going on/off although the atm0 interface is not active? (on atm0 is not any cable connected).


I have 2 Network scenarios:


Note: I live in germany - if somebody like to help a little bit let me know.


1. Scenario: When possible i like to use the normal atm0 from c836 device. I guess its possible but i was not able to set it up. Some People say it wont work to use the internal c836 dsl modem on a ADSL 2+ line. I know that there are some differences between adsl and adsl 2+ but isnt there a fall back option?


Afaik there should exist some compatibility between ADSL and ADSL2 / ADSL 2+ . Physically on this connection is a speed limit something round about

8726 Kbps Down and 1017 Kbps Upstream.


I prefer a stable connection (useing the internal atm0 interface) more then useing an external dsl modem (which my provider supplied. Whats your opinion?


By the way i will post now the output about dsl connectivity that i take from out from the external modem device.


Is there generally a chance to get a adsl modem (with its maximum dsl operation speed) working on ADSL 2+ ???


I tryed a couple configurations but something go always wrong. Also i cant exclude i made configurations mistakes or its simple unpossible to work.


ADSL Status

ADSL status shows the ADSL physical layer status.

ADSL Firmware Version: E.37.2.8

Line State: Showtime/Data

Modulation: ADSL2+

Local/Remote Tx Power: 1.26 dB / 0.0 dB


Item Downstream Upstream Unit

SNR Margin 8.0db 5.5db dB

Line Attenuation 29.0db 15.0db dB

Loss of Signal 0 0

CRC Errors 0 0

Data Rate 8726 Kbps 1017 Kbps kbps

Latency - -


PVC-0 , PVC-1 and PVC-2 show this:


WAN

Virtual Circuit

Connection Connected

IP Address N/A

Subnet Mask N/A

Default Gateway N/A


PVC3 show the following:


WAN

Virtual Circuit

Connection Connected

IP Address 10.100.100.2

Subnet Mask 255.255.255.0

Default Gateway 10.100.100.1


Is it normal that always only one PVC is in use? Do is change automatic?


Due a Message length is limited to 4000 characters i will post my 2. Scenario later (if possible in the same conversation).


Thanks for every help!

Correct Answer by paolo bevilacqua about 8 years 2 months ago

Please read my reply above - you have latest firmware and the modem connects OK looking at you trace.


Just configure correctly and you can eliminate the external modem.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.2 (5 ratings)
Loading.
paolo bevilacqua Tue, 02/10/2009 - 07:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

1 - configure "no logging console" if you are bother by the messages


2 - adsl only equipment may have trouble working on adsl2 lines. You need to replace router with an 856 or 876.

Giuseppe Larosa Tue, 02/10/2009 - 07:15
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello,



1) ADSL2+ is backward compatible ADL2 no so verify the line with the provider


if you have an external modem working use it



Germany ADSL implementation can be different with support for ISDN instead of simple POTS (because ISDN BRI is very wide deployed)


Hope to help

Giuseppe


mhnsitnet Tue, 02/10/2009 - 07:59
User Badges:

Here now my 2. Scenario/Option:


If there is no chance to get a connection with the integrated (only adsl) modem, then this c836 router should dial in over a external dsl modem.


ISP (Alice) <-> Adsl 2+ Modem <-> c836 Router <-> Switch (2916M-XL) <-> LAN


I am a little bit confused how to setup this correctly. I only found a german manual version. There is a "Network scenarios" page. On this page a found the tile "PPP über Ethernet mit NAT bei Verwendung einer Dial-on-Demand PPPoE-Verbindung". In English this means something like "PPP over Ethernet with NAT by useing a Dial-on-Demand PPPoE-Connection".


This Sounds very good for me. But what i not understand is - why there will be always talked about the ATM inzerface.

Thats something i dont undrstand.


I like to Config my c836 router that it should use its ATM0 (when it work) OR simple say the router that it should use a external (directly connected) dsl modem for pppoe dial in.


When i use an external dsl modem isnt the internal atm0 interface no longer needed and i an disable it,right!?

The manual make not any sense for me. If german users read this the manual link is this one:


http://www.cisco.com/en/US/docs/routers/access/800/826/software/configuration/guide/german/gnetscen.html#wp93678


Maybe somebody here can help me with a correct configuration. I tryed some different way's but as maximum i was able to get a dial in with a the external modem in use and active routes.


Anybody know a link or maybe can post me a sample configuration for a setup that i am looking for?


I am a little but unsure whether the following looks normal. A ping to wan IPs was possible, but i was not able to connect from a client to the internet.


R1#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


213.191.89.0/32 is subnetted, 1 subnets

C 213.191.89.24 is directly connected, Dialer0

78.0.0.0/32 is subnetted, 1 subnets

C 78.50.18.133 is directly connected, Dialer0

C 192.168.1.0/24 is directly connected, Ethernet0



R1#ping 213.191.89.24


Sending 5, 100-byte ICMP Echos to 213.191.89.24, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 36/40/44 ms



R1#ping 78.50.18.133


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 78.50.18.133, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 80/80/80 ms

R1#


I hope i can get this fixed soon.

paolo bevilacqua Tue, 02/10/2009 - 08:02
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Seem like you're connected ok. Have you configured NAT?


Note since it seems you're not a networking person, suggest you hire a professional for the job, you will save time and frustration.

mhnsitnet Tue, 02/10/2009 - 08:39
User Badges:

@giuslar


AFAIK it is a ADSL2+ line. But thanks for this informations. I will contact them and ask directly whether it currently a ADSL 2 or ADSL2+ line.


ISDN / POTS: I have not much know-how in deeper details. Simply because i workd not much with WAN connectivity from admin perspective. Configuration from User Side (how setup) are more or less clear for me.


@p.bevilacqua


I didnt found any way for example just to filter/ignore this DSL warning (only when i dont use atm0).


The c836 was a cheaply shot on ebay. It should be to collect some cisco experience and afaik it includeds all functions excluded an internal ADSL2+ modem. When everything work i see no reason why i should buy a new router but thanks for your informations about that.


I did some networking jobs but more or less for private persons (endusers) for soho solutions.


Currently there is just a simple test connfiguration on my router. My problem is mainly to work correctly with IOS. Very scalable - very good for flexibility/ustomization but more difficult to learn.


NAT should be enabled (i hope correctly).


I also looking for a way to check the dial in call (for errors). Do that not have any debug function?


I will post more my config soon. Maybe you can take a look in it (or a other person).

mhnsitnet Tue, 02/10/2009 - 08:42
User Badges:

The Currecnt Configuration is this one.


I know there isnt any acl security but only for tasteing reasons. When i got a working configuration i will work out some acl for my needs.


R1#show running-config

Building configuration...


Current configuration : 3535 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

no logging console

enable secret 5

enable password

!

no aaa new-model

!

resource policy

!

ip subnet-zero

!

!

ip cef

ip domain lookup source-interface Dialer0

ip name-server 213.191.74.12

ip name-server 62.109.92.82

vpdn enable

!

vpdn-group 1

!

!

!

crypto pki trustpoint TP-self-signed-3594655958

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3594655958

revocation-check none

rsakeypair TP-self-signed-3594655958

!

!

crypto pki certificate chain TP-self-signed-3594655958

certificate self-signed 01




username privilege 15 0 trying

!

!

!

!

!

interface Ethernet0

description $ETH-WAN$

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Ethernet2

no ip address

pppoe enable

pppoe-client dial-pool-number 1

!

interface BRI0

no ip address

shutdown

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface FastEthernet1

speed auto

full-duplex

!

interface FastEthernet2

duplex auto

speed auto

!

interface FastEthernet3

shutdown

duplex auto

speed auto

!

interface FastEthernet4

duplex auto

speed auto

!

interface Virtual-Template1

no ip address

!

interface Dialer0

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname

ppp chap password

ppp pap sent-username password 0

ppp ipcp dns request

ppp ipcp address accept

!

ip classless

ip http server

ip http authentication local

ip http secure-server

!

ip dns server

ip nat inside source list 1 interface Dialer0 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

!

control-plane

!

!

line con 0

no modem enable

line aux 0

line vty 0 4

privilege level 15

password

login local

transport input telnet ssh

!

scheduler max-task-time 5000

!

end


paolo bevilacqua Tue, 02/10/2009 - 08:43
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

If you can ping from router connection is OK.

If the PC behind the router cannot ping, you have misconfigured NAT something else.

There is no dial call in ADSL so I'm not sure what you're talking about.

mhnsitnet Tue, 02/10/2009 - 08:53
User Badges:

Hello p.bevilacqua


>There is no dial call in ADSL so I'm not sure what you're talking about.


With "dial call in ADSL" i simple mean that the c836 router should go over the external modem and use my pppoe account to login on my ISP's server. Are you now sure what i mean?


Maybe i was not able to articulate correctly in english. Sorry about it english isnt my native language.


p.s: looks NAT correclty configured for you?

paolo bevilacqua Tue, 02/10/2009 - 09:14
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You are using ethernet 2 (FA4 physically) for WAN. According to cisco, that is not supported:


http://www.cisco.com/en/US/docs/ios/12_3/12_3x/12_3xr/dmz_port.html


However, config seems ok beside lack of default route that you can do either as


int dialer 0

ppp ipcp default route


or


ip route 0.0.0.0 0.0.0.0 dialer0


You also need "ip tcp adjust-mss 1452" under inside interface.


If you want to see how the router connects a PPP level, do "debug ppp neg" and "term mon".

mhnsitnet Tue, 02/10/2009 - 10:50
User Badges:

Hello p.bevilacqua


Indeed default route was missing. If someone asked me i was sure that i set a default route.


I have no clue why its missing now. I checked the router and its running without a restart. I belief that i made sure to save running config to start up config. No idea what happends here ...


I have some additional quests maybe you find some time to answer them.


Using Ethernet 2 interface for WAN is not supported (by Cisco). That means they dont support this but it should generally work!? Or are you sure that this wont work due technical limitations?


Will it be better to change int eth0 to WAN and eth2 as LAN interface?


ppp ipcp default route <-- is to get/take the default route from ISP, right?


And what means ip route 0.0.0.0 0.0.0.0 dialer0 ?


route everthing to interface dialer0 ???


Note: I added ppp ipcp default route

Can you give me an example when this both commands are needed/used at a same time? I am not sure with this ...


ETH0 also updated:


interface Ethernet0

description $ETH-WAN$

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452


I will test it out soon and i hope it works now for me. Currently i am online only with one client ^^

paolo bevilacqua Tue, 02/10/2009 - 11:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Not supported means it may work, or not.


I gave you two ways to set a default route, there is no practical difference.



mhnsitnet Tue, 02/10/2009 - 11:52
User Badges:

@all


For the first scenarios useing the internal c836 dsl modem i will try to collect more technical background informations. If anybody can give me more details about my first Post feel free to answer here.


@p.bevilacqua


The 2. way (with a external dsl modem) works now. It was simple the missing default route. Thanks for the help.

paolo bevilacqua Tue, 02/10/2009 - 12:09
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Which exact IOS do you have? An upgrade with newer FW could help connecting to ADSL2+ DSLAM.

mhnsitnet Tue, 02/10/2009 - 12:53
User Badges:

Currently its an older IOS Version:


Directory of flash:/


1 -rw- 8696576 c836-k9o3y6-mz.124-3a.bin

2 -rw- 321319 adsl_alc_firmware.bin


Do you know whether an IOS image always include an ADSL Firmware upgrade? Or are this 2 different update type's?


I also have to find out which ADSL Firmware version run on my router and what the latest one is.


Currently i have no access to c836 updates, BUT on old devices i can maybe get special file access after contact with cisco. Unsure how they handle this.

paolo bevilacqua Wed, 02/11/2009 - 12:49
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, since you already have a FW file in flash, check "show dsl interface" to know which version it is.

Latest one, 4.10.9 is accessible to everyone at: ftp://ftp.cisco.com/pub/access/800/


That is supposed to address interoperability with certain Siemens DSLAM cards, it might be your case.

mhnsitnet Wed, 02/11/2009 - 20:24
User Badges:

Hi p.bevilacqua,


Thanks for your Posting. I checked this, but i woundering my self why about the results. When i understand it right the output below say that my device use FW Version: 4.10.158. Looks newer but why is this version not on cisco's FTP?


So my ADSL Firmware is the latest!?


R1#show dsl interface atm 0

ATU-R (DS) ATU-C (US)

Modem Status: Showtime (DMTDSL_SHOWTIME)

DSL Mode: AnnexB (Standard)

ITU STD NUM: 0x01 0x01

Vendor ID: 'ALCB' 'IFTN'

Vendor Specific: 0x0000 0x7178

Vendor Country: 0x00 0xB5

Capacity Used: 98% 98%

Noise Margin: 7.0 dB 6.0 dB

Output Power: 18.5 dBm 11.0 dBm

Attenuation: 25.0 dB 20.0 dB

Defect Status: None None

Last Fail Code: None

Selftest Result: 0x00

Subfunction: 0x0B

Interrupts: 20094 (30 spurious)

Activations: 2

Init FW: ASW_init_4_10_158.bin

Operartion FW: ASW_R4_10_158.bin

SW Version: 4.10.158

FW Version: 0x1A04


Interleave Fast Interleave Fast

Speed (kbps): 5696 0 800 0

Reed-Solomon EC: 0 0 0 0

CRC Errors: 0 0 0 0

Header Errors: 0 0 0 0

Bit Errors: 0 0

BER Valid sec: 0 0

BER Invalid sec: 0 0


LOM Monitoring : Disabled


DMT Bits Per Bin

00: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

10: 0 0 0 0 0 0 0 0 0 0 0 0 0 6 7 8

20: 9 9 A A A B B B B B B B B B B B

30: A A 9 8 8 6 0 0 0 0 0 0 0 0 0 9

40: A A A B B B A 9 9 9 9 9 9 9 9 A

50: A A A A A A A A A A A A A A A 0

60: 0 A A A A A A 2 A A A A A A A A

70: A A A A 0 A A A A A A A A A A A

80: A A A A A A B A A A A A A A A A

90: A A A A A A A A A A A A A A A A

A0: A A A A A A A 6 A A A A A 9 9 9

B0: A A A 9 9 9 9 9 9 9 9 0 9 9 9 9

C0: 9 9 9 9 9 9 9 9 9 9 7 7 8 8 9 9

D0: 9 9 9 8 9 9 9 9 9 8 9 8 9 8 8 8

E0: 8 8 8 8 8 8 8 8 8 8 7 8 6 8 8 8

F0: 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0


paolo bevilacqua Thu, 02/12/2009 - 01:34
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi, you have the latest firmware, one that require a CCO account to be downloaded.


The modem is connected, you should be able to make it work.

mhnsitnet Thu, 02/19/2009 - 02:46
User Badges:

Hello,


Thank you for everyone who help'ed me with my problems. It is more or less solved.


Currently i use pppoe by useing the external dsl modem. All looks good and working. I will do some tests later (i like to find out whether the internal c836 dsl modem will work on a ADSL 2 line or not.


For now it is fine - thanks!


@p.bevilacqua do you know where i normaly find ADSL Firmware on cisco's website?

Correct Answer
paolo bevilacqua Thu, 02/19/2009 - 05:18
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Please read my reply above - you have latest firmware and the modem connects OK looking at you trace.


Just configure correctly and you can eliminate the external modem.

mhnsitnet Thu, 02/19/2009 - 05:31
User Badges:

Hi p.bevilacqua


I saw your post i am just interested where cisco place firmware updates. I know mostly updates cant be download without tec contract but its possible to check which versions are available and/or getting more details.


I will play with the internal atm0 dsl interface later :)

Actions

This Discussion