H323 trunk between two 2821s, one is cme

Unanswered Question
Feb 11th, 2009

Hello,

This is going to be tricky to explain without diagrams! This is what we want:

Box1 is a CME with extensions 3xx

Box2 is connected to global CUCM with extensions 8xx

Need to be able to dial 3xx from Box2 and 8xx from Box1. Have created dial-peers on both boxes and can dial 8xx from CME side. Phone rings but when answered there is no audio and the off-hook signal is not sent to the calling party. Same for other way round.

We've got this working between two CME boxes so sure the config is correct. The problem is we don't have access to the CUCM so would like to be able to completely ignore it when dialling 3xx from box2.

Possible?

Thanks, if further info needed please let me know.

Dave

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.7 (3 ratings)
Loading.
Paolo Bevilacqua Wed, 02/11/2009 - 04:52

1. box2 is doing IP-to-IP GW, aka CUBE, needs an IVS image and license.

2. Check if any FW or ACL between box1 and 2.

philquinney Wed, 02/11/2009 - 05:07

Hi there,

Thanks for your reply.

We're using Advanced IP Services on the gateway hosting the 8xx phones and SP Services on the CME gateway.

As for firewalls / ACL's we've double checked this too. There is nothing in the way.

Here's some more detailed configuration from GWA which we're hoping will allow us to dial 440468xx:

dial-peer voice 44046000 voip

destination-pattern 4404....

progress_ind setup enable 3

session target ipv4:10.125.151.11

no vad

Under voice-service-voip on both gateways:

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

h323

call start slow

call preserve limit-media-detection

Thanks to anyone who can help,

Phil.

Paolo Bevilacqua Wed, 02/11/2009 - 05:22

You need an IP-to-IP GW image, these are labelled with _ivs in the filename.

Also I recommend you use G.711 codec, that is not configured currently.

Nicholas Matthews Wed, 02/11/2009 - 05:41

Hi Phil,

Try taking out 'call start slow'. On the CUCM H323 gateway page, check 'Enable Inbound Fast Start'. Also uncheck 'wait for far-end H245'.

Then on your dial peers, configure:

codec transparent.

As well, configure this command:

voice service voip

h323

h225 connect-passthru

Let me know if this helps your problem. And as Paolo said, you should get onto CUBE code instead of SP services. CUBE is actually a different 'product' and is licensed separately, so it has a different IOS image.

-nick

philquinney Wed, 02/11/2009 - 06:43

Hey Nick,

Adding h225 connect-passthru has helped.

If we now call from the phone on the CME to the phone on the gateway we can pick up the call on the gateway phone. However, when we pick up the gateway phone the phone on the CME seems to get put on hold (you hear the beep-beep you get on hold).

I've tried both "codec transparent" and "codec g711ulaw", neither of which make any difference.

One error which is showing in the H323 traces is "Received event H225_EV_RELEASE while at state H225_WAIT_FOR_H245"

The fun thing here is that we can't change the fast start setting on the CallManager because we don't have access to the configuration.

Can anyone help?

Phil.

Nicholas Matthews Wed, 02/11/2009 - 06:49

Hi Phil,

Glad I could help.

I think what is happening is that you need to uncheck the 'wait for far-end h245' box.

Do you have any firewalls between the devices? Sometimes they block the H245 SYN packet.

You can also try this command:

voice service voip

h323

h245 passthru all

-nick

philquinney Wed, 02/11/2009 - 12:21

Hey Nick,

I gave the h245 passthru all a go by adding it to the configuration on both routers. Unfortunately no joy!

We'll try your first suggestion regarding the "wait for far-end h245" option. Here's hoping I can get the CM administrators to disable it.

Thanks again,

Phil.

Dave Lewis Wed, 02/11/2009 - 05:46

Thanks to everyone for their responses, it now makes sense.

Kind regards,

Dave (&Phil)

philquinney Thu, 02/12/2009 - 04:22

Hey Everyone,

We've managed to get the "Wait for Far End H.245 Terminal Capability Set" setting disabled on the CallManager, but are still having the same issue whereby the call from the phone on the CME goes on hold immediately, and then disconnects after approx 12 seconds.

I've attached some more H323 debugs from the CME gateway. Can anyone help?

Thanks to everyone,

Phil.

Attachment: 
Nicholas Matthews Thu, 02/12/2009 - 05:43

It looks like we're receiving a H245 disconnect with cause code 47.

Cause code 47 is No Resources Available.

Double check your region settings, outbound fast start codec, MTP requirements, and if you need a transcoder for this call.

hth,

nick

Actions

This Discussion