Problem with rbackup-server

Unanswered Question
Feb 11th, 2009
User Badges:

Dear Mister


I have the next configuration:


rserver host WWW-GEMINIS

ip address 10.100.5.26

probe PING

probe HTTP

inservice

rserver host WWW-NOVA

ip address 10.100.5.5

probe PING

probe HTTP

inservice


serverfarm host WWW

rserver WWW-GEMINIS

backup-rserver WWW-NOVA

inservice

rserver WWW-NOVA

inservice standby


The ides is that when the WWW-GEMINIS is down, jump to the server WWW-NOVA. This is functioning. The problem is in when WWW-GEMINIS come back to up, WWW-NOVA still is receiving connections. WWW-NOVA remains in balancing, but the ral state is standby??


Which is my error???

Does exist another solutions???


Best Regards

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dario.didio Wed, 02/11/2009 - 07:34
User Badges:
  • Silver, 250 points or more

Are you using stickyness?


That would be the only reason it still receives connections, because for me the config looks good.

rodrigo.hernandez Wed, 02/11/2009 - 08:25
User Badges:

Yes, iam looking the rest of configuration.


I must to disable that ???


Plly disable the policy regarding stick ???


Best regards and lot of thanks.

ciscocsoc Wed, 02/11/2009 - 08:44
User Badges:
  • Silver, 250 points or more

Hi,


If you don't need the stickiness for any other reason and if NOVA is really just a backup for GEMINIS You could define two serverfarms with one rserver in each.


serverfarm host WWW-Primary

rserver WWW-GEMINIS

inservice


serverfarm host WWW-Backup

rserver WWW-NOVA

inservice


With only one server in each farm you don't need stickiness and then your loadbalance policy can look like:


policy-map type loadbalance first-match LB-POLICY

class class-default

serverfarm WWW-Primary backup WWW-Backup



HTH


Cathy

Actions

This Discussion