eBGP connection showing Idle to MPLS-aware PE

Answered Question
Feb 11th, 2009

I have a cisco 2650 connecting to an MPLS-aware PE via eBGP. The configuration is as follows:

router bgp 65512

no synchronization

bgp log-neighbor-changes

redistribute connected

neighbor 10.253.0.2 remote-as 23532

neighbor 10.253.0.2 update-source Loopback0

neighbor 10.253.0.2 next-hop-self

no auto-summary

ip route 10.253.0.2 255.255.255.255 10.105.250.1

The BGP peer is set up between the loopback on the CE to the loopback on the vrf on the PE. I am able to ping each loopback from the other's source interface. Here is the sh ip bgp neigh:

BGP neighbor is 10.253.0.2, remote AS 23532, external link

BGP version 4, remote router ID 0.0.0.0

BGP state = Idle

Last read 00:00:01, hold time is 180, keepalive interval is 60 seconds

Message statistics:

InQ depth is 0

OutQ depth is 0

Sent Rcvd

Opens: 0 0

Notifications: 0 0

Updates: 0 0

Keepalives: 0 0

Route Refresh: 0 0

Total: 0 0

Default minimum time between advertisement runs is 30 seconds

For address family: IPv4 Unicast

BGP table version 4, neighbor version 0

Index 1, Offset 0, Mask 0x2

NEXT_HOP is always this router

Sent Rcvd

Prefix activity: ---- ----

Prefixes Current: 0 0

Prefixes Total: 0 0

Implicit Withdraw: 0 0

Explicit Withdraw: 0 0

Used as bestpath: n/a 0

Used as multipath: n/a 0

Outbound Inbound

Local Policy Denied Prefixes: -------- -------

Total: 0 0

Number of NLRIs in the update sent: max 0, min 0

Connections established 0; dropped 0

Last reset never

External BGP neighbor not directly connected.

No active TCP connection

It shows to be idle- yet it shouldnt. Suggestions?

I have this problem too.
0 votes
Correct Answer by Jon Marshall about 7 years 9 months ago

Greg

EBGP expects the peering address to be on a directly connected subnet. If you want to peer using the loopbacks add this to your config -

router bgp 65512

neighbor 10.253.0.2 ebgp-multihop 2

Hopefully the other end ie. the PE also has this configured.

Jon

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jon Marshall Wed, 02/11/2009 - 10:45

Greg

EBGP expects the peering address to be on a directly connected subnet. If you want to peer using the loopbacks add this to your config -

router bgp 65512

neighbor 10.253.0.2 ebgp-multihop 2

Hopefully the other end ie. the PE also has this configured.

Jon

Actions

This Discussion