CAR Issue CUCM 6.1.2.100-13

Unanswered Question
Feb 12th, 2009
User Badges:

For no apparent reason CAR has stopped working.


We tried running reports from CAR but no data is returned. We tried a manual purge of the database and this took two attempts before the process ran. When this finished we performed a "reload all call detail records". This process took nearly 7 hours to complete and we checked the event log and saw a "complete" status here.


The problem is that when we run a CDR report there is no data returned. The CDR load parameters are set for continuous loading 24/7 and load CDR only.


The CUCM cluster was rebooted yesterday and we still have the same problem.


Any thoughts?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ivillegas Wed, 02/18/2009 - 09:23
User Badges:
  • Silver, 250 points or more

Check and set the following settings:


Enterprise Parameters Configuration Page:


- CDR File Time Interval = 1

- CDR Format = CDR's will be inserted into the DB

- CDR UNC path = \\ip_address_of_pub\CDR

- Local CDR Path = c:\Program Files\Cisco\CallDetaill

- Off Cluster CDR Connection String = blank field


On Publisher and Subscribers Service Parameters>Service*=Cisco CallManager:


CDR Enabled Flag* =TRUE

CDR Log Calls with Zero Duration Flag* =FALSE

Call Diagnostics Enabled* =TRUE


- "CDR Insert service" should be running only on the Publisher. If it is active on Sub, please disable it.


- In Window services, check "Cisco CDR Analysis and Reporting Scheduler" service is running.


- STOP / START Cisco Database Layer Monitor on Subscriber and then on Publisher.

Data is absent in Reports Created by the CAR Tool:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008056bd4e.shtml


Roger Terhune Thu, 02/19/2009 - 05:39
User Badges:

Hi All

This fixed our issue with CAR, but I do not understand what the function of CDR Log Calls with Zero Duration Flag. Changing it to FALSE worked for me.


thanks


roger....



htluo Thu, 02/19/2009 - 05:49
User Badges:
  • Red, 2250 points or more

based on your description "This process took nearly 7 hours to complete", you have too many records in the CDR. This is usually caused by "Zero Duration Flag" set to true (which means all calls, including unconnected calls.


Michael

http://htluo.blogspot.com/

ansalaza Thu, 02/19/2009 - 06:23
User Badges:
  • Cisco Employee,

CDR Log Calls With Zero Duration Flag-This parameter enables or disables the logging of CDRs for calls which were never connected or which lasted less than 1 second. Cisco Unified Communications Manager logs unsuccessful calls (calls that result in reorder, such as might occur because of a forwarding directive failure or calls that attempt to go through a busy trunk) regardless of this flag setting. This represents a required field. The default value specifies False.

http://www.cisco.com/en/US/docs/voice_ip_comm/cucmbe/service/6_0_1/car/caranrpt.html#wp1037699

cg100668 Wed, 02/18/2009 - 09:59
User Badges:

Hi,

I have exactly the same issue with the same version of CUCM, 6.1.2-1000-13. I raised a TAC case this morning. The engineer will come back to me.

Will let u know.

Regards,


Chandrasen

csg-admin Thu, 02/19/2009 - 03:49
User Badges:

Thanks, I have checked these parameters, they are slightly different in 6.1 and the services are named differently too.


Chandrasen if you can post your TAC case results in the forum then this will be really helpful.


Many thanks.

cg100668 Thu, 02/19/2009 - 03:59
User Badges:

Hi,

I will post the resolution from Cisco TAC once sorted out. The TAC engineer is still working in this issue.

Regards,

Chandrasen

csg-admin Thu, 02/19/2009 - 06:35
User Badges:

I have managed to resolve my problem.


Here is what I did:-


From this guide http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a008056bd4e.shtml, telnet to the publisher and run Run sql Select max(Error_Record_Id) from car:tbl_error_id_map


Use the returned value and add 1 to this number. Now enter run sql update car:tbl_system_preferences set param_value="Number returned from first command +1"


Then I went into CAR and disabled the loader and then renenabled it for continous loading.


Then I stoped and started the CAR schedule process on the Pub, left this for 15 mins and now I have my records back.

andy_vvc2 Thu, 03/19/2009 - 07:28
User Badges:

Hi csg - sorry to highjack your thread.


We have problems getting CDR reports to work (no data is returned). Can you clarify:


CAR Scheduler should run on Pub only.

CAR Web Service should run on Pub only.

CDR Enabled Flag should be set to TRUE on all nodes.


Anything else? I have the CDR Mgmt set to 3GB, 30 day retention for now, with 1 min file writes.


Thanks!




Actions

This Discussion