ISDN BRI on Cisco 2651XM with IOS 12.3.22a

Unanswered Question
Feb 12th, 2009

Recently my company upgraded IOS on several hundred Cisco 2651XMs from 12.2.37 to 12.3.22a and we started having problems with some 50+ sites still on ISDN BRI as backup. We use dialer interface as multilink PPP logical interface. So on actual BRIs only thing configured is spids, dialer group and priority. On primary serial interface we use "backup interface dialer 0" command so when primary link goes down dialer kicks in. The problem is that when dialer kicks in only 1 B-channel stays up regardsless number of BRIs we're subscribed to. So for example if there is a site with 384k ISDN or 3 BRIs that would 6 B-channels and only one B-channel would stay up. I tried different parameters under 12.3.22a such as disabling TWAIT, chaning dialer load-thereshold, changing ppp multilink parameters with no avail. As soon as I revert that router back to 12.2.37 and perform a backup test all B-channels starts working fine. So far I tested at 8 different sites, I have Cisco TAC case open and working with an engineer and we are trying to identify a site that we can give it to Cisco Engineer for live test but before that I figured I ask you guys... I even verified the authentication on TACACS server and dialer authenticates correctly. here is a configuration....

interface Serial0/0

bandwidth 1536

backup delay 10 1

backup interface Dialer0

ip address 192.168.1.124 255.255.255.252

ip route-cache flow

max-reserved-bandwidth 100

service-policy output AMICOSA

!

... ... ...

!

interface BRI1/0

no ip address

encapsulation ppp

dialer rotary-group 0

dialer priority 4

dialer-group 1

isdn switch-type basic-ni

isdn spid1 94837648170101

isdn spid2 94837648230101

no cdp enable

!

interface BRI1/1

no ip address

encapsulation ppp

dialer rotary-group 0

dialer priority 3

dialer-group 1

isdn switch-type basic-ni

isdn spid1 94833745191101

isdn spid2 94833745118101

no cdp enable

!

!

interface Dialer0

ip address 172.16.18.124 255.0.0.0

encapsulation ppp

ip ospf network point-to-multipoint

ip ospf hello-interval 10

dialer in-band

dialer string 1888#######

dialer load-threshold 1 outbound

dialer-group 1

no cdp enable

ppp authentication chap

ppp chap password 7 ******************

ppp multilink

ppp timeout multilink link add 1

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion