outgoing caller ID - block

Unanswered Question
Feb 12th, 2009

i have to set up outgoing call for call manager 4.2.1 so that it will be shown as " private" instead of presenting their caller ID..

i am trying to set it up at gateway level in call manager

Calling Party Presentation* = restricted

However, it has no effect at all, and all calls still showing individual calling ID

any idea how can i block it?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
pemelend Thu, 02/12/2009 - 23:02

hi Rachel

That's the correct parameter to block it at GW level. If it is already restricted and CCM is still sending it something might have been save on cache. you can try restarting CCM service to refresh the change.



rachelau_2005 Wed, 02/25/2009 - 15:57


I have made some changes and now the caller ID is working fine for the calls except those call that is using call forwarding

I am using call manager 4.2.1 and I have set up "calling Line ID presentation" under the calling party transformations on route pattern level to show the outgoing calling number.

When I set it up as "default", then the outgoing caller ID show the individual outgoing caller ID correctly.

When I set it up as " private", then the outgoing caller ID would appear as Private number.

However... if I do a call forward all on a phone to a mobile number, then it will show the pilot point of the DDI block instead of the individual DID number or " private" .... any idea why this is not working for the phone if " call forward all" has been set?


I use a phone to call 90003522, then I set up call forward all to a mobile on this extension 3522 to 0423848200. then when the phone ring on my mobile, it will be showing 90003500 which is the pilot point of the DDI range. no matter what setting I put in the call manager under the "calling Line ID presentation" , its still showing the pilot number of the DDI range.

if i call directly from the handset 3522 to my mobile, then i am able to control whether the number will be display as 90003522 or Private via the "calling Line ID presentation"

I have attached the debug here as well.. any idea?


kind regards


anatsira Wed, 08/19/2009 - 04:34

Hi Rachel,

Did you find why the pilot point of your DDI range was shown when you setup a call forward all?



rachelau_2005 Wed, 08/19/2009 - 21:33

Hi Alban

yes, the problem was on the ISP's side.. the circuit didnt support the CLID... and we have to upgrade our circuit to the type that support the caller ID feature..


kind regards



This Discussion