CCA 1.9 java.lang.NullPointerException

Unanswered Question
Feb 12th, 2009

Hi There,

Recently installed the newest release pack and also CCA 1.9 to test it out. Have quickly hit an error when opening Telephony --> Voice.

While its downloading and interpreting the config, the attached error occurs.

Hitting ok on the error means it sits there and continues reading the user parameters but it never finishes. Only leaving the option to cancel in the window behind it.

Any ideas whats causing this, and/or if there is any way to determine what part of the config its falling over on.

Thanks in advance :)

Andrew

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
philcisco2 Fri, 02/13/2009 - 10:09

I got the same error, i have to reset my UC back to the factory default via the CLI to get around this problem.

Andrew Hurl Fri, 02/13/2009 - 14:41

Hi There,

Thanks for the feedback.

Yes we are running a supported version of Java.

This particular UC is not a new configuration, in fact, it was one of the first UC multi-site configurations implemented in Australia, NSW atleast, and has many custom dial peers (as there was no dial pattern configs in CCA for us), site to site VPN's and SIP tunnels between UC's.  The same error also occurs when accessing our own internal UC which was a config almost entirely put together by hand as the first CCA versions, in my opinion expecially for the AU market, were counter productive.

So at this stage CCA can still only interpret its own configurations, if we use CLI for anything complex (which, to date has included every deployment we have done) its not going to work very well in CCA? Its beneficial for a simple geenfield site but not to pickup existing ones?

Don't get me wrong, we appreciate the improvements in this release, but I've always found CCA doesn't quiet get there for our configurations and we have always had to move back to trusty CLI to achieve the best results.

Many Thanks,

Andrew Hurl

Marcos Hernandez Fri, 02/13/2009 - 15:37

Andrew,

I am afraid that your system may have reached a "point of no return", unless you are willing to re-install (and that seems to be off the table).

CCA has added major improvements over the last couple of releases, and there are many more in the pipeline. However, quite candidly, systems out there that were configured using CLI may prove a challenge if what you want is to reconcile the two worlds. I wish I could share more options, but there aren't any (other than start from scratch).

In the future, and if CLI is absolutely mandatory, you can use the CCA 1.8 Out of Band Guidelines. A update for 1.9 will be available shortly:

https://www.myciscocommunity.com/docs/DOC-1517

Thanks,

Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Andrew Hurl Fri, 02/13/2009 - 15:59

Hi Marcos,

Thought that would be the case.  I wasn't across the Out of Band but will certainly investigate that in more detail.

Unfortunately some of these systems have been in production >12 months and it wouldn't be justified to re-configure from scratch. I may look at an upcoming deployment to further push the limits of CCA and see what the newer versions can do.

We are working with Leah and Dave on another project that will likely see our own system re-configured, following that trial I may reset our own and trial CCA on that.

Thanks for the information, and hopefully this thread will be helpful for others who face similar issues.

Kind Regards,

Andrew Hurl

eljaouhari04 Wed, 10/14/2009 - 03:14

hi

i have the same problem

please if you can tell me what do you did exactly because i don't understand your process

help me

Actions

This Discussion