SSL Certificate CSR using SH1

Unanswered Question
rdleeuw Fri, 03/27/2009 - 14:25
User Badges:

Well, I have run into the same issue. I'm trying to generate a CSR (certificate signing request) on a Cisco 2821 running IOS 12.4(15)T8 with a SHA signature because StartSSL does not accept CSR's with a MD5 signature anymore.


According to me the 'hash sha1' command within the crypto pki trustpoint should do the trick, but apparently not. The CSR that is generated is still not accepted by StartSLL claiming it is still signed with a MD5 hash.


So: How to generate a CSR with a SHA signature?

cisco.cisco728 Wed, 12/14/2011 - 12:55
User Badges:

I have run into the same situation. Did you find a solution?


Thanks

rdleeuw Fri, 12/16/2011 - 02:14
User Badges:

Not on the Cisco router itself. I ended up creating the CSR on a Windows 2008 R2 server . After receiving the certificate I exported the entire certificate chain from the server and imported it into the Cisco router, worked like a charm.


Ronald

Actions

This Discussion