7960 and Messages Button goes to a different line Unity Voice Mail

Unanswered Question


I have a 7960 with a 14 buton extension giving it 20 lines. When you press teh messages button it does not go to Voicemail for the line in the first position. If they pick up the handset and dial the Unity number (the same number in the display when they press the messaged button) it will go to the users mailbox fine. It is only when they directly push teh messages button that it dials the Unity number, but ends up somewhere else.

Any ideas why teh messages button is not defaulting to the line in the first position???

Thanks for your help


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rob.huffman Fri, 02/13/2009 - 09:07

Hi Gene,

I think you would need to change the following so that the Message Button is only associated with the Prime Line;

Service Parameters Configuration

Clusterwide Parameters (Device - Phone)

Always Use Prime Line for Voice Message - **Change from False to True**

Hope this helps!


rob.huffman Fri, 02/13/2009 - 09:39

Hey Gene,

No worries my friend :)

From CCM Admin go to>Service> Service Parameters Configuration>Callmanager Service> Scroll 1/4 of the way down the page to Clusterwide Parameters (Device - Phone)> Always Use Prime Line for Voice Message> **Set to True

Hope this helps!


Great, found it. It is set to false. If there is a cluster wide parameter to turn this on, there must be a local way to change it on each device. If not,then I would think this would not be an option. Is this true, and if so, does anyone know it.

I would hate to make a global change at this time, as it might fix this particular issue, but screw up a lot of other people.

Just wondering....thanks!!!!

rob.huffman Fri, 02/13/2009 - 11:23

Hi Gene,

Good stuff!

In CUCM 6.1(X) and above;

The Always Use Prime Line for Voice Message setting displays in the following windows in Cisco Unified Communications Manager Administration.

•System > Service Parameters (for Cisco CallManager service)

•Device > Phone

•Device > Common Phone Profile

•Device > Device Settings > Default Device Profile

•Device > Device Settings > Device Profile

Tip If you configure the Always Use Prime Line setting in the Service Parameter, Common Phone Profile, and in the Phone Configuration window, Cisco Unified Communications Manager uses the configuration from the Phone Configuration window.


Hope this helps!


I appreciate your help. Unfortunately we are using v4.1 and a lot of these granular settings are not there. I understand if you have offered all you can. I will need to put eyes on it.

The funny thing is the user states that when she picks up the handset, it goes to prime line. It is only when she presses the messages button that it goes to VM and that is not here line. I can monitor unity when she hits the message button and see what line it thinks is comoing in and go from there. She is the only user having this issue. I removed the primary line and readded and still NG. I had her reset the phone, as that expansion module may have confused itself as I have been screwing with it since yeateday. We shall see...

Thanks for the links...


rob.huffman Fri, 02/13/2009 - 13:35

Hi Gene,

Funny ...this stuff is always funny ;-)

Users will only see this behaviour with the Messages Button, when they have Shared lines (like this person with the expansion module) and when some of the Shared lines have Voicemail waiting. I think you would be safe to change the parameter we spoke of before "Always use Prime Line for VM" as most people never see this behaviour and if they do have shared lines they aren't wanting to access other users VM.

There is also a second Setting called "Always Use Prime Line" if this is set to True, the Handset will only pick up calls ringing in on the Prime Line. If it is set to False, picking up the handset will Pickup any ringing call.

In order to change this parameter, log in to the Cisco CallManager Administration page and perform these steps:

From the Service menu, choose Service Parameters.

Choose Publisher CallManager Server > Cisco CallManager service.

Under the Clusterwide Parameters (Device - Phone) section, scroll down to the Always Use Prime Line parameter, choose True for this parameter, and click Update.

Note: The default value for the Always Use Prime Line parameter is False. If the flag is set to True, when the phone goes off-hook or the speaker button is pressed, then the primary line is chosen and becomes the active line. If a call comes in on the second line of a user, going off-hook makes only the first line active. In this case, the user must select the second line in order to answer the call. If the flag is set to False, the phone automatically chooses a line as the active line based on the line status.

From this doc;


Hope this helps!


rob.huffman Fri, 02/13/2009 - 15:46

Hey Gene,

You are always welcome my friend! Glad to be of some small assistance.




This Discussion