Route Pattern goes fast busy but DNA Shows valid

Unanswered Question
Feb 13th, 2009


We're currently running CCM 4.2.3 and have a strange problem. When our system was first setup, there were no class of service partitions created so everyone was allowed to dial everywhere. I've been working on cleaning it up but have run into a problem. I copied all the route patterns out of our PSTN partition into the proper partition for that pattern... (IE: Local, long distance, international, etc.)

When I try to place a long distance call I get a fast busy as soon as I hit the last digit. If I change my Calling Search Space back to the origional one it works fine. I ran the dialed number analizer and it shows that the call should go through fine.

I don't understand why this isn't working. I did a debug isdn q931 on our gateway and I don't see the call come through so it it being blocked in CallManager for some reason.

Any thoughts?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Jaime Valencia Fri, 02/13/2009 - 11:46

the routing table might be still on cache memory, a CUCM detailed trace can prove what CUCM thinks is the actual data.

DNA uses the info from the DB directly

try restarting the server if the config looks right, if still no avail a CUCM trace will tell where the error is



if this helps, please rate

ecornwell Mon, 02/16/2009 - 07:57

Thanks for your help! I've had this problem before and a reboot seemed to fix it but I was wondering if there was a way to fix it without one.

I'll look through the traces.

ecornwell Mon, 02/16/2009 - 10:29

Here's what I found in the trace...

02/16/2009 10:58:02.497 CCM|Digit analysis: match(pi="1", fqcn="4194247376", cn="7376",plv="5", pss="Site-911:Site-CallPark:Site-Phones:Site2-Phones:Site:Site-IPCC:Site_Nortel-Trunk:Site-Intersite-Outbound:Site-Local:Site-LongDistance:Site-International:Site-Undefined-Ext", TodFilteredPss="Site-911:Site-CallPark:Site-Phones:Site2-Phones:Site:Site-IPCC:Site_Nortel-Trunk:Site-Intersite-Outbound:Site-Local:Site-LongDistance:Site-International:Site-Undefined-Ext", dd="918882378289",dac="0")|

02/16/2009 10:58:02.497 CCM|Digit analysis: analysis results|

02/16/2009 10:58:02.497 CCM||PretransformCallingPartyNumber=7376


















































|AlternateMatches= Information Not Available

|TranslationPatternDetails= Information Not Available|

(I cleaned up the file to not show too much information.)

It looks like it is picking 9.@ route that we block calls with over the 9.1[2-9]xx[2-9]xxxxxx route that exists in the LongDistance Calling Search Space.

Is there anyway around that or is a reboot required?

ecornwell Fri, 02/20/2009 - 13:40

I ended up deleting the 9.@ route pattern and everything started working without a reboot.


This Discussion