cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
382
Views
0
Helpful
1
Replies

Dial on demand routing between (2) 1841 Routers

matcor9925FDS
Level 1
Level 1

I'm trying to set up dial on demand routing between (2) cisco 1841 routers with PPP authentication. Both routers have a modem connected to the AUX port and both modems are connected to a POTS line. I want both routers to be able to initiate a call. Currently the modems are connecting but it appears that I'm failing PPP negotiation. Any help would be greatly appreciated. Below are running configs of both routers.

########################

ROUTER 1 RUNNING CONFIG#

########################

hostname RT108111

!

enable secret xxx

!

aaa new-model

!

aaa authentication ppp default if-needed local

!

aaa session-id common

!

multilink bundle-name authenticated

chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNE

CT \c

!

username ddr password 0 d1@lin

!

interface FastEthernet0/0

ip address 10.201.30.106 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 20

routing dynamic

!

interface Dialer10

ip address 10.201.30.82 255.255.255.252

encapsulation ppp

dialer pool 20

dialer remote-name asyncTESTserver

dialer idle-timeout 900

dialer string 2077

dialer-group 1

ppp authentication chap

!

router eigrp 65201

network 10.201.30.104 0.0.0.3

auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer10

!

access-list 101 remark define dialer traffic

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

dialer-list 2 protocol ip permit

!

line aux 0

exec-timeout 0 0

script dialer Dialout

modem InOut

modem autoconfigure type default

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

########################

ROUTER 2 RUNNING CONFIG#

########################

hostname asyncTESTserver

!

enable secret xxx/

!

aaa new-model

!

aaa authentication ppp default if-needed local

!

aaa session-id common

memory-size iomem 5

dot11 syslog

ip cef

!

multilink bundle-name authenticated

chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNE

CT \c

!

username xxx password xxx

username xxx password xxx

interface FastEthernet0/0

ip address 10.201.30.105 255.255.255.252

duplex auto

speed auto

!

interface FastEthernet0/1

ip address 10.201.30.86 255.255.255.252

duplex auto

speed auto

!

interface Async1

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 20

routing dynamic

!

interface Dialer10

ip address 10.201.30.81 255.255.255.252

encapsulation ppp

dialer pool 20

dialer remote-name RT108111

dialer idle-timeout 900

dialer-group 1

ppp authentication chap callout

!

router eigrp 65201

network 10.201.30.80 0.0.0.3

network 10.201.30.84 0.0.0.3

network 10.201.30.104 0.0.0.3

auto-summary

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 FastEthernet0/1

ip route 10.201.30.80 255.255.255.252 Dialer10

ip route 10.201.40.0 255.255.255.0 Dialer10

access-list 101 remark define dialer traffic

access-list 101 permit ip any 10.201.40.0 0.0.0.255

dialer-list 1 protocol ip list 101

line aux 0

exec-timeout 0 0

script dialer Dialout

modem InOut

modem autoconfigure type default

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

1 Reply 1

paolo bevilacqua
Hall of Fame
Hall of Fame

The async interfaces needs IP addresses or ip unnumbered, to begin with.

If still trouble, send output of debug ppp negotiation.