E1 R2 Digital

Unanswered Question
Feb 13th, 2009

I have customer in Sao Paulo, Brazil.2801 gw SRST site(CCM 4.1.3). Firstly I search for 2 days to get hold of a RJ45 to BNC, 75 Ohm, Unbalanced cable. I got the part eventually from a Cisco shop. This connects to a VWIC2-2MFT-T1/E1. Something I saw in my configs is a show controller E1 says balanced:

OSANET01# sh controller e1

E1 0/2/0 is up.

Applique type is Channelized E1 - balance

controller E1 0/2/0

framing NO-CRC4

ds0-group 0 timeslots 1-15 type r2-digital r2-compelled ani

ds0-group 1 timeslots 17-31 type r2-digital r2-compelled ani

cas-custom 0

country brazil use-defaults

metering

category 2

answer-signal group-b 1

cas-custom 1

country brazil use-defaults

metering

category 2

answer-signal group-b 1

description link to TELCO

voice-port 0/2/0:0

no vad

cptone BR

!

voice-port 0/2/0:1

no vad

cptone BR

dial-peer voice 1 pots

translation-profile incoming 5digits

destination-pattern .T

progress_ind alert enable 8

incoming called-number .T

direct-inward-dial

port 0/2/0:0

forward-digits all

!

dial-peer voice 2 pots

translation-profile incoming 5digits

destination-pattern .T

progress_ind alert enable 8

incoming called-number .T

direct-inward-dial

port 0/2/0:1

forward-digits all

!

dial-peer voice 20 voip

destination-pattern 30...

session target ipv4: X.X.X.X

incoming called-number .T

codec g711ulaw

no vad

When dialling in I get the following on my debug:

Feb 13 19:07:26.135 BRT: //47/1DE6B814804D/CCAPI/cc_api_call_disconnected:

Cause Value=16, Interface=0x654666D4, Call Id=47

Feb 13 19:07:26.135 BRT: //47/1DE6B814804D/CCAPI/cc_api_call_disconnected:

Call Entry(Responsed=FALSE, Cause Value=16, Retry Count=0)

Feb 13 19:07:26.139 BRT: //48/1DE6B814804D/CCAPI/ccCallDisconnect:

Cause Value=16, Tag=0x0, Call Entry(Previous Disconnect Cause=0, Disconnect Cause=0)

Feb 13 19:07:26.139 BRT: //48/1DE6B814804D/CCAPI/ccCallDisconnect:

Cause Value=16, Call Entry(Responsed=FALSE, Cause Value=16)

Feb 13 19:07:26.139 BRT: //48/1DE6B814804D/CCAPI/cc_api_get_transfer_info:

Transfer Number Is Null

And when dialling out, the phone ring once, and then goes engaged:

Feb 13 19:08:17.803 BRT: //49/004291911100/CCAPI/cc_api_call_disconnected:

Cause Value=47, Interface=0x64DA4504, Call Id=49

Feb 13 19:08:17.803 BRT: //49/004291911100/CCAPI/cc_api_call_disconnected:

Call Entry(Responsed=TRUE, Cause Value=47, Retry Count=0)

Feb 13 19:08:17.803 BRT: //49/004291911100/CCAPI/cc_api_get_transfer_info:

Transfer Number Is Null

Feb 13 19:08:17.803 BRT: //49/004291911100/CCAPI/ccConferenceDestroy:

Conference Id=0x6, Tag=0x0

Feb 13 19:08:17.803 BRT: //49/xxxxxxxxxxxx/CCAPI/cc_api_bridge_drop_done:

Conference Id=0x6, Source Interface=0x64DA4504, Source Call Id=49,

csim start works

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Fri, 02/13/2009 - 16:15

On dialing in:

The E1 R2 side of the circuit is disconnecting with a normal cause code. Hard to say without looking at painful E1 R2 debugs.

On dialing out:

Your H323 leg is disconnecting with no resources. Check DSP resources, transcoding, and codecs.

Good luck,

-nick

LouisKoekemoer_2 Fri, 02/13/2009 - 16:23

I just noticed a possible mistake. I see I have 2 ds0 groups. I have debug voip ccapi's which I could look through if I just knew what to look for. As you say it is just quit bulky. Could send it to you if I had your mail address:) DSP's? I have a PVDM 2-64, and a PVDM 2-32 in there. Can see what that should be an issue. I have 8 transcoding, 6 conferencing, and 250 software sessions sucessfully configured. Somethat bothers me is the fact that the cable is unbalanced, and that when I do a show controller E1, it say balanced. Could this be an issue.

Nicholas Matthews Fri, 02/13/2009 - 16:29

There's not really a 'good' spot to look. You have to know the E1 R2 signaling in order to find out who's creating the disconnect condition - which isn't any fun because there are a TON of E1 R2 variations.

debug vpm signal is the one that's going show you the state changes on the E1 R2 circuit. I don't see these circuit very often at all, so it's hard to tell you.

-nick

Paolo Bevilacqua Sun, 02/15/2009 - 10:00

which isn't any fun because there are a TON of E1 R2 variations.

True, but the good news is that in most cases, the circuits are digital/compelled, and tolerant of minor mistakes in customization. If you're interested in a couple of non-cisco docs detailing R2, let me know and I'll send these to you.

Paolo Bevilacqua Sat, 02/14/2009 - 03:49

Ola', for unbalanced E1 configure

controller E1 x/y

line-termination 75-ohm

Also remember to configure network-clock-participate and network-clock-select to give priority to this E1.

I don't think this is the cause of the problem however.

lagos Sun, 02/15/2009 - 05:49

Is your carrier Telefonica in Sao Paulo?

I would suggest using just one ds0/CAS group:

ds0-group 1 timeslots 1-15,17-31 type r2-...

I would also suggest adding this to your voice-port:

bearer-cap Speech

Good luck.

Paolo Bevilacqua Sun, 02/15/2009 - 08:22

lagos, very often E1 R2 circuits are split in two sets of channels, to ensure that outgoing and incoming calls never overlap, minimizing the possibility of glare.

Also, bearer-capability is effective on PRI circuits only. There is no bearer capability concept in E1 R2.

Actions

This Discussion