Maintaining list of allowed vlans on etherchannel

Answered Question
Feb 14th, 2009
User Badges:

Hi,


Looks like a typical trivial task, but I still can't find solution in docs.

At the beginning, I had just one link to uplink switch, then added the second one and built etherchannel. I do not undrestand how to modify list of allowed vlans so that to avoid errors. Should i have "switchport" commands on Port-Channel level or Gigabit ethernet level? Where should I apply "spanning-tree" commands?


interface Port-channel1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,6,21

switchport mode trunk

switchport nonegotiate

!

interface GigabitEthernet3/1

description link1

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,6,21

switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

!


interface GigabitEthernet4/1

description link2

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1,6,21

switchport mode trunk

switchport nonegotiate

channel-group 1 mode on

!


Thank you in advance!

Correct Answer by adamclarkuk_2 about 8 years 3 months ago

Hi


You need to apply any configuration changes to your Port-Channel interface, this will update the config on all members within that port channel.


Applying config to a single physical interface could cause it to drop out of the etherchannel.


Hope that helps.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (4 ratings)
Loading.
Correct Answer
adamclarkuk_2 Sat, 02/14/2009 - 06:48
User Badges:
  • Silver, 250 points or more

Hi


You need to apply any configuration changes to your Port-Channel interface, this will update the config on all members within that port channel.


Applying config to a single physical interface could cause it to drop out of the etherchannel.


Hope that helps.

glen.grant Sat, 02/14/2009 - 09:00
User Badges:
  • Purple, 4500 points or more

It goes on the " interface port channel" . To add vlans use "switchport trunk allowed vlan add " .

Giuseppe Larosa Sat, 02/14/2009 - 12:23
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Mihails,

once the etherchannel is up and running do changes only on the port-channel interface.


We had very bad experiences two times for someone trying to add a vlan on a member link: both times a bridging loop formed with extended out of service

The involved devices were C6500 with Sup 720 3B.

So I strongly recommend once the etherchannel is up to makes changes only on the port-channel interface

use the command suggested by Glen:

switchport trunk allowed vlan add x



Hope to help

Giuseppe



Actions

This Discussion