Problem When Upgrade Router Rommon Mode From USB

Unanswered Question
Feb 15th, 2009

Dear All,

While i was trying to upgrade the Rommon IOS via USB, I found the below error message.

Kindly advise

cisco#upgrade rom-monitor file usbflash0:

%Error: srec file read failed


Mohamed Ibrahim

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mibrahim81 Sun, 02/15/2009 - 02:49

Dear p.bevilacqua ,

Thanks for interset

But i specified the file name as shown with the same error message

Abba_Test#upgrade rom-monitor file usbflash0:C2800NM_RM2.srec.124-13r.T

%Error: srec file read failed


Mohamed Ibrahim

Paolo Bevilacqua Sun, 02/15/2009 - 02:56

Correct filename should be C2800NM_RM2.srec.124-13r.T6

Check that you file is not corrupt and try again.

mibrahim81 Sun, 02/15/2009 - 03:37

Dear p.bevilacqua ,

I downloaded this IOS from CISCO Web site and it is C2800NM_RM2.srec.124-13r.T NOT C2800NM_RM2.srec.124-13r.T6

Is there is special USB flash type dedicated for that ?


Mohamed Ibrahim

Paolo Bevilacqua Sun, 02/15/2009 - 03:45

I've verified this right now and indeed T6 is the correct filename, so check again.

You can verify that your usb stick works Ok by copying some files from/to regular flash for a test.

If still trouble, use TFTP that works all the times.

Leo Laohoo Sun, 02/15/2009 - 15:13

Nope. I upgraded my routers (1800/2800/3800) ROMmon using USB and it worked. What is the specific model of the router? Is it a 2811 or a 2821/2841?


This Discussion