RVS4000 Firmware Upgrade

Unanswered Question
Feb 15th, 2009

Recently purchased a RVS4000 Router, which included v1.1.14 firmware. Is it necessary to reset the router to Factory Default settings, after upgrading to v1.2.11, as in most of the other previous upgrades?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 0 (0 ratings)
Steven DiStefano Tue, 02/17/2009 - 05:06

For  RVS4000, we recommend a reset to factory default to get peace of  mind.

The router is a real performer though, 800Mbps advertised throughput with GE interfaces.  IPsec tunnels support (5).  Has a SIP ALG and supports VLANs and QoS.  The wireless sister WRVS4400N adds wireless N.

gregory.tompkins Sat, 07/11/2009 - 17:56

Hi,

I have never worked on this particular router until this job. I am more familiar with "true" Cisco products than with the Linksys line.

I'm woking on a job for a customer to get VPN working on his RVS4000. It was still on the original firmware and VPN wasn't working. I flashed to the newest version and now cannot connect to the WAN (Internet). I also tried the previous rev. AND reset to factory defaults - no go. This is very frustrating. My customer is saying it would have been less expensive for him to just buy a whole new router than getting this router to work as advertised. Any help would be greatly appreciated.

Thank You,

--GREG--

jarharpe Sun, 07/12/2009 - 08:26

You can call in for an RMA since the router has turn into a brick, if you are entitle. The support number that you will need to call is 1-866-606-1866. Make sure you have your serial number of the defective unit prior to calling in.

jarharpe Sun, 07/12/2009 - 08:45

Disreguard the previous reply, I responded to the comment not the orginal post. I suggest not to upgrade firmware unless you are having problems. If the unit is working LEAVE IT ALONE!

gregory.tompkins Sun, 07/12/2009 - 19:22

If you had read my original message you'd have noticed that I was having problems with VPN, thus why I went ahead with the firmware upgrade. Why would a simple firmware upgrade "brick" the router? This router is two years old and my customer has never gotten VPN to work. Is anyone from Cisco able to reply to my issue? Thank You,

--GREG--

gregory.tompkins Sun, 07/12/2009 - 22:38

The router doesn't seem bricked - it only won't connect to the Internet. I thought "bricked" meant that it was totally unresponsive. That's why I'm wondering if the upgrade added a "feature" or something that is blocking access to the Internet.

It responds normally on the LAN side of the network. I can get into the administration, etc. I'm working remotely and not at the site. I want to avoid a trip up there if possible.

Thanks everyone for all your help,

--GREG--

Te-Kai Liu Sun, 07/12/2009 - 22:50

RVS4000 firmware 1.2.11 is the best firmware so far. After firmware upgrade, please do a reset to factory default, clearing all existing settings on the router, and you should be fine. If you have WAN connection problem, please provide us the WAN connection type, the modem's model number and the firmware version on the modem. Contacting tech support to get a ticket created will also get the ball rolling faster.

BTW, what type of VPN issue were you facing?

gregory.tompkins Sun, 07/12/2009 - 23:06

Does Cisco charge for the incident if its out of warranty? I don't want this project to end up costing him more than the router's worth and he's over an hour away from me!

I think my customer has had this router for a couple of years now. He just recently needed VPN functionality and that's what I'm helping him configure. The client would go through all the steps and timing out at the very end almost like not getting a dhcp address but everything else seemed connected. The router was showing an active client but the client wouldn't connect. I tried changing the MTU to manual and set the size to 1428. I also tried from my laptop connected to an AirCard AND my home network. My customer's LAN is a 192.168.1.x configuration. My home network is 172.16.1.x and when I used my aircard it was a public IP. Anyway the VPN problem is what brought this whole firmware upgrade to light. For all I know the ISP is doing some NATting within their network to a 192.x number and that's why VPN isn't working? I don't know..... I just want to be able to get it working well enough that I can resume remotely administrating it from here.

Te-Kai Liu Sun, 07/12/2009 - 23:19

Router's warranty is 3 years.

If the RVS4000's WAN port is behind a NAT device, it's more complex to set up a VPN tunnel. The user guide of RV042 (a free download on cisco.com) has an appendix that covers IPSec NAT Traversal, whose concept could be applied to RVS4000 as well. 

gregory.tompkins Mon, 07/13/2009 - 22:55

Ok,

I had my customer run the upgrade again, then reset back to default and put in the WAN IP info. once again. Same thing, again.

So then I had him run the "rescue" utility which brought the firmware down to 1.11.11 version. He is able to get back on the net but I'm afraid VPN won't work again on this version as this is an even earlier version than before!

I contacted Cisco today and unfortunately this router is out of warranty.

Is there another product that actually works with VPN and allows firmware upgrades without rendering the router useless?

Thanks,

--GREG--

David Carr Tue, 07/14/2009 - 08:27

Hey Gregory are you trying to connect using the quickvpn utility on the router?  If that is the case make sure the block wan request is disabled on the rvs4000.  Secondly if you are using xp to connect to the router use service pack 3 with the windows firewall disabled.  If using vista, it will only work with vista 32 bit and the windows firewall has to be enabled.  If you have the private ip address set to 192.168.1.1 and are trying to connect using another device with the same private ip address of 192.168.1.1 it will not connect.  The best practice is to always change the private ip address of a vpn router to a 192.168.2.1 or something like that.  If you are trying to connect using a wireless card, like verizon or something like that there are issues with our vpn client not connecting up with router.  If your internet connection on the rvs4000 is fiber or satellite it will not connect, cause the connections on the fiber are to fast to connect and we are having issues with satellite internet.  I hope this will help you out and by the way if the 1.2.11 firmware renders it unusable try the 1.2.10 version and see if that makes the wan work.  Thank You.

gregory.tompkins Tue, 07/14/2009 - 10:40

Hi,

I already attempted the 1.2.10 firmware and it also rendered the WAN useless. With all these gotchas and the router not working I am going to recommend my customer ditch it. Whaqt product would you instead recommend?

Thank You,

--GREG--

Te-Kai Liu Tue, 07/14/2009 - 10:56

Go with RV042, which has better VPN throughput and dual WAN ports for backup or load balancing.

gregory.tompkins Tue, 07/14/2009 - 11:10

That's the one I was looking at. Are there any VPN gotchas with this one like with the RVS4000? I understand not working between two 192.168.1.x networks but what about peculiarities like having to turn off firewalls, not working with x64 O/S, etc?

Thanks for the suggestion,

--GREG--

David Carr Wed, 07/15/2009 - 06:49

The rv042 has the same vpn gotcha's as the rvs4000, but the rv042 has the pptp server which you can use with vista 64 bit, macintosh pretty much anything as long as you use the vpn client built in the pc's device.  The rv042 will support 5 pptp clients and you can use quickvpn as well to connect up clients that are not having any issues.

David Hornstein Sun, 07/26/2009 - 19:56

Hi Gregory,

Cisco does charge for incidents that are out of phone warranty.. to stop the myriad of frivolous calls that come in.

If phone support warranty has run out, this may not mean that the product warranty has run out, and as such depending on the situation, if the unit really is faulty your credit card charge will be reversed.

The Small Business Support center Engineer will ask you for a credit card, if the phone support period on your product has run out. But according to the following Service support Q&A on warranty support,  referenced in the following Cisco URL;

http://www.cisco.com/cisco/web/solutions/small_business/services/docs/Service_Support_Incident_QACustomer_0302.pdf

Question.
What if a customer purchases Out-of-Warranty Phone Support and it is determined that the customer’s issue is caused by a hardware problem covered by the Cisco Small Business product warranty?

Answer.
The customer’s credit card charges for the Out-of-Warranty Phone Support will be reversed.


You might find it useful to enable dynamic dns on the WRVS4400N, since the WAN address on your customers machine may change.  It's a free feature, and you can easily find the router on the internet, or at least find out if the WAN address of the WRVS4400N is a private or Global address.

regards Dave

gregory.tompkins Fri, 07/17/2009 - 09:33

This whole thing still doesn't seem right to me. Why would a simple firmware upgrade cuase the WAN to go awry? What, specifically, is different between the 1.1.14 version that WAS on it and the now dysfunctional 1.2.10 version? Is there a new policy or switch that disables the WAN access by default? If I can't get this to work I am going with a competitor's product or a "real" Cisco not Linksys. Is anyone fromCisco/Linksys listening?

Thanks for listening but I am losing my patience with this product,

--GREG--

Te-Kai Liu Fri, 07/17/2009 - 09:43

I was told that there is some incompatibility in the bootloaders that caused this issue, and there is a fix under testing now.

gregory.tompkins Fri, 07/17/2009 - 09:48

What is the ETA to getting this fix?

I really don't have time to wait. What is a good entry-level "CISCO" product that would suit our needs? An 1811? I don't want to spend over $1k and don't necessarily care about WiFi functionality either.

Thanks for all your help!

--GREG--

Te-Kai Liu Fri, 07/17/2009 - 10:20

According to the support policy, you would need to get a ticket number before you could receive the fix, which will wipe out all the settings on your router including the incompatibility in the bootloader that is causing the issue.

camda03123 Sat, 10/17/2009 - 21:31

The latest firmware bricked my RVS4000 as well.

The link you sent doesn't work anymore.

Do you have a current link to the rescue tool.

Thanks!

David Carr Mon, 10/19/2009 - 08:03

What do you mean by bricked it?  Do you mean it is not accessible, or that the wan port is not working?  If you can access the router I would reload the latest frimware located at this site http://tools.cisco.com/support/downloads/go/DownloadCart.x?imageGuId=EFAFDED5B5038E7B46C14C60B8AB201194313855 .

Once you do that, do a factory reset of the router and reload the configurations again.  If that does not work, I would call the SBSC at 1866-606-1866 and let them further trouble shoot with you.  Hope this helps.

Mikezyzni Fri, 01/01/2010 - 15:08

It looks like I'm having a similar problem to the previous post.  I attempted to update the firmware on my RVS4000 to RVS4000-1305.img.  The router was at factory defaults and had version 1.1.14 of the firmware on it.   The firmware upload failed at about 30% complete and the router is now flashing the power and diag light in sequence.  It looks like I need the firmware recovery tool but it's not visible when I search for it when logged in.  Maybe someone can point me to the correct location or update my account so that I have enough rights to see the link.

Thank you!

jbattist Sun, 01/03/2010 - 03:53

Mikezyzni,

   I am sorry your router failed during the upgrade.  I have searched the site for a recovery tool for the RVS4000 but I have not found one either.  At this point, if a factory reset does not get the router to get past the diagnostic light, and/or you can not access the web interface of the router to attempt to try the upgrade again, please call SBSC at 1-866-606-1866 and let them attempt to troubleshoot the issue.  Thank you.

Mikezyzni Sat, 01/09/2010 - 11:22

Thank you for the reply!  I was able to use the RVS4000 firmware rescue utility v1.2 to recover the base firmware and access the router again (couldn't reach the support folks over the holidays, very understandable).  It would be very helpful if this utility was openly posted in the same location as the firmware and QuickVPN utility. Could that be run up the management chain at Cisco to improve the self service support and save cost associated with the phone support?  

I did a good deal of trouble shooting with IE8 on my Windows XP SP3 system to try to determine the problem that I originally encountered.  It became very clear that IE8 would fail loading any version of the RVS4000 firmware at the 23% (I tested them all).  I suspected a security setting problem with IE8 so I attempted to adjust security settings to allow for the router to be in the trusted zone and minimized any security related settings that I thought might get in the way.  Unfortunately these attempts didn't prove out a solution in the time that I had left to troubleshoot before my holiday time off was over.  I then loaded the latest version of Firefox and proceeded to load the RVS4000-1305.img with no failure.   I would like to see this worked further by the Cisco Small Business experts to help others avoid the problem that I had. 

Bottom line in my testing on the issue is don't use IE8 when doing a firmware upgrade on your device.  Firefox was a safe alternative for my configuration. 

I hope my experience helps others before they have a firmware upgrade problem!

Mike

c21weinert Wed, 02/10/2010 - 07:48

Where did you get the firmware rescue tool for this router...

It's not in with the firmware & a search shows nothing...

can you post the file to a reply or send me a link or email me the file?

"K*I*S*S" to Cisco ......

(Keep it Simple Stupid) this Linksys integration sucks....

A Simple support page for the product, with links to the software/archives

that actually work is needed....Oh, Wait, Linksys already HAD that !!!!

:(

c21weinert Wed, 02/10/2010 - 08:42

Here.. help if you are stuck.

use the utility...the one for the WRVS-4400N..

so go into the downloads for this one, get the file then install it local to your system.

Disconnect all but power and a cable from port 1 (one) to your system.

Set a static address of 192.168.1.? ?=pick 2 to 253 as they will all be open and the router is on 1.

open the utility and ignore the warnings as at this point your settings are all gone & you just want it to work again.

after it's done, power cycle the router and try to connect to the admin-web-page (http://192.168.1.1) U=admin P=admin

if it works it thinks it's a wireless router,  Now, Go to the admin page & upgrade the firmware to the latest one for the correct

product (RVS4000) which is 1.3.0.5 right now. Then after you flash it, check it again & it should be working fine now.



pachermann Fri, 02/12/2010 - 07:45

here comes my question:

So what can i do if this recovery utility does not work at all.

It just tells me that it cannot scan my device and my router is still "blinking red" that he is updating firmware.

he is crashed during firmware update with mozilla 3.

what else can i do now?

thx for your help

Pascal

c21weinert Fri, 02/12/2010 - 12:56

Me too, the first time didn't work, power off the router for a few minutes, then with NOTHING connected,

plug in just power, then I held in reset, then while still holding it, powered off & then back on (still holding it)...

then when the lights "Blinked" and seemed to go normal... then I tried again...

one more note... I could only get it to work with a "Static address" on my laptop, the DHCP gave an address,

but I couldn't get it to even ping, that's why I listed that in the first post... tried to save u some time !

Unfortunately .... if you still get nothing.... it may be a very pretty paperweight ! Hope this helps !

                  Cheers & Luck !  :D

Mikezyzni Tue, 02/16/2010 - 19:53

I'm not sure why this Cisco small business product is not supported with the self help tools that had been in place previously, but I suspect this link will help a significant number of the people who have found this posting:

http://download.modem-help.co.uk/mfcs-L/LinkSys/RVS4000/Utilities/Firmware-Rescue/RVS4000-firmware-rescue-utility-v1.2.zip.php

I thought that an apeal via my post over the holidays would improve the situation but based on a quick look tonight there has been no addition of this tool that is so critical to the many technical people who maintain this product for small businesses.

http://tools.cisco.com/support/downloads/pub/Redirect.x?mdfid=282413304

I hope this helps all of you!



Mike

Te-Kai Liu Tue, 02/16/2010 - 21:57

The RVS4000 Firmware Rescue Utility v1.2 will downgrade the firmware of RVS4000 router to version 1.1.11. It's recommended that you do an additional firmware upgrade to version 1.1.14, reset to factory defaults, and then upgrade to firmware 1.2.11 or 1.3.0.5. These steps are needed to overcome the incompatibility between the bootloaders of firmware 1.1.x and 1.2.x.

Mikezyzni Wed, 02/17/2010 - 20:20

That's great information and the post of the update tool on the forum will really help others who found themselves in a bad situation like I did over the holidays!

Thank you from all of us who were concerned that our upgrade had caused us to permanently disable the router.

Mike

adam_warsaw Wed, 02/08/2012 - 04:44

Hello,

I have rvs4000 with firmware 1.1.14. Should I upgrade it to 1.2.11 and next to 1.3.3.5 or I can upgrade from 1.1.14 to the latest 1.3.3.5 without any problems? (incompatibility between the bootloaders of firmware 1.1.x and 1.2.x.)

In Cisco Small Business site there is no 1.2.11 version.

Regards

Te-Kai Liu Wed, 02/08/2012 - 07:05

If your RVS4000 is running firmware 1.1.14, you can go straight to firmware 1.3.x.

Actions

Login or Register to take actions

This Discussion

Posted February 15, 2009 at 9:05 AM
Stats:
Replies:37 Avg. Rating:
Views:50027 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard