no local directory on CIPC...

Unanswered Question
Feb 15th, 2009
User Badges:

I have setup a name in CME for specific DNs but I still don't see a local directory when I click on the phonebook button. All I see is "Missed Calls", "Received Calls" and "Placed Calls". At the bottom left it seems to be stuck on "Requesting..." Are there any useful debug commands to see what's going on?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Aaron Harrison Tue, 02/17/2009 - 03:49
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


If you take a look in the settings menu on CIPC (the phone button, not the prefs menu) you should be able to find the Directories URL. All phones have missed/received/placed in the firmware, then pull an XML list of additional, server based, directories via HTTP.


Open this URL in a web browser on your PC (IE can be funny with the XML that is returned, so try Firefox or in IE do a 'edit/view source').


If you get the XML back, then CIPC should be able to do so as well. If you get an error or no response, verify that you can reach the web page (there may be a routing issue or filter between your PC IP and the voice VLAN/CME IP address)


Please rate helpful posts...


Aaron

snickered Tue, 02/17/2009 - 06:18
User Badges:

Thanks for the reply. I can access http://ip/localdirectory fine but there is nothing there. FF says


"XML Parsing Error: no element found

Location: http://IP/localdirectory

Line Number 1, Column 1:"


When I view the source there is nothing. I turned on http debugging and got this:


Feb 17 14:13:02.228: lds_urlhook, url=/localdirectory

Feb 17 14:13:02.228: Tue, 17 Feb 2009 14:13:02 GMT 192.168.2.44 /localdirectory ok

Protocol = HTTP/1.1 Method = GET

Feb 17 14:13:02.228: If-Modified-Since = Tue, 17 Feb 2009 14:08:06 GMT


Feb 17 14:13:02.236: local_directory_search_get_action: minor = 0, uri_index =

Feb 17 14:13:02.236: ipkeyswitch_ldir_send_file 1: page 0

Feb 17 14:13:02.236: ipkeyswitch_ldir_send_file 3: to send prologue


When I go to http://IP/localdirectory/query I get some XML displayed in FF. When I access the directory on a 7960 I get the local directory without issue. I can also search and everything works correctly. So, it looks like this might be a problem with CIPC's XML parsing.

Actions

This Discussion