VOIP dial peer - redundancy not working

Unanswered Question
Feb 16th, 2009

I have a problem with two VOIP dial peers in the config below on a CUBE.

When calls come into the CUBE they are sent to CUCM via dial peer 200 and 210. DP200 is preference 1 so is always chosen. DP210 is preference 2 so this is a redundant route to another CUCM.

Here is the config:-

dial-peer voice 300 voip

description ** incoming dial peer **

rtp payload-type nse 99

rtp payload-type nte 100

session protocol sipv2

incoming called-number .

dtmf-relay rtp-nte

codec g711ulaw

fax-relay sg3-to-g3

!

dial-peer voice 400 voip

description ** SIP Trunk from SP**

destination-pattern 9T

session protocol sipv2

session target ipv4:x.x.x.x

dtmf-relay rtp-nte

codec g711ulaw

fax-relay sg3-to-g3

!

dial-peer voice 200 voip

description ** outgoing call to CUCM **

preference 1

destination-pattern 44T

monitor probe icmp-ping 10.25.0.199

rtp payload-type nse 99

rtp payload-type nte 100

session protocol sipv2

session target ipv4:10.25.0.199

dtmf-relay rtp-nte

codec g711ulaw

fax-relay sg3-to-g3

!

dial-peer voice 210 voip

description ** outgoing call to CUCM **

preference 2

destination-pattern 44T

monitor probe icmp-ping 10.25.0.11

rtp payload-type nse 99

rtp payload-type nte 100

session protocol sipv2

session target ipv4:10.25.0.11

dtmf-relay rtp-nte

codec g711ulaw

fax-relay sg3-to-g3

The problem is that when the CUCM on DP200 is not reacheable, calls to not pass over to DP210.

Here is the output of a show dial-peer voice summary:

AD PRE PASS OUT

TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT

PORT

300 voip up up 0 syst

400 voip up up 9T 0 syst ipv4:x.x.x.x

200 voip up up 44T 1 syst ipv4:10.25.0.199

210 voip up up 44T 2 syst ipv4:10.25.0.11

I though that the monitor probe icmp command would detect that the DP200 CUCM is down but it doesn't seem to detect this? (Incidentially to test this I have used a fake IP address in DP200 - it doesn't exist anywhere on my network and so is obviously down).

Any ideas?

Thanks,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Randall Poteat Thu, 08/25/2011 - 06:24

Hi Yuko.

What was the fix in this problem?  I am running into the same issue.

Thanks,

Randy

Actions

This Discussion