multicast over frame-relay issue !!

Unanswered Question
Feb 16th, 2009
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

i have simple hub and spoke tpology


the hub configured with to map statments of frame-relay point to both spoks with broadcast word


spoks has one with broadcast word for the hub other one only map the other spok and point it to the local DLCI


simple and everyone ping each other

now i run ospf over this network


and we know by defualt it is non-broadcast then i add the neighbor command on the hub point to each spoke


now evrthing works fine as well


Multicast


the hub is the RP and discovery comand entered as well

one router behind the sopks joined an igmp group


each router run pim sapre-mode and the hub in addition to that has pim nbma-mode


the problem is

everything OK every on ping the joined igmp group

ecept from the other spoke

when i ping forst packet get replay and anything after first packet NO


in the hum and the RP as well what i noticed

first ping there is outgoing interface for that spoke for the subsequent the outgoing interface shows as NULL !!!!


however when i run ospf as poin-to-multipoint works fine


with EIGRP the same issue (split-horizon disabled)


any Idea Guys !!!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (9 ratings)
Loading.
Edison Ortiz Mon, 02/16/2009 - 14:29
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Please post the output from:


show ip mroute

show ip pim rp mapping

show ip pim interface

show ip pim neigh

show ip os neigh


from the 3 routers.


__


Edison.

Marwan ALshawi Mon, 02/16/2009 - 14:42
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

hi Edison


i dont have this output now

but i can give what you looking for frothis show comands


for mroute

spoke show the outgoing interfac as the FR interface

but the issue with the hub


although it has ip pim nbma-mode

as i mention firt time with show ip mroute

the hub shows

for the sopke i ping FROM the ip address in S and the destination ijmp grup in the G

and the incoming and outgoing interfaces correct

howver fter first success ping

on the hub the outgoing interface for this spok ( the one i ping from ) the outgoing interface shown as NULL


here why i am confsed

even if i put he command ip pim spt-thrshould infinity no lck !!!


for mappping they all see the hub as the RP


becuase i did in the spoke autorp listner !!!


if you need anymore details let me know ?


but why the first packet go then the outgoing interface in the hub change to NULL ??


thanks again

Edison Ortiz Mon, 02/16/2009 - 15:00
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

I can't duplicate your problem here and it could be an underlying problem with the IGP.


Here is my lab, R1 (Hub) R2 and R3 (Spokes)


R1:


interface Serial1/0

ip address 192.168.123.1 255.255.255.0

ip pim nbma-mode

ip pim sparse-mode

encapsulation frame-relay

no ip mroute-cache

serial restart-delay 0

frame-relay map ip 192.168.123.2 102 broadcast

frame-relay map ip 192.168.123.3 301 broadcast

no clns route-cache


R2:


interface Serial1/0

ip address 192.168.123.2 255.255.255.0

ip pim sparse-mode

encapsulation frame-relay

ip ospf priority 0

serial restart-delay 0

frame-relay map ip 192.168.123.3 201

frame-relay map ip 192.168.123.1 201 broadcast

no clns route-cache


R3:


interface Serial1/0

ip address 192.168.123.3 255.255.255.0

ip pim dr-priority 0

ip pim sparse-mode

encapsulation frame-relay

ip ospf priority 0

no ip mroute-cache

serial restart-delay 0

frame-relay map ip 192.168.123.2 103

frame-relay map ip 192.168.123.1 103 broadcast

no clns route-cache

end


__________


I made sure R1 was the DR for that segment by changing the OSPF priority on the spokes.


I configured R1 with Auto-RP by using loopback and here are the mappings all routers:


PIM Group-to-RP Mappings


Group(s) 224.0.0.0/4

RP 150.1.1.1 (?), v2v1

Info source: 150.1.1.1 (?), elected via Auto-RP

Uptime: 00:39:54, expires: 00:02:49


_____


Now, I'm going to do a join on R3 and do a ping from R2..


R3(config)#int lo0

R3(config-if)#ip igmp join-group 229.3.3.3

R3(config-if)#do show ip mroute 229.3.3.3



(*, 229.3.3.3), 00:00:07/00:02:52, RP 150.1.1.1, flags: SJCL

Incoming interface: Serial1/0, RPF nbr 192.168.123.1

Outgoing interface list:

Loopback0, Forward/Sparse, 00:00:07/00:02:52


_____


Verify the join was sent to the RP:


R1#sh ip mroute 229.3.3.3



(*, 229.3.3.3), 00:01:42/00:02:47, RP 150.1.1.1, flags: S

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Serial1/0, 192.168.123.3, Forward/Sparse, 00:01:42/00:02:47


______


Ping from the other spoke:


R2#ping 229.3.3.3 repeat 10


Type escape sequence to abort.

Sending 10, 100-byte ICMP Echos to 229.3.3.3, timeout is 2 seconds:


Reply to request 0 from 192.168.123.3, 152 ms

Reply to request 1 from 192.168.123.3, 92 ms

Reply to request 2 from 192.168.123.3, 128 ms

Reply to request 3 from 192.168.123.3, 136 ms

Reply to request 4 from 192.168.123.3, 140 ms

Reply to request 5 from 192.168.123.3, 132 ms

Reply to request 6 from 192.168.123.3, 116 ms

Reply to request 7 from 192.168.123.3, 104 ms

Reply to request 8 from 192.168.123.3, 192 ms

Reply to request 9 from 192.168.123.3, 124 ms


_______


Check the hub mroute table now:


R1#sh ip mroute 229.3.3.3



(*, 229.3.3.3), 00:03:54/00:02:32, RP 150.1.1.1, flags: S

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Serial1/0, 192.168.123.3, Forward/Sparse, 00:03:54/00:02:32


(192.168.123.2, 229.3.3.3), 00:01:04/00:02:54, flags: T

Incoming interface: Serial1/0, RPF nbr 0.0.0.0

Outgoing interface list:

Serial1/0, 192.168.123.3, Forward/Sparse, 00:01:04/00:01:55


HTH,


__


Edison.




Marwan ALshawi Mon, 02/16/2009 - 15:50
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Hi Edison

first Thank you for this config i will give it try tonight

however i did the same as u did mostly except i did not put

th following command on the hub inteerface

no ip mroute-cache

dose this make deffrence ??


also for rp in the hub i did it like


int lo0

ip pim spare-mode



ip pim send-rp-announce looback 0 secope 16

ip pim send-rp-discovery loopback 0 scope 16


in addition to that

IF I DONTPUT the AUTORP LISTNER on SPOKES they will not know about the RP

becuase u know there is know dense ???!!!


let me know if something missing


as i mentioned

why it wor when i have it as ospf poin-to-multipoint

but with non-broadcast and eigrp Not ??!!!


Thanks again

Edison Ortiz Mon, 02/16/2009 - 15:56
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

however i did the same as u did mostly except i did not put

th following command on the hub inteerface

no ip mroute-cache

dose this make deffrence ??


No, I did it for the debugs.


It works the same w/o it.


IF I DONTPUT the AUTORP LISTNER on SPOKES they will not know about the RP

becuase u know there is know dense ???!!!


Correct.


let me know if something missing


Try forcing the hub to be the PIM DR as well as the OSPF DR.


as i mentioned

why it wor when i have it as ospf poin-to-multipoint

but with non-broadcast and eigrp Not ??!!!


point-to-multipoint does not use the concept of the DR and that's the reason I told you, something is wrong with the underlying IGP.


I'll check with EIGRP later on and see if I can duplicate the problem.


__


Edison.



Marwan ALshawi Mon, 02/16/2009 - 16:13
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Try forcing the hub to be the PIM DR ?


how can this be done and what is the defrence from from RP role ?



by the way sometimes they mentioned about Mapping agent MA is that means the router with the discovery command ??

which we have it in my case on the same router !!??


also if i have question say this router need t be the group maping

sometimes i see it solved as above with discovery and filltering if required HOEVEVER somtimes i see it used as BSR ??


why and how i can kno which one to use


Thanks again mate

Edison Ortiz Mon, 02/16/2009 - 16:13
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

No problems with EIGRP, see attached file.



Attachment: 
Marwan ALshawi Mon, 02/16/2009 - 16:18
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

i will try it tonight :)


by the way why u did used

neighbor 192.168.123.3 Serial1/0

neighbor 192.168.123.2 Serial1/0


while we done need to send roting as unicast


it should work without it right ?

Marwan ALshawi Tue, 02/17/2009 - 02:37
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Hi Edison


i have attached the router config i have tried th ething u have mentioned but no luck


R1 hub

R2 and R3 spokes

R4 just a router connected to R3 and has defualt route to R3 and i joined it to an ijmgp group for ping test


first ping from R2 go and the subsequent NOT


other routers ping normally


also if u see in router 1 the outgoing interface for R2 to the gorup i use is Null


in router 4 for all other router shows null but they can ping except R2


any idea will be helpful cause i got confused all configred ok but not luck !!


thank you



Attachment: 
Edison Ortiz Tue, 02/17/2009 - 07:08
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Unable to duplicate.


Based on your attachment, the Hub is Pruning the S,G although you have a pim nbma on the interface so it seems to be a bug.


Try with a different IOS.


Posting configs with R4 attached to R3.


HTH,


__


Edison.



Attachment: 
Marwan ALshawi Tue, 02/17/2009 - 13:19
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

hi Edison


based on my config it should work i mean the config is ok ?

because i just get confused about it


about the comment bellow from mohamed

the RPF not the issue becuase it is just simple hub and spoke

even not full meshed network

and the traffic should go R1 !!!


Thanks Edison, by the way if you think my config OK becuase as i told you only with OSPF non-broadcast and eigrp dose not work !!


do you think becuase i use GNS3 for this ?!


Thanks again

Edison Ortiz Tue, 02/17/2009 - 13:48
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

I will let Mohamed discuss his logic on RPF since I don't see any RPF problem on the topology.


As you see from my configs, EIGRP & OSPF worked identically.


BTW, my lab was also done on GNS3, using 7200 routers and 12.2(25)S15 image.


HTH,


__


Edison.

Mohamed Sobair Tue, 02/17/2009 - 03:06
User Badges:
  • Gold, 750 points or more


Marwan,


what is 225.0.0.1 represets? If you are Pinging from IGMP group assigned on router-2 interface to the Source which should be 150.x.x.x should be successful and its only a source of check.


The RPF method state the following:


If the incoming Interface for the multicast packet doesnt lead back to the source which is (R1) in your case,then the RPF fails and multicast packet is dropped.


Make sure that R1 source of the multicast packet is reachable via the same Interface of the recieved incoming multicast packet. (You will need to source the Ping from that Interface) OR you have to configure the following:


IP mroute "Source addresss" "subnet Mask" exit interface.



HTH

Mohamed

Mohamed Sobair Tue, 02/17/2009 - 14:06
User Badges:
  • Gold, 750 points or more


Edison,


The original poster has claimed that he can perform ping from all routers except R2? and I have suggested the following:


Since all routers recieved their mapping information and they have route back to the RP, then the possible cause is the Source of the ICMP packet from R2 is not the incoming interface for the multicast packet. I have also suggested him to configure Static IGMP Group on one of R2's Ethernet Interface and perform normal ping sourced from the serial Interface while making sure the outgoing interface for the ICMP packet is an RPF interface.



Another question is why Marwan is performing ping to 225.x.x.x Group from R2? what is this going to accomplish?


Mohamed

Marwan ALshawi Tue, 02/17/2009 - 14:22
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Hi Mohamed

i do this for CCIE LAB !


and if it is RPF problem then in this case i could not have been ble to get any response or reply when i ping

while i do have first packet with replay and the others failes which exclude RPF!


Edison i use the same as yours but not sure what IOS version exactly i will check tonight

by the way my config same as yours then can i consider my config right? and the logic i do my multicast over FR with NBMA is right as well ??


one more thing why u used neighbor command with eigrp without it it should work as well ??


thank you

Edison Ortiz Tue, 02/17/2009 - 15:12
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Marwan,


I tried to match your config as close as possible and I'm unable to duplicate what you are seeing.


Per your config output, you get the join:


From R3


(*, 225.1.1.1), 00:13:38/stopped, RP 150.1.1.1, flags: S

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Serial1/0, 10.1.1.3, Forward/Sparse, 00:13:12/00:02:35


Then the ip pim nbma-mode isn't doing what is supposed to do then the router prunes the S,G:


(10.1.1.2, 225.1.1.1), 00:00:05/00:02:55, flags: PT

Incoming interface: Serial1/0, RPF nbr 0.0.0.0

Outgoing interface list: Null


With my config, I get the join from R3:


(*, 225.1.1.1), 00:02:47/00:02:43, RP 150.1.1.1, flags: S

Incoming interface: Null, RPF nbr 0.0.0.0

Outgoing interface list:

Serial1/0, 192.168.123.3, Forward/Sparse, 00:02:47/00:02:43


and the nbma mode kicks in by listing S0/1 with the unicast information from each router of the link:


(192.168.123.2, 225.1.1.1), 00:01:21/00:02:45, flags: T

Incoming interface: Serial1/0, RPF nbr 0.0.0.0

Outgoing interface list:

Serial1/0, 192.168.123.3, Forward/Sparse, 00:01:21/00:01:39


As you can see, the ping is coming from R2 to R3.


________


As for the EIGRP neighbor statement, it does not factor into problem. It works the same with or without.


__


Edison.





Marwan ALshawi Tue, 02/17/2009 - 15:28
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Ok upon this

i can guess it is more IOS issue as said rather than config

becuase my config since first time sae as yours.. and with Mcast as you know there is no much config it just concepts need to be applied correctly


i think i need to change the IOS otherwise it will not work for ever becuase no way to configure it other than this way right ..!!


thanks for you help

Edison Ortiz Tue, 02/17/2009 - 16:24
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Marwan,


I have good news. I was able to duplicate your problem.


Try creating a loopback in R2.


I deleted the loopback in R2 and the hub pruned the S,G like in your lab.


Very interesting and I wonder if this is a GNS3 behavior. I don't have real routers to test right now but this is very strange.


__


Edison.

Edison Ortiz Tue, 02/17/2009 - 16:43
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Further testing...


It seems the behavior (at least on GNS3), you need to have more than one Layer3 interface in up/up state if you have the router acting as a Mcast Server.


I did the opposite and setup R2 as the Mcast client with R3 being the server.


R3 is connected to R4 so it has two Layer3 links hence there is no need for loopback.


Multicast is working fine on this scenario.


__


Edison.

Marwan ALshawi Tue, 02/17/2009 - 19:10
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Hi Edison

really interesting and strange !!!!


i will try it

by the way do i expect it in the CCIE LAB as well :)


i think this is only in gns3 because i have never seen a document or bock mentioned about this point !!


i think the copy right for this will be yours :)


thanks again i will let you know after try it

by the way i have to make this loopbackaddress Mcast enabled ??



Edison Ortiz Tue, 02/17/2009 - 21:10
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

You won't expect that kind of behavior in the CCIE lab as most routers will have multiple L3 interfaces.


The fact that we created a router with just one interface and in your case without a loopback, created the issue.


Routers aren't that good for Mcast server/client function, their function is to be Mcast routers.


No, you don't need to enable PIM on the loopback.


HTH,


__


Edison.

Marwan ALshawi Wed, 02/18/2009 - 03:23
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

actually i did what you have notced


but it was good to some extend


ping from R3 to R2 as R2 joind a group dose the ping ffrom 8 i get about 3 replyes whihc means ok but somthing wrong maybe with GNS3 !!!!


from R2 to R3 or R4 the same problem


anyway i think this is the only way to configure the Mcast over FR


thank you for your help


Marwan ALshawi Wed, 02/18/2009 - 12:49
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Hi Edison

i have somthing confused me

in multicast section


i see in internetworkexpert workbooks sometimes when the question say this router will be resposible for RP to group maping

they solved as RP agent with discovery comaand


and in others useing BSR


when i have to use BSR


thanks

Edison Ortiz Wed, 02/18/2009 - 13:07
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Why people fail in the CCIE Lab is mostly due to interpreting what is asked.


It's very hard to tell you when to choose one technology over the other without reading the whole workbook.


Often the answer is tied to another underlying technology that is part of that Lab.


Other times, the answer is there with some hints like:


Use PIM version 2.0

or

Use PIM version 1.5

or

Use PIM described on RFC 5059


Understand?


I'm afraid, you need to practice and practice. There isn't a straight answer to this type of query.


__



Edison.

Marwan ALshawi Wed, 02/18/2009 - 14:19
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Hi Edison

i agree with you

because with multicasting and IPV6 there is no alot practice i think i need to cover all posible case as i can

for example the hints you have mentioned very nice

thats why i need to know what hints should i see to use this one or that one

for example maybe the type of network effect the choice with frame-relay and ospf

we need to see what frame-relay we hav P2P or P2multipoint and so on then we can decied


i am aware aboutthat thanks


but for example i will give now somthing i am thinking about confusing HSRP solusion


there is to labs in he IE workbook

both of them asked to track the connection to the FR cloud OK


buut one of them solved with normaway which is track interface serial x/x


the other one solved in a way i liked it

lets say the 2 spokes are HSRP peeers and they have to track the connection to the FR cloud i mean the active one as above

but what they did

the created a tunnel interface between the active HSRP(spoke) and the hub router and they put the tracked interface as the tunnel

it is interesting one i tried it and worked fine


but which one rom your experince will be considered the right one ( or both works)


the question ask the same and the case mostly the same


thanks again :)

Actions

This Discussion