Cann't open/start Device Discovery

Unanswered Question
Feb 17th, 2009
User Badges:

Hi,


yesterday I installed CiscoWorks LMS3.1 and everything seemed fine. I started Device Discovery and few times I refreshed it and could see that some devices had been discovered and last time when I had refreshed I got the exception:

The server encountered an internal error () that prevented it from fulfillinf this request.

The full stack trace of the root cause is available in the Apache Tomcat/5.5.17.logs


I thought that next time when I log in and start Device Discovery everything will go fine cause in this exception I get some Read timed out. but, unfortunately I was wrong. This morning I tried to open Device Discovery page and I got the same exception.


Do you have any idea what could happened and what should I do to start device discovery?


Thx,

Jelena

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Tue, 02/17/2009 - 00:53
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Please post the NMSROOT/MDC/tomcat/logs/stdout.log.

Joe Clarke Tue, 02/17/2009 - 07:46
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Run the command:


pdterm CSDiscovery


Then see if you can view Discovery Status.

jardalic1 Tue, 02/17/2009 - 23:29
User Badges:

hi,


just to let you know that this is known bug

- CSCsq63152 HTTP Status 500 error thrown while launching Discovery screen


And it's said that after a while, the screen will be launch able with no issue.


In my case, I tried to refresh page for like 10 to 15 times and it didn't help, but restart of server did :)


Br,

Jelena

Joe Clarke Wed, 02/18/2009 - 09:36
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

The problem is actually due to a hung CSDiscovery process. When this happens, it no longer services RPC requests. The quick workaround is to shut it down. This will cause the web frontend to look at a static file to get Discovery status.

Actions

This Discussion