CDP: Disable

Unanswered Question
Feb 17th, 2009

Is it possible to disable cdp under an SVI on a Catalyst 6500 switch. tried running the command but still no sucess. CDP is globally enabled.

interface vlan 100

no cdp run

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Tshi M Tue, 02/17/2009 - 05:04

I have not tried it but isn't the command to disable cdp under an interface:

no cdp en


glen.grant Tue, 02/17/2009 - 08:17

CDP is not a layer 3 function so you would have to disable it on the port interfaces.

Leo Laohoo Tue, 02/17/2009 - 13:34

The "no cdp run" is for Global configuration only (turns off CDP to the appliance).

You can over-ride this command by going into the interface and do the "no cdp enable".

For example.

config t

no cdp run < -- Turns OFF CDP to the appliance.


interface FastEthernet 2/12

cdp enable < --- Enable CDP to this AND ONLY this interface.

Does this help?

Tshi M Tue, 02/17/2009 - 15:02

Hi Leo,

exactly my point in my posting earlier that he ought to use no cdp en under the interface.



This Discussion