Configuration Etherchannel broadcast storm-control

Unanswered Question
Feb 17th, 2009
User Badges:

Hi all!

I am configuring a 6500 series, broadcast storm-control. This feature is enabled on a port-channel and the physical interfaces.

In the documentation of Cisco, reports that this feature should not be enabled on interfaces configured as member of a group Etherchannel, if enabled the door and enter the "suspended mode".

Sometimes we have this feature enabled on a port-channel and its physical interfaces, and interfaces are in "on mode", contradicting what the document says the cisco "suspended mode". This is ok?

If taking the "broadcast storm-control" of the physical interface, the configuration of port-channel will be different from the physical interfaces, it is recommended?


Thank's!


Documentation Cisco: http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/storm.html


"When configuring the traffic storm control level, note the following information:


•You can configure traffic storm control on thw port channel interface of an EtherChannel.


•Do not configure traffic storm control on ports that are members of an EtherChannel. Configuring traffic storm control on ports that are configured as members of an EtherChannel puts the ports into a suspended state. "



Configuration Switch 6500:


switch6500#sh run int g 7/1


Building configuration...



Current configuration : 409 bytes


!


interface GigabitEthernet7/1


description *x-x-x*


switchport


switchport trunk encapsulation dot1q


switchport trunk native vlan 214


switchport trunk allowed vlan 25,31,204,206,209,214,216,217,232-235


switchport mode trunk


logging event link-status


no snmp trap link-status


mls qos trust dscp


flowcontrol send off


storm-control broadcast level 0.50


channel-group 2 mode on


end



switch6500#sh run int g 7/2


Building configuration...



Current configuration : 409 bytes


!


interface GigabitEthernet7/2


description *x-x-x*


switchport


switchport trunk encapsulation dot1q


switchport trunk native vlan 214


switchport trunk allowed vlan 25,31,204,206,209,214,216,217,232-235


switchport mode trunk


logging event link-status


no snmp trap link-status


mls qos trust dscp


flowcontrol send off


storm-control broadcast level 0.50


channel-group 2 mode on


end



switch6500#sh run int po 2


Building configuration...



Current configuration : 331 bytes


!


interface Port-channel2


description *CAT4506C_CTO - 10.32.0.54*


switchport


switchport trunk encapsulation dot1q


switchport trunk native vlan 214


switchport trunk allowed vlan 25,31,204,206,209,214,216,217,232-235


switchport mode trunk


logging event link-status


mls qos trust dscp


storm-control broadcast level 0.50


end



CTO07D-ITASRF-WD01#sh etherchannel 2 port-channel


Port-channels in the group:


----------------------



Port-channel: Po2


------------



Age of the Port-channel = 22d:08h:02m:58s


Logical slot/port = 14/2 Number of ports = 2


GC = 0x00000000 HotStandBy port = null


Port state = Port-channel Ag-Inuse


Protocol = -


Fast-switchover = disabled



Ports in the Port-channel:



Index Load Port EC state No of bits


------+------+------+------------------+-----------


0 55 Gi7/1 On 4


1 AA Gi7/2 On 4



Time since last port bundled: 4d:14h:58m:13s Gi7/2


Time since last port Un-bundled: 4d:14h:58m:22s Gi7/2



Last applied Hash Distribution Algorithm: Fixed

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
JamesLuther Tue, 02/17/2009 - 07:02
User Badges:
  • Silver, 250 points or more

Hi,


What the documentation is saying is that to apply storm control enable it on the port-channel interface. This will then apply it down to the physical interfaces.


If you try to apply this to the physical interfaces (not the port-channel) it will break the port-channel.



jrmalmeida Tue, 02/17/2009 - 11:19
User Badges:

Thank's JamesLuther. But the documentation is saying that if apply to the physical interfaces, the interface is in "suspended mode",

but the interface on my switch is in "mode on". Do you know?


Thank's!

adamclarkuk_2 Tue, 02/17/2009 - 12:13
User Badges:
  • Silver, 250 points or more

Hi


What James is saying is you must apply the the configuration to the Port-Channel interface as with any etherchannel configuration ( with the exception of the description comnmand ).

If you apply config to the physical interface, it will be suspended as the configs are out of sync. When you apply any configuration to the Port-Channel, like trunking an extra vlan, then the config is updated on all members of the channel-group.

jrmalmeida Wed, 02/18/2009 - 06:09
User Badges:

Hi Adam!


I don't understand why the ports are not into “suspended state”, compliance cisco documentation: CISCO - Do not configure traffic storm control on ports that are members of an EtherChannel. Configuring traffic storm control on ports that are configured as members of an EtherChannel puts the ports into a "suspended state".”


My switch:


SWITCH6500#sh etherchannel 2 port-channel


ocult-x-x


Index Load Port EC state No of bits


------+------+------+------------------+-----------


0 55 Gi7/1 On 4


1 AA Gi7/2 On 4



Interface Gi7/1 and Gi7/2 are in mode "on".

Interfaces Gi7/1 and Gi7/2 are configured with traffic storm, and are members of an Etherchannel Group.

Etherchannel Group is configured whit traffic storm too.


Interface Gi7/1 and Gi7/2 should be "suspended mode"?


Thank's!




blue phoenix Fri, 02/17/2017 - 04:10
User Badges:

Hi,


How did you configure your storm-control?  Did you configure it on the port-channel first?  The doc says that if you configure storm control on member ports, it will make the ports suspended because they will have a different port setting configs.  Now the result of configuring it on the port-channel, will then result to storm control configurations to be replicated on the member ports automatically.


Did you by any chance configure member ports only for storm control and the result is that the storm control configs got replicated on the port-channel and the ports remained up and in use?


Cheers,

Actions

This Discussion