UC520 and FXO Ports

Unanswered Question
Feb 17th, 2009
User Badges:

Hi,


I ran into another problem with my UC520 set-up today. External PSTN call comes in through the FXO ports successfully but when the call is completed and the caller hangs-up, the UC520 does not seem to release the PSTN line (i.e the LED on the FXO remains "on") and new external call attempt on that FXO gets a "busy" tone. I have to manually unplug the PSTN and plug it back into the UC520 for the line to become usable again. Is there a way to resolve this problem?


Thanks in advance for your help as always.


Tee

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
David Harper Tue, 02/17/2009 - 23:29
User Badges:
  • Cisco Employee,

This is what is referred to as a disconnect supervision issue.  Basically, different telephone exchanges around the world use different mechanisms to indicate when the remote telephone goes on hook, and in this case, the UC500 is not recognising whatever mechanism is being used.  In what country is this system located?  The resolution for the problem will most likely be a fairly simple configuration change, but without knowing where you are located, it is hard to say what that change is.


Cheers,

Dave.

aoyawale Wed, 02/18/2009 - 09:47
User Badges:

Hi Dave,


Thanks for your response. The setup is in Nigeria, pls advise what changes to make in the configurations. Also is there anyway to activate the login softkey on 521SG IP Phones so that users can log into their phones before making calls to their restricted destinations (local, national or international).


Thanks a million.


Tola

Saurabh Verma Fri, 02/20/2009 - 11:29
User Badges:
  • Silver, 250 points or more

Hi Tola,


Was your question answered? Did you take a look at the document that Marcos pointed out?


For your other question related to 521SG IP Phone, are you asking how to enable Extension Mobility? Please note that the CP52X IP Phones do not support Extension Mobility. For Class-of-Restrictions, using CCA, you can definitely configure appropriate level of COR for each of the IP Phone user.


Let us know if that answers your question.


Thanks,

Saurabh

enwkcarty Mon, 04/27/2009 - 12:04
User Badges:

I hate to revive an old thread, but I'm having exactly the same problem on my UC520.  I've tried every config example I could find in the documentation and nothing is working for me.


I have 3 POTS lines coming in to the FXO ports on the UC520.  When a call comes in, if the caller hangs up, the port is not being released...  green light stays active on the port & eventually the phones in my internal hunt group start ringing (but no one is there).


The POTS lines are from Embarq.  Does anyone happen to have a working configuration?


I would post my current config, but since it isn't working I don't know that it would be of any assistance.  I've tried every possible supervisory disconnect, battery reversal and timeout option listed in the docs - none of which have worked.


Could Embarq possibly have any services enabled on the line (that I'm not aware of) that are causing my problem???


Thanks.

Will

Steven Smith Mon, 04/27/2009 - 13:16
User Badges:
  • Gold, 750 points or more

You might ask Embarq if they could turn on one of the methods.  If not, I would open a TAC case if the document didn't give you very good results.

johjohn2 Mon, 04/27/2009 - 14:33
User Badges:


I have Embarq service. I ran into a similiar problem. Here's my working FXO configuration for 2 of my 4 FXO ports. Note 0/2/0 maps to IP Phone extension 205 and 0/2/1 maps to extension 301 which is an FXS port.


HTH



voice-port 0/2/0

trunk-group ALL_FXO 1

supervisory disconnect dualtone mid-call

timeouts call-disconnect 3

timeouts wait-release 3

connection plar opx immediate 205

description Configured by CCA xxx-Custom

caller-id enable

!

voice-port 0/2/1

trunk-group ALL_FXO

supervisory disconnect dualtone mid-call

timeouts call-disconnect 3

timeouts wait-release 3

connection plar opx immediate 301

description Configured by CCA Fax_Line-Custom

caller-id enable



enwkcarty Mon, 04/27/2009 - 15:23
User Badges:

Thanks for pointing out a minor detail that I'd overlooked... trunk-group.


Added that & now it's working as expected.


Thanks!!

Marcos Hernandez Mon, 04/27/2009 - 15:30
User Badges:
  • Blue, 1500 points or more

It's great to hear that it's working, but that command is only for outbound port grouping. Should not have any effect on port disconnect. I would advise that you open a TAC case when you get some time, so we can get to the bottom of this.


Thanks,


Marcos

MICHAEL JOHNSON Tue, 06/29/2010 - 23:04
User Badges:
  • Bronze, 100 points or more

To anyone reading this post and having to deal with CenturyLink (formally Embarq), I did have to open a TAC case to get the issue resolved.


Marcos' link is excellent - contained earlier in this post!


We did have to open a TAC case to help with determining the "custom cp-tone" that Centruy Link was using on this customer's phone lines. We also had to play with the input gain on each line to get the disconnect to work. The interesting thing about this issue was that incoming calls that rang an extension and were answered by an extension would disconnect as expected. It was calls being answered by the auto attend that were remaining in the off-hook state forever after a caller disconnected.


Here is the config from one of the FXO ports:


  voice-port 0/1/0
trunk-group ALL_FXO 64
supervisory disconnect dualtone mid-call
supervisory custom-cptone ru-custom
input gain 3
timeouts call-disconnect 2
timeouts wait-release 2
connection plar opx 150
caller-id enable

voice class custom-cptone ru-custom
dualtone disconnect
  frequency 478 623
  cadence 264 258


A SPECIAL THANKS to Andy Cai of Cisco TAC who worked with me for over an hour on this one!

Jonathan Hay Thu, 01/02/2014 - 14:07
User Badges:

I know this is an old thread but maybe someone will benefit in the future. I was having this issue as well with business lines into FXO interfaces. It came about when the associate set her phone to forward to her cell phone and the voice-port would never go back to on-hook. After a lot of troubleshooting with TAC, they responded that the disconnect tone was so low, the voice-card was unable to "hear" it.


I placed a call to CenturyLink and the tech stated that superviosry disconnect was not a default feature on the lines we had. This was a no-cost feature and they enabled it that day. After doing so, the calls now work as expected and go back to on-hook immediately after the call is terminated; without any custom cp-tones applied.

Actions

This Discussion