Adding Voice Translation-Rule

Unanswered Question

I have a translation rule that appears to be at its max with 15 rules. I need to add more to this and wonder how to do it.  The rule is made to point DID's to individuals extensions.  We are trying to assign a second set of DID's to each user and once I got to 15 rules inside the translation-rule it does not allow me to add.  Below are the pieces that make up the rule.


voice translation-rule 10
rule 1 /0651/ /100/
rule 2 /5151/ /101/
rule 3 /2008/ /101/
rule 4 /5200/ /102/
rule 5 /0626/ /103/
rule 6 /2024/ /104/
rule 7 /5208/ /105/
rule 8 /0659/ /106/
rule 9 /0271/ /107/
rule 10 /2025/ /111/
rule 11 /0267/ /112/
rule 12 /5168/ /116/
rule 13 /2027/ /118/
rule 14 /0699/ /800/
rule 15 /2038/ /600/

!
voice translation-profile TranslateDIDs
translate called 10

!
voice-port 0/2/0:23
translation-profile incoming TranslateDIDs
translation-profile outgoing callerid

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Wed, 02/18/2009 - 07:58
User Badges:
  • Blue, 1500 points or more

What about using secondary numbers under the DN?


!

ephone-dn 1

number 101 secondary 5556 no-reg both

!


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Marcos


Here is one of my DID DN's. I do not understand how the secondary number will relate to the new DID I want to assign


ephone-dn  34  dual-line
number 104 no-reg primary
label Kevin DID
name Kevin
call-forward busy 5104
call-forward noan 5104 timeout 20
corlist incoming user-domestic
translation-profile incoming CallBlocking


I like the thought of your idea but need more input to understand how to make it work.


Thanks,

Craig

Marcos Hernandez Thu, 02/19/2009 - 18:11
User Badges:
  • Blue, 1500 points or more

For what I saw in your config, your provider is delivering the last four digits of the full number. You currently have a translation rule that changes that into the internal extension. But since you ran our of rules, you have to either create more, which requires dial peer manipulation, or tell the system that those four digits are also a valid pattern for the DN (using the secondary command).


A great way to verify what you are getting is by enabling the following debug


debug isdn q931

term mon


Look for the field "called number" in the inbound Q931 Setup. When you are done, turn off the debugs:


undebug all

term no mon


Let me know if this helps.


Marcos

Marcos - you gave me the right answer again - number 101 secondary 2008 no-reg both was the trick.  I just didn't see it the first time I looked at it.  When I actually plugged it in the CLI it made perfect sense.  Now I can go into the 12 existing EPHON-DN's related to users DID's and add this command.


Thank you for the help.

Craig

Marcos Hernandez Thu, 02/19/2009 - 18:43
User Badges:
  • Blue, 1500 points or more

Glad to hear it worked. One last thing, for outbound calls from that DN, the primary number is used, not the secondary. So for correct CLID display, outbound digit manipulation is still needed.


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Steven Smith Wed, 02/18/2009 - 10:51
User Badges:
  • Gold, 750 points or more

You could also try putting the translation profiles on multiple dial peers.  It would require you having more dial-peers and more translation rules.


The secondary number on the ephone-dn is a very good solution as well.

Actions

This Discussion