Soho 871 routing issue.

Answered Question
Feb 17th, 2009

I have been trying to setup an 871 soho router and I am running into an issue with routing information from the lan to the wan. It will not forward the data I know I am missing something but I don't know what. This is the config I am using if anyone could take a look and let me know.

no ip domain lookup

ip dhcp pool CLIENT

network 192.168.6.0 255.255.255.0

default-router 192.168.6.1

dns-server 208.67.222.222 208.67.220.220

lease 0 2

ip dhcp pool rhondastatic

host 192.168.6.250 255.255.255.0

client-identifier 0100.1617.c7a6.ea

client-name rhonda

default-router 192.168.6.1

dns-server 208.67.222.222 208.67.220.220

ip dhcp excluded-address 192.168.6.89

ip dhcp excluded-address 192.168.6.90

ip dhcp excluded-address 192.168.6.91

ip dhcp excluded-address 192.168.6.92

ip dhcp excluded-address 192.168.6.93

ip dhcp excluded-address 192.168.6.94

ip dhcp excluded-address 192.168.6.95

ip dhcp excluded-address 192.168.6.200

ip dhcp excluded-address 192.168.6.254

ip nat inside source static tcp 192.168.6.250 5500 interface f4 5500

ip nat inside source static tcp 192.168.6.90 2203 interface f4 2203

ip nat inside source static tcp 192.168.6.89 2201 interface f4 2201

ip name-server 208.67.222.222 208.67.220.220

no ip http server

no ip http secure-server

interface Vlan1

ip address 192.168.6.1 255.255.255.0

interface FastEthernet0

description Lan Connection

switchport access vlan1

interface F4

ip address X.X.X.X 255.255.255.224

description Wan Connection

no shutdown

no cdp enable

I have this problem too.
0 votes
Correct Answer by Mark Yeates about 7 years 9 months ago

Like I said in the previous post it appears you are missing NAT. Add this to your config.

access-list 10 permit 192.168.6.0 0.0.0.255

ip nat inside source list 10 interface FastEthernet4 overload

int fa4

ip nat outside

int vlan 1

ip nat inside

If this does not resolve your issue please post the full config (minus passwords and sensitive info).

HTH,

Mark

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
foxbatreco Tue, 02/17/2009 - 21:44

The default route pointing to isp doesnt appear in the config posted..is this because its missed out or is it not configured?

if not pls configure the default route towards the isp.

Also, i would suggest avoid using the interface names when using the nat commands,like the ones u hav done for interface f4.Use the actual global ip.

Pls rate if this helps!

ssperry12 Wed, 02/18/2009 - 17:22

I tried that maybe i had it wrong.

Ip route 192.168.7.1 255.255.255.0 32.45.67.112

This is what i had at one point is this incorrect or is this accurate.

Mark Yeates Wed, 02/18/2009 - 18:26

Shawn,

You would be better off creating a default route to your ISP. Add this to your config:

ip route 0.0.0.0 0.0.0.0 32.45.67.112

and remove the above static route

no ip route 192.168.7.1 255.255.255.0 32.45.67.112

HTH,

Mark

foxbatreco Thu, 02/19/2009 - 06:41

Place a default route towards ur isp..

Ip route 0.0.0.0 0.0.0.0 32.45.67.112

HTH..

ssperry12 Thu, 02/19/2009 - 19:48

I tried the suggestions and they still would not communicate.

I setup the f4 to use a dhcp address and it would communicate to the outside when i was consoled in. But it still would not route the information to any of the devices plugged into the other ports.

I was also wondering do these 871 units come with a web interface?

Mark Yeates Thu, 02/19/2009 - 20:14

The 871 does work with SDM which is a GUI for the router (a link for it is below). If you are using a DHCP address I would use the following default route.

ip route 0.0.0.0 0.0.0.0 dhcp

If this does not help could you post the full config and we will be able to work from there.

Also it would be helpful to explain what works and what doesn't. I have a feeling it is a NAT issue based upon your last post. Hopefully you can further clarify.

http://www.cisco.com/en/US/products/sw/secursw/ps5318/index.html')">http://www.cisco.com/en/US/products/sw/secursw/ps5318/index.html

HTH,

Mark

ssperry12 Fri, 02/20/2009 - 19:02

The wan port will communicate with the external sites. and f0-3 on the unit will communicate with everything internal but if i plug in to the switch then ping Google or open dns it will not communicate.

Correct Answer
Mark Yeates Fri, 02/20/2009 - 20:20

Like I said in the previous post it appears you are missing NAT. Add this to your config.

access-list 10 permit 192.168.6.0 0.0.0.255

ip nat inside source list 10 interface FastEthernet4 overload

int fa4

ip nat outside

int vlan 1

ip nat inside

If this does not resolve your issue please post the full config (minus passwords and sensitive info).

HTH,

Mark

Actions

This Discussion