CSA 6.0 (v6.0.0.220) & Citrix Secure Access Client (4.5.2)

Unanswered Question
Feb 18th, 2009
User Badges:

Hi,

we want to start using CSA in our company and we're now in testing phase.

Everything works fine in our test environment, except when using a SSL VPN connection using the Citrix Secure Access client


As soon as the connection is made (net6vpn.exe in running processes), and you want to open an application from the start menu, or the desktop, explorer.exe crashes and the application does not start


Opening applications from commandline works fine, or from the Citrix Access Gateway interface (published apps, url's, ...) is not an issue either, but local apps fail to start


I already checked every possible rule that might be causing this (exceptions made etc).


I ran into a similar problem when googling saying McAfee HIPS has the same symptoms, but this has been solved in 4.5.2 (our current version)


Is there anybody who has experienced this same issue, apparantly there seems to be something handling the same entries which makes explorer.exe crash, when CSA is uninstalled, everything works fine

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
tsteger1 Mon, 02/23/2009 - 10:23
User Badges:
  • Red, 2250 points or more

You may need to have Citrix look in to this since they were able to fix it for McAfee HIPS.


It may be as simple as excluding net6vpn.exe from a System API rule.


This is a good place to start (and might be more than is needed). Create an application class for net6vpn.exe called "Citrix Secure Access Client"


Create a DAC control rule that triggers whenever "any application" tries to run "Citrix Secure Access Client"


Set it to take the action "add current process to application class" and add it to the dynamic application class "processes requiring kernel only protection".


Post back with results.


Tom

alken-maes Mon, 02/23/2009 - 23:01
User Badges:

Thanks for your reply Tom, I will test these things out and let you know the results


Kind regards


Christophe

Actions

This Discussion