CUPS and LCS integration, + symbol failing

Unanswered Question
Feb 18th, 2009

I have an odd problem with CUPS. I can dialing number out of the MOC/LCS client except for any number that starts with a plus. I added in th Application Dial Rule in CUCM, it replicated over to the the CUPS server ( can see it on the CLI SQL querry). In the SIP Proxy logs, it does not even show it hitting the server from LCS.

Basically, if I hit +14085551212, the phone goes off hook, and it's blanks, no digits on the screen. The SIP Proxy log shows this as well, but no + digits sent. If I free dial any other number from MOC, it works fine.

Is this a LCS issue or CUPS issue?

CUPS 6.05

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Tommer Catlin Wed, 02/18/2009 - 10:06

Shoot. LCS sends the message to take the phone off hook, but never sends the digits with the + (at least what I see in the log)

Tommer Catlin Wed, 02/18/2009 - 11:17

Is there a way to do this on the LCS side to remove the + symbol before sending it to the CUPS server?

htluo Wed, 02/18/2009 - 11:41

That is called "number normalization". Search Microsoft technet. There's should be a doc on it.


Tommer Catlin Wed, 02/18/2009 - 12:02

I see the CSTA messages, but not the INVITE messages when we try to dial with a +

Tommer Catlin Wed, 02/18/2009 - 12:06

Sorry, it was buried in the log file, I must have missed it. The customer has spaces in their e.164 numbers. So +1 650 555 1212 CUPS does not understand spaces.

Workaround.... 7.x bah!

Tommer Catlin Wed, 02/18/2009 - 12:35

Ok, so now I am stumped. I opened up CUPC to try dialing with the +, I get the same thing. So it's not LCS. Is this a bug in 6.05?

Tommer Catlin Thu, 03/26/2009 - 12:54

Yeah, i have some other posts on here about using Application Dialing Rule. Basically the plus is ignored completely. So if you do have it as a rule, it's ignored and not counted as a digit. So if you think your application rule is 12 digits because it has a + symbol, it's wrong. Its 11 digits and it starts with (1).

I think that fixed my issue, but play around with it and dont forget to restart the sync service on CUPS when you update CUCM dialing rules.

jrossouw Tue, 04/07/2009 - 02:57

I'm using CUCM6 with CUPS7 and had to create a rule that would replace +44 with 90 in order to allow UK calls from CUPC. I found that the "+" was actually counted as a digit which means that my rule only worked when it was configured as below:

Number begins +44

Number of digits 13

Digits to be removed 3 (this is to remove the +44)

Prefix 90

As you said the sync service had to be restarted but I also had to keep logging off and back on to the CUPC client after each change during testing.

BTW...I've also tested this with spaces in the number and it worked fine.


This Discussion