Problem Installing LMS 3.1 on Solris 10 (10/08)

Unanswered Question
Feb 19th, 2009

I am trying to install LMS 3.1 on to a Solaris 10 box running 10/08. I have downloaded the latest patch cluster from Sun and installed this.

When I run through the installation, I get the warning at the start of the installation about the 'correct verison of Solaris'

I have a much newer OS Installed but I am ignoring this message so I press y and the installation continues. I then select the products that I wish to install (all of them).

the install then continues and I get a list of all the products (along with the warning that DFM HP-OV adapter will not be loaded). I am then tols 'press enter to continue' I tis at this point that the installation script fails and I get the following

Press y to reselect the components or ENTER to proceed ? (y/n) [n]:

INFO: Checking dependencies

/opt/software/lms31/install/dp.sh: -classpath: not found

ERROR: no ordered.list file

=================================================================

Finished: Thu Feb 19 15:45:33 GMT 2009

=================================================================

===============- Software Installation Tool Completed -==============

=================================================================

===================- Possible Warnings/Errors Encountered -===================

WARNING: Ensure that you have installed the recommended Solaris 10 cluster patches released

WARNING: on Apr/17/07, in this server.

WARNING: If these cluster patches are not installed, please download and install them

WARNING: from http://www.sun.com/.

WARNING: Otherwise, some features of the CiscoWorks applications will not function properly.

ERROR: no ordered.list file

=====================================================================

bash-3.00#

This ordered list file seems ot be the problem. Does anyone have any suggestion on how to reslove this issue?

I have attached a complete copy of the installation script output.

Cheers

Mark

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Thu, 02/19/2009 - 15:07

It appears that you have copied the installation media to hard disk. This most likely corrupted the files. It is highly recommended you do the installation from locally mounted original DVD media.

yjdabear Thu, 02/19/2009 - 16:41

To get the benefit of having the installation DVD on the hard disk while still making the volume appear to be a mounted optical disc, I use the following method (untested/unsupported by Cisco, YMMV) which also saves the trouble of physically swapping multiple discs:

1. Mount the DVD somewhere and make an ISO image of it.

1.1 On Solaris, as root,

mkisofs -R -o /path/to/harddisk/lms_31_sol.iso /dvdrom/lms_31_sol

1.2 On Windows, I find a 52KB freeware--LCISOCreator--perfect for this task. Copy the resulting ISO image to the Sol box.

2. Create a mount point somewhere on the Solaris box:

mkdir /path/to/mountpoint/lms_31_sol_local

3. Mount the ISO image on Solaris

/usr/sbin/lofiadm -a /path/to/harddisk/lms_31_sol.iso

Note the output number after lofi, e.g.:

/dev/lofi/1

4. Mount the loopback device:

mount -F hsfs /dev/lofi/1 /path/to/mountpoint/lms_31_sol_local

5. This virtual volume can be umounted with:

umount /path/to/mountpoint/lms_31_sol_local

lofiadm -d /dev/lofi/1

If it returns "volume is busy", find what process has it occupied:

fuser -cu /path/to/mountpoint/lms_31_sol_local

Or, simply force close access to the volume:

fuser -kcu /path/to/mountpoint/lms_31_sol_local

Usually, it's a simple oversight of having the current working directory in /path/to/mountpoint/lms_31_sol_local

Of course, delete the ISO image once done with it.

Joe Clarke Thu, 02/19/2009 - 18:53

This method does work, and I have done it quite a few times to install LMS. I have also given the following recipe out to customers that absolutely must copy the media to hard disk:

cd /cdrom/cdrom0

tar -cpf . - | (cd /opt/software/lms && tar -xpf -)

While both options have worked for me, neither are recommended, and if there is a problem, TAC would insist you try from locally attached original media to rule out other issues.

markjankiewicz Fri, 02/20/2009 - 03:18

Thanks for the responses. I will try the 'old fasioned way' and load it from the original disk.

Cheers

Mark

Actions

This Discussion