[UDP fast age support for ACE Module]

Unanswered Question
Feb 19th, 2009
User Badges:

Hello,


I'm testing 2 ACE modules running A3.0.0 for DNS load balancing (UDP). We're testing this by using a DNS query generator that (always) seems to use the same UDP source port when originating these queries. At the moment, the ACE module is hardly doing any load-balancing.


It looks to me like, that because of this, the ACE believes it's the same session (connection) and doesn't really load-balance, so I started looking for a solution and found the fast-age udp feature. But, it seems this is not supported on my ACE modules. Can any one offer another solution and/or look at my config and see if there is another way to achieve load balancing in a testing environment when using a tool like the one I described?


(I put it that way because i believe in real life since queries come from different IP addresses and randomized udp ports, the ACE module will be just fine).


Thanks in advance!

c.



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ciscocsoc Thu, 02/19/2009 - 08:40
User Badges:
  • Silver, 250 points or more

Hi,


UDP fast-age is a Version 2 feature. Try upgrading. Version 1.6.3 is quite old now and there is lots of good stuff in Version 2.


HTH


Cathy

Carlos A. Silva Thu, 02/19/2009 - 08:45
User Badges:

Hi, Cathy:


So, version 3.0.0 is lower than 2.1.0?


system: Version 3.0(0)A1(6.3a) [build 3.0(0)A1(6.3a)


that means that the actual version number is taken from the last part: A1(6.3.a)?


Thanks in advance!

c.

ciscocsoc Thu, 02/19/2009 - 08:51
User Badges:
  • Silver, 250 points or more

Hi Carlos,


Correct. The 3.0(0) is really misleading. You need to start with the "A" - so you really have 1.6.3a installed.


The "show version" for V2 is slightly better -


system: Version A2(1.2) [build 3.0(0)A2(1.2)


Cathy

Actions

This Discussion