Is it possible to setup the system not to require 9 to reach PSTN?

Answered Question
Feb 19th, 2009
User Badges:

Hello-


I would like to know if it is possible to setup the system not to require 9 to reach PSTN? I saw this question on an FAQ regarding PSTN connectivity, and it was answered "You can configure the UC500 in keysystem mode, where the user can seize available FXO or T1 CAS to dial numbers directly to CO."


I have our UC500 currently configured as a keysystem, with our PSTN/FXO dial peers set up as shared-dn's on all the phones. On our old phone system, it was possible to just press a line button and begin dialing a number, or just pick up the phone and a line was automatically selected and you could being dialing (without having to dial a number).


Is it possible to do this on the UC500, and if so, how would you go about configuring it?


Thanks,


Derek

Correct Answer by David Harper about 8 years 4 months ago

If you are just picking up the handset or pressing speaker to make the call, then you are going offhook on the internal line and you do indeed need to dial 9 to reach the PSTN, even though this is a key system.  To avoid dialing 9, you need to explicitly select a CO line to place the call on by pressing the corresponding button.  When you do this, you are immediately connecting to the associated phone line, will hear dial tone coming directly from the telephone exchange, and will be able to place calls without dialing 9.


Cheers,

Dave.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Derek Thom Thu, 02/19/2009 - 13:46
User Badges:

I guess I was looking more for a way to select which shared-dn to dial directly out on, as well as being able to skip pressing 9 first.


If we have 3 shared-dn PSTN numbers, is there a way to press the button associated with it on the phone and have it immediately connect to the outside without having to dial any number?  Right now, I can press the button and that share-dn lights up and shows in use for the duration, but when it actually connects to the PSTN via an FXO line, it picks the first available FXO port. Is there a way to make a one-to-one relationship between the dn and an FXO port? And can it automatically skip the "9" and just connect to the PSTN when that button is pressed?


Still not savvy on the phone side of these things, so I may inadvertantly be asking the impossible. But, I am just comparing it to characteristics of traditional phone systems that customers have asked about, so I like to have an answer for them.


Thanks for your help!

Marcos Hernandez Thu, 02/19/2009 - 18:28
User Badges:
  • Blue, 1500 points or more

What you describe is actually the exact behavior of a key system, which we support and it is easily configured via CCA. The bad news is that you have to start your config from scratch (factory reset your UC500).


We are in the process of updating the First Look Labs, including the Key Switch System (KTS) one. The current documentation can be found on:


https://supportforums.cisco.com/docs/DOC-9618


In CCA 1.9 the screens vary slightly. If you want, I can give you an early unedited copy of these labs. You can email me at [email protected]


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Derek Thom Fri, 02/20/2009 - 11:11
User Badges:

The UC500 I am talking about was configured as a keysystem from the start, using the latest CCA of the time (1.6). I made changes to it since then with mostly the CLI. Maybe I have the buttons set up incorrectly?


Basically, I have the FXO's PLAR-ing to a dial-peer, and that dial peer has a shared-dn assigned that is configured as a button on all phones (3 outside/FXO lines total configured like this). The incoming calls ring down no problem, including rolling over when a line is busy. But, when I press a button on an outside line, I get a dial tone, but I still have to dial 9 and when it rings out, no matter line button I press, it always uses the first available line. I test this by calling my cell phone and I see the same number pop up (the first line available).


Hopefully this makes sense? I want to make sure I am setting up systems to industry best practices, so I appreciate the install/configuration guides (these weren't around back when I was doing the inital systems, so I had to kind of wing it).


I'll look through that install guide and see if I have done things right. I have a couple more installs coming up so I want to do them right from the start and offer the client all of the options available.


Thanks again for your help!


Derek

Daniel Hoffman Fri, 02/20/2009 - 14:05
User Badges:
  • Cisco Employee,

Marcos,


Is it possible to keep the system in PBX mode and use a translation rule to eliminate the need to dial 9 to access a trunk? This is for a very simple dial plan with just a couple of phones with users that disdain dialing 9 to dial a local number! :)

Marcos Hernandez Fri, 02/20/2009 - 14:16
User Badges:
  • Blue, 1500 points or more

Derek,


What you describe is not KTS, but rather PBX. The moment you need an access code to dial out of the FXO ports, the system is operating in KTS mode.


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Derek Thom Fri, 02/20/2009 - 14:37
User Badges:

So what you're saying is because I am dialing 9 to reach an outside line, I am running in KeySystem mode, correct? And what I am actually describing that I want to do can be accomplished by running in PBX mode?


Thanks,

Derek

Marcos Hernandez Fri, 02/20/2009 - 14:44
User Badges:
  • Blue, 1500 points or more

I am actually saying (or trying to say) exactly the opposite. When you dial 9, you are in PBX mode. If you want to avoid having to dial 9 while still keeping PBX mode, then refer to the link that I posted earlier on this thread.


Here is a step by step lab showing how to set up PBX mode. It is not updated (we are working hard to get updated labs soon) but they should be a good start.


https://supportforums.cisco.com/docs/DOC-9516


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

Derek Thom Fri, 02/20/2009 - 16:36
User Badges:

OK, well somewhere along the line I must have messed something up, because I originally set up the system from CCA as a keysystem. Even when I open up the CCA to view the configuration it shows it as a keysystem (under Telephony>Voice on the first screen). Yet, I still dial 9 to get out.


Any idea how to fix this via the CLI, or even what the problem could be?


Thanks,


Derek

Correct Answer
David Harper Fri, 02/20/2009 - 16:58
User Badges:
  • Cisco Employee,

If you are just picking up the handset or pressing speaker to make the call, then you are going offhook on the internal line and you do indeed need to dial 9 to reach the PSTN, even though this is a key system.  To avoid dialing 9, you need to explicitly select a CO line to place the call on by pressing the corresponding button.  When you do this, you are immediately connecting to the associated phone line, will hear dial tone coming directly from the telephone exchange, and will be able to place calls without dialing 9.


Cheers,

Dave.

Derek Thom Thu, 02/26/2009 - 10:04
User Badges:

Maybe I have the CO lines set up wrong, because even after pressing a button for a specific line, I still have to dial 9 to get out.


Can someone paste what it should look like in the running config in terms of how the buttons and FXO/dial peers, etc. should be configured to automatically reach an outside line by pressing a button?


Thanks,


Derek

Derek Thom Mon, 03/09/2009 - 10:48
User Badges:

I have read that before, and it seems to me that based on what I want to do (connect straight to PSTN by pressing a button on the phone), I will need to configure Trunk Lines. Is that correct?


I don't like the restrictions it has attached to it, so that's whay I have shyed away from that in the past.


If I were to reconfigure this from the ground up using just the CCA and configuring as a key system, would this issue be resolved? I guess I am just trying to figure out how I got to this point. I would galdy sendmy "show-run" output if you wanted to take a look.


Thanks for your help as always,


Derek

Marcos Hernandez Wed, 03/25/2009 - 14:41
User Badges:
  • Blue, 1500 points or more

Hi Derek,


Let us know if you still need help here.


Thanks,


Marcos

Derek Thom Wed, 03/25/2009 - 16:07
User Badges:

No more help required, this has been resolved (thanks for your help!).

Derek Thom Wed, 03/25/2009 - 16:11
User Badges:

Solution courtesy of Marcos:


Once you use CCA, you will see something like this on the CLI:



For each (FXO port in UC500) {


!

voice-port connection plar opx 3A10dial-peer voice xx pots description ** FXO pots dial-peer ** destination-pattern A0 port

!

ephone-dn xx

number 3A10 no-reg primary

label Line 1

trunk A0



}


The trunk lines are assigned to phone buttons the same way as any other DN – eg button 3:54. There is no particular mystery about the numbers A0 and 3A10 – they are just used to associate the DN, the dial-peer and the port. It is customary to stick one of the non-dialable DTMF digits in there somewhere to avoid accidental dialing, but it is not mandatory. It’s also a good idea to add the following config to enable hookflash for access to features provided by the telephone exchange.


!

telephony-service

fxo hook-flash



And that’s it.



I had the ephone-dn's setup as octo-line, so at first I could not use the "trunk" command, it would just "Unrecognized" from the CLI. So, removing the dn and readding it as a dual-line resolved the issue and I could create the trunk.


Basically, this whole problem occured because I did not select the "CO" check boxes in CCA. I had modified so much via the CLI, that CCA gave me an error when I tried to run it, so I couldn't make the change there. This was a long time ago when I set up the system, and had not been trained properly, so I winged it. But, having the knowledge now I am able to set up the system now no problem via the CCA.


Thanks,


Derek

Actions

This Discussion

Related Content