switchport voice vlan

Unanswered Question
Feb 19th, 2009

I am trying to configure an 881 for a remote location, the port the phone(s) (tried both a 7960 and a 7941G) is connected to will not go on the Voice VLAN, it will obtain an IP address on the data VLAN (as will the computer connected via the phone). I can ping from the data VLAN to the Voice VLAN.

Data VLAN is 1

Voice VLAN is 20

interface is currently configured as such:

interface FastEthernet0

switchport mode trunk

switchport voice vlan 20

spanning-tree portfast

I have an 871 configured the same way (as far as I can tell from looking at the confs) that works with the same phones. Any input is greatly appreciated.

Cheers

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Thu, 02/19/2009 - 15:16

Hello Matt,

I would try to add:

switchport trunk allowed vlan 1,20

note:

this config that is used on lan switches can be a solution

int fas0

switchport mode access

switchport access vlan 1

switchport voice vlan 20

Hope to help

Giuseppe

mattiqmetrix Thu, 02/19/2009 - 15:42

Thanks Giuseppe,

I tried your second suggestion with the same results when I tried adding switchport trunk allowed vlan 1,20 to the interface the console returened:

Command rejected: Bad VLAN allowed list. You have to include all default vlans,

When I issue the command show vlan-switch it shows in the list.

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0

10 VLAN0010 active Fa1, Fa3

20 VLAN0020 active Fa0, Fa2

You can see here that VLAN20 is on fa2 as well I have set the access vlan to 20 on this interface and the phone boots up on the correct VLAN and works.

Thanks for looking.

Actions

This Discussion